Bug 280022 - kcmshell crashes on close
Summary: kcmshell crashes on close
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: System Settings Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-13 13:06 UTC by m.stoeckholz
Modified: 2011-08-13 14:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.stoeckholz 2011-08-13 13:06:49 UTC
Application: kcmshell4 ()
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
i just closed the Window "settings of a window"

- Custom settings of the application:
i have the bespin style from the ubuntu mirrors installed

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Kontrollmodul (kcmshell4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fdb4cafd780 (LWP 22043))]

Thread 2 (Thread 0x7fdb4615f700 (LWP 22047)):
#0  0x00000030016d8f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003004643104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x0000003004643639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x0000003009786446 in QEventDispatcherGlib::processEvents (this=0x2396620, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x000000300975a882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x000000300975aabc in QEventLoop::exec (this=0x7fdb4615edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0000003009671924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x000000300973cc2f in QInotifyFileSystemWatcherEngine::run (this=0x23942b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x0000003009674175 in QThreadPrivate::start (arg=0x23942b0) at thread/qthread_unix.cpp:320
#9  0x0000003001e06d8c in start_thread (arg=0x7fdb4615f700) at pthread_create.c:304
#10 0x00000030016e604d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fdb4cafd780 (LWP 22043)):
[KCrash Handler]
#6  0x000000300c1af699 in QRasterWindowSurface::~QRasterWindowSurface (this=0x212ce70, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x000000300c1af719 in QRasterWindowSurface::~QRasterWindowSurface (this=0x212ce70, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#8  0x000000300c1c9cd2 in QWidgetBackingStore::~QWidgetBackingStore (this=0x2453270, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x000000300c003789 in QWidgetBackingStoreTracker::destroy (this=0x24bd460) at kernel/qwidget.cpp:210
#10 0x000000300c0038d9 in QWidgetPrivate::deleteExtra (this=0x22ec920) at kernel/qwidget.cpp:1776
#11 0x000000300c003b1c in QWidgetPrivate::~QWidgetPrivate (this=0x22ec920, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:337
#12 0x000000300c003e29 in QWidgetPrivate::~QWidgetPrivate (this=0x22ec920, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:342
#13 0x0000003009772645 in cleanup (this=0x22ec8e0, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x22ec8e0, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x22ec8e0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:818
#16 0x000000300c005f80 in QWidget::~QWidget (this=0x22ec8e0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1508
#17 0x0000003a13945077 in ~EffectWatcher (this=0x22ec8e0, __in_chrg=<value optimized out>) at ../../plasma/private/effectwatcher_p.h:31
#18 Plasma::EffectWatcher::~EffectWatcher (this=0x22ec8e0, __in_chrg=<value optimized out>) at ../../plasma/private/effectwatcher_p.h:31
#19 0x0000003a139a42cc in ~ThemePrivate (this=0x22e8770, __in_chrg=<value optimized out>) at ../../plasma/theme.cpp:127
#20 Plasma::Theme::~Theme (this=0x22e8770, __in_chrg=<value optimized out>) at ../../plasma/theme.cpp:481
#21 0x0000003a139a4727 in ~ThemeSingleton () at ../../plasma/theme.cpp:421
#22 destroy () at ../../plasma/theme.cpp:436
#23 0x0000003001639961 in __run_exit_handlers (status=0) at exit.c:78
#24 exit (status=0) at exit.c:100
#25 0x000000300161ef06 in __libc_start_main (main=0x400740 <main(int, char**)>, argc=12, ubp_av=0x7fff93e8d288, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff93e8d278) at libc-start.c:258
#26 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 261539.

Possible duplicates by query: bug 277044, bug 269671, bug 265100, bug 255081.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-08-13 14:38:34 UTC

*** This bug has been marked as a duplicate of bug 261539 ***