Bug 265100 - ...
Summary: ...
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 1.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: System Settings Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-01 17:03 UTC by Люсиен
Modified: 2011-08-13 15:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Люсиен 2011-02-01 17:03:25 UTC
Application: systemsettings (1.0)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.38-1-generic i686
Distribution: Ubuntu natty (development branch)

-- Information about the crash:
- Unusual behavior I noticed:

Another applicatin crash just before close it...

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings), signal: Segmentation fault
[Current thread is 1 (Thread 0xb770a710 (LWP 4345))]

Thread 2 (Thread 0xb1e73b70 (LWP 4347)):
#0  0x03cce29b in pthread_mutex_unlock () from /lib/libc.so.6
#1  0x066aab21 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#2  0x066ab430 in ?? () from /lib/libglib-2.0.so.0
#3  0x066ab6e4 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00873a67 in QEventDispatcherGlib::processEvents (this=0x9c6f828, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00845859 in QEventLoop::processEvents (this=0xb1e73290, flags=...) at kernel/qeventloop.cpp:149
#6  0x00845af2 in QEventLoop::exec (this=0xb1e73290, flags=...) at kernel/qeventloop.cpp:201
#7  0x0074fc08 in QThread::exec (this=0x9f069a8) at thread/qthread.cpp:490
#8  0x008276fb in QInotifyFileSystemWatcherEngine::run (this=0x9f069a8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00752689 in QThreadPrivate::start (arg=0x9f069a8) at thread/qthread_unix.cpp:285
#10 0x0253be99 in start_thread () from /lib/libpthread.so.0
#11 0x03cc05ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb770a710 (LWP 4345)):
[KCrash Handler]
#7  0x010c0baa in QRasterWindowSurface::~QRasterWindowSurface (this=0xb5a1a10, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#8  0x010c0c42 in QRasterWindowSurface::~QRasterWindowSurface (this=0xb5a1a10, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#9  0x010dc811 in QWidgetBackingStore::~QWidgetBackingStore (this=0xa12a250, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#10 0x00f02e2b in QWidgetBackingStoreTracker::destroy (this=0x9d40fd0) at kernel/qwidget.cpp:205
#11 0x00f02f81 in QWidgetPrivate::deleteExtra (this=0xb5b4210) at kernel/qwidget.cpp:1750
#12 0x00f031ae in QWidgetPrivate::~QWidgetPrivate (this=0xb5b4210, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:318
#13 0x00f034a2 in QWidgetPrivate::~QWidgetPrivate (this=0xb5b4210, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:323
#14 0x0085e8b0 in cleanup (this=0xb5b34d8, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0xb5b34d8, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0xb5b34d8, __in_chrg=<value optimized out>) at kernel/qobject.cpp:817
#17 0x00f056c9 in QWidget::~QWidget (this=0xb5b34d8, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1477
#18 0x003bc035 in ~Private (this=0xb5b34d8, __in_chrg=<value optimized out>) at ../../kdeui/util/kmanagerselection.cpp:376
#19 KSelectionWatcher::Private::~Private (this=0xb5b34d8, __in_chrg=<value optimized out>) at ../../kdeui/util/kmanagerselection.cpp:376
#20 0x003babc4 in KSelectionWatcher::~KSelectionWatcher (this=0xb5b41a8, __in_chrg=<value optimized out>) at ../../kdeui/util/kmanagerselection.cpp:419
#21 0x003bac02 in KSelectionWatcher::~KSelectionWatcher (this=0xb5b41a8, __in_chrg=<value optimized out>) at ../../kdeui/util/kmanagerselection.cpp:420
#22 0x0085a0a7 in QObjectPrivate::deleteChildren (this=0xb5ae8a8) at kernel/qobject.cpp:1957
#23 0x0085e85f in QObject::~QObject (this=0xb5afa18, __in_chrg=<value optimized out>) at kernel/qobject.cpp:945
#24 0x021d70ff in Plasma::Theme::~Theme (this=0xb5afa18, __in_chrg=<value optimized out>) at ../../plasma/theme.cpp:448
#25 0x021d748a in ~ThemeSingleton () at ../../plasma/theme.cpp:400
#26 destroy () at ../../plasma/theme.cpp:415
#27 0x020ecbab in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0x22f3830, __in_chrg=<value optimized out>) at ../../kdecore/kernel/kglobal.h:62
#28 0x03c1f8bf in ?? () from /lib/libc.so.6
#29 0x03c1f91f in exit () from /lib/libc.so.6
#30 0x03c06cee in __libc_start_main () from /lib/libc.so.6
#31 0x08050211 in _start ()

Possible duplicates by query: bug 261539, bug 255081.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-02-01 17:56:39 UTC

*** This bug has been marked as a duplicate of bug 261539 ***
Comment 2 Thomas Lübking 2011-08-13 15:20:09 UTC
Do you use the Bespin UI style?