Bug 274741 - Open plain text - errors, blank text, crush like hell
Summary: Open plain text - errors, blank text, crush like hell
Status: RESOLVED DUPLICATE of bug 160630
Alias: None
Product: ktouch
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR major with 20 votes (vote)
Target Milestone: ---
Assignee: Haavard Froeiland
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-02 12:01 UTC by Luke
Modified: 2012-07-10 15:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2011-06-02 12:01:57 UTC
Version:           unspecified (using KDE 4.6.3) 
OS:                Linux

ktouch 1.7.1

I tried to copy text from website, save as text file and open in ktouch, some text is ok but most of the time it's messed up or blank, it can even crush whole desktop 

Reproducible: Always

Steps to Reproduce:
copy text from website -> save as text file -> "open plain text file" in ktouch -> try a little while, after some time letters will be messed up, blank/invisible letters occurs or even hell on earth/crash whole desktop

Actual Results:  
letters messed up, writing area errors, invisieble/blank letters or even big ass crash

Expected Results:  
it should be like other lessons, smooth and painfree
Comment 1 Peter Ruethemann 2011-06-04 15:37:01 UTC
Hi

Can you upload a text file which leads to a crash?
Some problems are already solved for KDE 4.7 (blank text)

But I know that further work is needed but I never had a crash.
Comment 2 Luke 2011-06-04 23:07:12 UTC
hmm I tried for a second this text https://rapidshare.com/files/537528506/0-k1.txt, it caused troubles before, now I couldn't reproduce hard crush, only blank letters, I'll try more  another day, maybe it was because of some other package or so, It was couple days ago and I'm after some upgrade (Archlinux)
Comment 3 Peter Ruethemann 2011-06-05 13:31:35 UTC
Ok, let me know if you can reproduce it.

I migth be possible that some signs leads to a crash. Which browser did you use?
Comment 4 Luke 2011-06-05 23:39:19 UTC
firefox 4.0.1
Comment 5 Luke 2011-06-05 23:52:01 UTC
oh an btw, so how it's gonna be about my idea https://bugs.kde.org/show_bug.cgi?id=274743 ?? it would be AWESOME!

regards
Comment 6 Luke 2011-06-06 00:01:27 UTC
ok there is another thing in the "plain text" option - special characters like long dash, there is no way to input this from keyboard couse it has only one key looking like dash which actually is a minus sign (-)

for example text from h-online
https://rapidshare.com/files/4173713534/1.txt

so I suppose that ktouch need to accept minus sign as all kind of dashes, and maybe skip characters that can't be typed? e.g. html codes (copyright character etc)
Comment 7 Peter Ruethemann 2011-06-27 07:16:55 UTC

*** This bug has been marked as a duplicate of bug 160630 ***
Comment 8 Jekyll Wu 2012-07-10 15:29:39 UTC
*** Bug 303307 has been marked as a duplicate of this bug. ***
Comment 9 Jekyll Wu 2012-07-10 15:31:06 UTC
*** Bug 303308 has been marked as a duplicate of this bug. ***