Bug 274743 - [wish] right click menu in the browser under selected text: "open/export as ktouch lesson"
Summary: [wish] right click menu in the browser under selected text: "open/export as k...
Status: RESOLVED INTENTIONAL
Alias: None
Product: ktouch
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Haavard Froeiland
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-02 12:21 UTC by Luke
Modified: 2012-10-26 07:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2011-06-02 12:21:29 UTC
Version:           unspecified (using KDE 4.6.3) 
OS:                Linux

Hi, new feature of ktouch (open plain text file) is awesome (well almost, because it need a big bug fix https://bugs.kde.org/show_bug.cgi?id=274741) but it require a saving files, it would be great if you could just select some text anywhere (web browser preferably, and I mean not only konqueror) and right click on it and "open as lesson" in ktouch automagically :)

Reproducible: Didn't try
Comment 1 Luke 2011-07-27 16:13:07 UTC
We don't want to bloat context menu so maybe only as an option in ktouch? something like: "context menu integration" or context menu entry would be available only when ktouch is running in the background?
Comment 2 Sebastian Gottfried 2012-10-26 07:41:17 UTC
First, version 2.0.0 lost the ability to train on plain text files because of a few unresolved issues if that feature. Integrating KTouch in other application's context menu goes to far IMO. I would be definitely offended by such a feature. 

The intended workflow to train on own texts is now: create a new course in course editor > add a lesson > copy&paste the text you want to train on > start training.

The lesson text editor has some built-in Q&A tools to ensure the resulting lesson is actually passable (e.g. untypeable characters).