Bug 273684 - knetwork manager crash
Summary: knetwork manager crash
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-20 01:50 UTC by joedwards49
Modified: 2011-05-20 04:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joedwards49 2011-05-20 01:50:03 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
i  opened yast ,network devices and network settings and changed hostname of my computer. then clicked ok and crash happened.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#5  0x00000000007590f8 in ?? ()
#6  0x00007fa9e28657a9 in QMetaObject::cast(QObject*) const () from /usr/lib64/libQtCore.so.4
#7  0x00007fa9e3292a98 in qobject_cast<Knm::InterfaceConnection const*> (first=0x748740, second=0x839560) at /usr/include/QtCore/qobject.h:468
#8  activatableLessThan (first=0x748740, second=0x839560) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:185
#9  0x00007fa9e329351a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x800410, lessThan=0x7fa9e3292a20 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:351
#10 0x00007fa9e3293307 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x7582b0, activatable=0x748740)
    at /usr/include/QtCore/qalgorithms.h:187
#11 SortedActivatableList::handleAdd (this=0x7582b0, activatable=0x748740) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#12 0x00007fa9e3283f53 in ActivatableList::notifyOnAddActivatable (this=<value optimized out>, activatable=0x748740) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:99
#13 0x00007fa9e3286e21 in WirelessNetworkInterfaceActivatableProvider::networkAppeared (this=<value optimized out>, ssid=...)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:208
#14 0x00007fa9e32800d1 in WirelessNetworkInterfaceActivatableProvider::qt_metacall (this=0x742990, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcafbcfc0)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_wirelessnetworkinterfaceactivatableprovider.cpp:81
#15 0x00007fa9e2873a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#16 0x00007fa9df12c1a2 in Solid::Control::WirelessNetworkInterfaceEnvironment::networkAppeared (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/networkmanagement/build/solidcontrolfuture/moc_wirelessnetworkinterfaceenvironment.cpp:99
#17 0x00007fa9df12c678 in Solid::Control::WirelessNetworkInterfaceEnvironment::accessPointAppearedInternal (this=0x749ba0, uni=<value optimized out>)
    at /usr/src/debug/networkmanagement/solidcontrolfuture/wirelessnetworkinterfaceenvironment.cpp:113
#18 0x00007fa9df12c291 in Solid::Control::WirelessNetworkInterfaceEnvironment::qt_metacall (this=0x749ba0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcafbd140)
    at /usr/src/debug/networkmanagement/build/solidcontrolfuture/moc_wirelessnetworkinterfaceenvironment.cpp:85
#19 0x00007fa9e2873a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#20 0x00007fa9e2e0ab75 in Solid::Control::WirelessNetworkInterface::accessPointAppeared (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/wirelessnetworkinterface.moc:150
#21 0x00007fa9e2e0afe4 in Solid::Control::WirelessNetworkInterface::_k_accessPointAdded (this=0x760b70, uni=...)
    at /usr/src/debug/kdebase-workspace-4.4.4/libs/solid/control/wirelessnetworkinterface.cpp:153
#22 0x00007fa9e2e0b201 in Solid::Control::WirelessNetworkInterface::qt_metacall (this=0x760b70, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcafbd310)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/wirelessnetworkinterface.moc:115
#23 0x00007fa9e2873a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#24 0x00007fa9d8d72b45 in NMWirelessNetworkInterface::accessPointAppeared (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/moc_wirelessnetworkinterface.cpp:133
#25 0x00007fa9d8d66b35 in NMWirelessNetworkInterface::accessPointAdded (this=0x754d70, apPath=...) at /usr/src/debug/kdebase-workspace-4.4.4/solid/networkmanager-0.7/wirelessnetworkinterface.cpp:176
#26 0x00007fa9d8d72cc1 in NMWirelessNetworkInterface::qt_metacall (this=0x754d70, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcafbd490)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/moc_wirelessnetworkinterface.cpp:99
#27 0x00007fa9e2873a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#28 0x00007fa9d8d64c92 in OrgFreedesktopNetworkManagerDeviceWirelessInterface::AccessPointAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-device-wifiinterface.moc:134
#29 0x00007fa9d8d672ad in OrgFreedesktopNetworkManagerDeviceWirelessInterface::qt_metacall (this=0x64cea8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffcafbd7b0)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-device-wifiinterface.moc:91
#30 0x00007fa9e2b97188 in QDBusConnectionPrivate::deliverCall (this=0x70b890, object=0x64cea8, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#31 0x00007fa9e2ba3ecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#32 0x00007fa9e2871509 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#33 0x00007fa9e1c514d4 in QApplicationPrivate::notify_helper (this=0x65bef0, receiver=0x64cea8, e=0x75beb0) at kernel/qapplication.cpp:4302
#34 0x00007fa9e1c59aca in QApplication::notify (this=<value optimized out>, receiver=0x64cea8, e=0x75beb0) at kernel/qapplication.cpp:4185
#35 0x00007fa9e3b73c06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#36 0x00007fa9e285fe4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#37 0x00007fa9e28635ba in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#38 0x00007fa9e2888173 in ?? () from /usr/lib64/libQtCore.so.4
#39 0x00007fa9ddd22a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#40 0x00007fa9ddd23270 in ?? () from /usr/lib64/libglib-2.0.so.0
#41 0x00007fa9ddd23510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#42 0x00007fa9e288867f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#43 0x00007fa9e1cf214e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007fa9e285f292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#45 0x00007fa9e285f495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#46 0x00007fa9e286388b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#47 0x000000000040e88f in _start ()

Possible duplicates by query: bug 269092, bug 267287, bug 264185, bug 263968, bug 263827.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-05-20 04:18:03 UTC
Monolithic knetworkmanager is unmaintained, please use the plasmoid version (plasmoid-networkmanagement in OpenSuse).

*** This bug has been marked as a duplicate of bug 210878 ***