Bug 272706 - rejonq crash on close
Summary: rejonq crash on close
Status: RESOLVED DUPLICATE of bug 269490
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: 0.7.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-07 15:54 UTC by AK
Modified: 2011-05-08 23:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description AK 2011-05-07 15:54:08 UTC
Application: rekonq (0.7.0)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
close rekonq 
after visiting some pages (also pdf reading) I close rekonq and it crashes, asking me to report a bug. 

Sometimes it crashes after the main window disappears, it just reports an unclean shutdown and asks me whether I want to restore the session -- which I dont, since I closed it correctly.

The crash can be reproduced every time.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f724e993780 (LWP 3182))]

Thread 8 (Thread 0x7f72395cb700 (LWP 3183)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f724d415832 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f7248b9dd8c in start_thread (arg=0x7f72395cb700) at pthread_create.c:304
#3  0x00007f724e1ff04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f7237f9a700 (LWP 3184)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f724ddf12a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f724e10a180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f724ddf12d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f724e118254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f7248b9dd8c in start_thread (arg=0x7f7237f9a700) at pthread_create.c:304
#4  0x00007f724e1ff04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f7236a78700 (LWP 3185)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f72493b482b in wait (this=<value optimized out>, mutex=0xf32890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xf32890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f724b3740b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x101c270, th=0x11c80a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f724b376723 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf2fbc0, th=0x11c80a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f724b37673c in ThreadWeaver::WorkingHardState::applyForWork (this=0xf2fbc0, th=0x11c80a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f724b37673c in ThreadWeaver::WorkingHardState::applyForWork (this=0xf2fbc0, th=0x11c80a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f724b37553f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7236a77e20, parent=0x101c270, th=0x11c80a0) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007f724b3755cb in ThreadWeaver::Thread::run (this=0x11c80a0) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007f72493b4175 in QThreadPrivate::start (arg=0x11c80a0) at thread/qthread_unix.cpp:320
#10 0x00007f7248b9dd8c in start_thread (arg=0x7f7236a78700) at pthread_create.c:304
#11 0x00007f724e1ff04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f722ffff700 (LWP 3186)):
#0  0x00007f7248ba03c4 in __pthread_mutex_lock (mutex=0x7f723000c598) at pthread_mutex_lock.c:61
#1  0x00007f72455d4f0d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f72455d5f9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f72455d6639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f72494c6446 in QEventDispatcherGlib::processEvents (this=0x7f72300096a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f724949a882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f724949aabc in QEventLoop::exec (this=0x7f722fffedd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f72493b1924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007f724947cc2f in QInotifyFileSystemWatcherEngine::run (this=0x124dc10) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f72493b4175 in QThreadPrivate::start (arg=0x124dc10) at thread/qthread_unix.cpp:320
#10 0x00007f7248b9dd8c in start_thread (arg=0x7f722ffff700) at pthread_create.c:304
#11 0x00007f724e1ff04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f72276b3700 (LWP 3198)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f72493b482b in wait (this=<value optimized out>, mutex=0xf32890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xf32890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f724b3740b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x101c270, th=0x144cec0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f724b376723 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf2fbc0, th=0x144cec0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f724b37553f in ThreadWeaver::ThreadRunHelper::run (this=0x7f72276b2e20, parent=0x101c270, th=0x144cec0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f724b3755cb in ThreadWeaver::Thread::run (this=0x144cec0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f72493b4175 in QThreadPrivate::start (arg=0x144cec0) at thread/qthread_unix.cpp:320
#8  0x00007f7248b9dd8c in start_thread (arg=0x7f72276b3700) at pthread_create.c:304
#9  0x00007f724e1ff04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f722608b700 (LWP 3544)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f72493b482b in wait (this=<value optimized out>, mutex=0xf32890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xf32890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f724b3740b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x101c270, th=0x169a9c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f724b376723 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf2fbc0, th=0x169a9c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f724b37673c in ThreadWeaver::WorkingHardState::applyForWork (this=0xf2fbc0, th=0x169a9c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f724b37553f in ThreadWeaver::ThreadRunHelper::run (this=0x7f722608ae20, parent=0x101c270, th=0x169a9c0) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f724b3755cb in ThreadWeaver::Thread::run (this=0x169a9c0) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f72493b4175 in QThreadPrivate::start (arg=0x169a9c0) at thread/qthread_unix.cpp:320
#9  0x00007f7248b9dd8c in start_thread (arg=0x7f722608b700) at pthread_create.c:304
#10 0x00007f724e1ff04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7212da6700 (LWP 3634)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f72493b482b in wait (this=<value optimized out>, mutex=0xf32890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xf32890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f724b3740b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x101c270, th=0x2c6a5b0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f724b376723 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf2fbc0, th=0x2c6a5b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f724b37673c in ThreadWeaver::WorkingHardState::applyForWork (this=0xf2fbc0, th=0x2c6a5b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f724b37673c in ThreadWeaver::WorkingHardState::applyForWork (this=0xf2fbc0, th=0x2c6a5b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f724b37553f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7212da5e20, parent=0x101c270, th=0x2c6a5b0) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007f724b3755cb in ThreadWeaver::Thread::run (this=0x2c6a5b0) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007f72493b4175 in QThreadPrivate::start (arg=0x2c6a5b0) at thread/qthread_unix.cpp:320
#10 0x00007f7248b9dd8c in start_thread (arg=0x7f7212da6700) at pthread_create.c:304
#11 0x00007f724e1ff04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f724e993780 (LWP 3182)):
[KCrash Handler]
#6  0x00007f7249b7cfa9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x142ce00, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x00007f7249b7d029 in QRasterWindowSurface::~QRasterWindowSurface (this=0x142ce00, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#8  0x00007f7249b975e2 in QWidgetBackingStore::~QWidgetBackingStore (this=0x167d6b0, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f72499d3779 in QWidgetBackingStoreTracker::destroy (this=0x14289f0) at kernel/qwidget.cpp:210
#10 0x00007f72499d38c9 in QWidgetPrivate::deleteExtra (this=0x169f1d0) at kernel/qwidget.cpp:1776
#11 0x00007f72499d3b0c in QWidgetPrivate::~QWidgetPrivate (this=0x169f1d0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:337
#12 0x00007f7249dcde6d in ~QMenuPrivate (this=0x169f1d0, __in_chrg=<value optimized out>) at widgets/qmenu_p.h:171
#13 QMenuPrivate::~QMenuPrivate (this=0x169f1d0, __in_chrg=<value optimized out>) at widgets/qmenu_p.h:183
#14 0x00007f72494b2645 in cleanup (this=0x169da20, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x169da20, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x169da20, __in_chrg=<value optimized out>) at kernel/qobject.cpp:818
#17 0x00007f72499d5f70 in QWidget::~QWidget (this=0x169da20, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1508
#18 0x00007f724bf83119 in KMenu::~KMenu (this=0x169da20, __in_chrg=<value optimized out>) at ../../kdeui/widgets/kmenu.cpp:167
#19 0x00007f724bde0546 in KActionMenu::~KActionMenu (this=0x169d360, __in_chrg=<value optimized out>) at ../../kdeui/actions/kactionmenu.cpp:77
#20 0x00007f724b9919e9 in KBookmarkActionMenu::~KBookmarkActionMenu (this=0x169d360, __in_chrg=<value optimized out>) at ../../kio/bookmarks/kbookmarkmenu.cc:763
#21 0x00007f72494adc14 in QObjectPrivate::deleteChildren (this=0xffd180) at kernel/qobject.cpp:1964
#22 0x00007f72494b25f4 in QObject::~QObject (this=0xffd140, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#23 0x00007f724e556cf9 in BookmarkProvider::~BookmarkProvider (this=0xffd140, __in_chrg=<value optimized out>) at /build/buildd/rekonq-0.7.0/src/bookmarks/bookmarkprovider.cpp:99
#24 0x00007f72494adc14 in QObjectPrivate::deleteChildren (this=0xf28440) at kernel/qobject.cpp:1964
#25 0x00007f72494b25f4 in QObject::~QObject (this=0x7fffc2b20640, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#26 0x00007f7249993112 in QApplication::~QApplication (this=0x7fffc2b20640, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1080
#27 0x00007f724e50826f in Application::~Application (this=0x7fffc2b20640, __in_chrg=<value optimized out>) at /build/buildd/rekonq-0.7.0/src/application.cpp:84
#28 0x00007f724e58c900 in kdemain (argc=1, argv=<value optimized out>) at /build/buildd/rekonq-0.7.0/src/main.cpp:213
#29 0x00007f724e137eff in __libc_start_main (main=0x400730 <main(int, char**)>, argc=1, ubp_av=0x7fffc2b20fc8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffc2b20fb8) at libc-start.c:226
#30 0x0000000000400659 in _start ()

This bug may be a duplicate of or related to bug 272330.

Possible duplicates by query: bug 272330, bug 271559, bug 269671, bug 269490, bug 268936.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-08 23:41:55 UTC
[Comment from a bug triager]
The bug was fixed recently in rekonqi. The issue was being tracked at bug 269490, merging.
Thanks

*** This bug has been marked as a duplicate of bug 269490 ***