Bug 268936 - Rekonq crash on exit
Summary: Rekonq crash on exit
Status: RESOLVED DUPLICATE of bug 269490
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-20 07:47 UTC by Ivaylo Kabakov
Modified: 2011-04-05 02:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (15.53 KB, text/plain)
2011-03-25 19:58 UTC, Ivaylo Kabakov
Details
New crash information added by DrKonqi (10.08 KB, text/plain)
2011-04-03 22:19 UTC, Alberto Mattea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivaylo Kabakov 2011-03-20 07:47:04 UTC
Application: rekonq (0.6.89)
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.2
Operating System: Linux 2.6.35.11-83.fc14.x86_64 x86_64
Distribution: "Fedora release 14 (Laughlin)"

-- Information about the crash:
- What I was doing when the application crashed:

Closing the browser window resulted in a crash. Could not reproduce it consistently. Had only Google Reader open before closing.
Rekonq is build from latest sources as of 2nd March.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f7ea1db6840 (LWP 5350))]

Thread 10 (Thread 0x7f7e9662d700 (LWP 5351)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00000033cfd28944 in scavengerThread (context=0x33d05458e0) at wtf/FastMalloc.cpp:2378
#2  WTF::TCMalloc_PageHeap::runScavengerThread (context=0x33d05458e0) at wtf/FastMalloc.cpp:1497
#3  0x00000033b2a06ccb in start_thread (arg=0x7f7e9662d700) at pthread_create.c:301
#4  0x00000033b1ee0c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 9 (Thread 0x7f7e94e15700 (LWP 5352)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00000033c1192bb4 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x33c14aad80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00000033c1192be9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x33c14b8e54) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00000033b2a06ccb in start_thread (arg=0x7f7e94e15700) at pthread_create.c:301
#4  0x00000033b1ee0c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 8 (Thread 0x7f7e938b5700 (LWP 5353)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00000033b927457b in wait (this=<value optimized out>, mutex=0x24d0b60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x24d0b60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000033ccc0a0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x24ce810, th=0x2747c10) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00000033ccc0c743 in ThreadWeaver::WorkingHardState::applyForWork (this=0x24d09f0, th=0x2747c10) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00000033ccc0c75c in ThreadWeaver::WorkingHardState::applyForWork (this=0x24d09f0, th=0x2747c10) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00000033ccc0b52f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7e938b4d50, parent=0x24ce810, th=0x2747c10) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:87
#7  0x00000033ccc0b5b8 in ThreadWeaver::Thread::run (this=0x2747c10) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:142
#8  0x00000033b9273e95 in QThreadPrivate::start (arg=0x2747c10) at thread/qthread_unix.cpp:320
#9  0x00000033b2a06ccb in start_thread (arg=0x7f7e938b5700) at pthread_create.c:301
#10 0x00000033b1ee0c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 7 (Thread 0x7f7e87b51700 (LWP 5361)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00000033b927457b in wait (this=<value optimized out>, mutex=0x24d0b60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x24d0b60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000033ccc0a0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x24ce810, th=0x282b8d0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00000033ccc0c743 in ThreadWeaver::WorkingHardState::applyForWork (this=0x24d09f0, th=0x282b8d0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00000033ccc0b52f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7e87b50d50, parent=0x24ce810, th=0x282b8d0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:87
#6  0x00000033ccc0b5b8 in ThreadWeaver::Thread::run (this=0x282b8d0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:142
#7  0x00000033b9273e95 in QThreadPrivate::start (arg=0x282b8d0) at thread/qthread_unix.cpp:320
#8  0x00000033b2a06ccb in start_thread (arg=0x7f7e87b51700) at pthread_create.c:301
#9  0x00000033b1ee0c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 6 (Thread 0x7f7e85945700 (LWP 5395)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00000033b927457b in wait (this=<value optimized out>, mutex=0x24d0b60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x24d0b60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000033ccc0a0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x24ce810, th=0x2b0e2d0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00000033ccc0c743 in ThreadWeaver::WorkingHardState::applyForWork (this=0x24d09f0, th=0x2b0e2d0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00000033ccc0c75c in ThreadWeaver::WorkingHardState::applyForWork (this=0x24d09f0, th=0x2b0e2d0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00000033ccc0b52f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7e85944d50, parent=0x24ce810, th=0x2b0e2d0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:87
#7  0x00000033ccc0b5b8 in ThreadWeaver::Thread::run (this=0x2b0e2d0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:142
#8  0x00000033b9273e95 in QThreadPrivate::start (arg=0x2b0e2d0) at thread/qthread_unix.cpp:320
#9  0x00000033b2a06ccb in start_thread (arg=0x7f7e85945700) at pthread_create.c:301
#10 0x00000033b1ee0c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7f7e5ffff700 (LWP 5431)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7e656da26e in queue_processor(void*) () from /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00000033b2a06ccb in start_thread (arg=0x7f7e5ffff700) at pthread_create.c:301
#3  0x00000033b1ee0c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f7e5f7fe700 (LWP 5432)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7e656da26e in queue_processor(void*) () from /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00000033b2a06ccb in start_thread (arg=0x7f7e5f7fe700) at pthread_create.c:301
#3  0x00000033b1ee0c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f7e5effd700 (LWP 5433)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7e656da26e in queue_processor(void*) () from /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/IcedTeaPlugin.so
#2  0x00000033b2a06ccb in start_thread (arg=0x7f7e5effd700) at pthread_create.c:301
#3  0x00000033b1ee0c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f7e66b0a700 (LWP 5494)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00000033b927457b in wait (this=<value optimized out>, mutex=0x24d0b60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x24d0b60, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00000033ccc0a0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x24ce810, th=0x42a0aa0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00000033ccc0c743 in ThreadWeaver::WorkingHardState::applyForWork (this=0x24d09f0, th=0x42a0aa0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00000033ccc0b52f in ThreadWeaver::ThreadRunHelper::run (this=0x7f7e66b09d50, parent=0x24ce810, th=0x42a0aa0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:87
#6  0x00000033ccc0b5b8 in ThreadWeaver::Thread::run (this=0x42a0aa0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:142
#7  0x00000033b9273e95 in QThreadPrivate::start (arg=0x42a0aa0) at thread/qthread_unix.cpp:320
#8  0x00000033b2a06ccb in start_thread (arg=0x7f7e66b0a700) at pthread_create.c:301
#9  0x00000033b1ee0c2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f7ea1db6840 (LWP 5350)):
[KCrash Handler]
#6  0x00000033b9baa869 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3f35010, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x00000033b9baa8e9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3f35010, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#8  0x00000033b9bc4ed2 in QWidgetBackingStore::~QWidgetBackingStore (this=0x4304400, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x00000033b9a021b9 in QWidgetBackingStoreTracker::destroy (this=0x42468d0) at kernel/qwidget.cpp:210
#10 0x00000033b9a02309 in QWidgetPrivate::deleteExtra (this=0x24c85f0) at kernel/qwidget.cpp:1776
#11 0x00000033b9a0254c in QWidgetPrivate::~QWidgetPrivate (this=0x24c85f0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:337
#12 0x00000033b9df7dcd in QMenuPrivate::~QMenuPrivate() () from /usr/lib64/libQtGui.so.4
#13 0x00000033b9374843 in cleanup (this=0x26be4c0, __in_chrg=<value optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x26be4c0, __in_chrg=<value optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x26be4c0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:818
#16 0x00000033b9a049cd in QWidget::~QWidget (this=0x26be4c0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1508
#17 0x00000033c3309999 in KMenu::~KMenu (this=0x26be4c0, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/kdeui/widgets/kmenu.cpp:167
#18 0x00000033c315fbe6 in KActionMenu::~KActionMenu (this=0x26ba710, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/kdeui/actions/kactionmenu.cpp:77
#19 0x00000033bd5be209 in KBookmarkActionMenu::~KBookmarkActionMenu (this=0x26ba710, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/kio/bookmarks/kbookmarkmenu.cc:763
#20 0x00000033b936fcb4 in QObjectPrivate::deleteChildren (this=0x25f6990) at kernel/qobject.cpp:1955
#21 0x00000033b93747f2 in QObject::~QObject (this=0x25f4ce0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#22 0x00007f7ea1eb7cd9 in BookmarkProvider::~BookmarkProvider (this=0x25f4ce0, __in_chrg=<value optimized out>) at /home/ivo/Development/rekonq/src/bookmarks/bookmarkprovider.cpp:100
#23 0x00000033b936fcb4 in QObjectPrivate::deleteChildren (this=0x2453220) at kernel/qobject.cpp:1955
#24 0x00000033b93747f2 in QObject::~QObject (this=0x7fffaecff3c0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#25 0x00000033b99c15a2 in QApplication::~QApplication (this=0x7fffaecff3c0, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1080
#26 0x00007f7ea1e68c9f in Application::~Application (this=0x7fffaecff3c0, __in_chrg=<value optimized out>) at /home/ivo/Development/rekonq/src/application.cpp:84
#27 0x00007f7ea1eeed10 in kdemain (argc=1, argv=0x7fffaecffd48) at /home/ivo/Development/rekonq/src/main.cpp:213
#28 0x00000033b1e1ee5d in __libc_start_main (main=0x4008a0 <main(int, char**)>, argc=1, ubp_av=0x7fffaecffd48, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffaecffd38) at libc-start.c:226
#29 0x00000000004007c9 in _start ()

Possible duplicates by query: bug 255081.

Reported using DrKonqi
Comment 1 Ivaylo Kabakov 2011-03-25 19:58:28 UTC
Created attachment 58337 [details]
New crash information added by DrKonqi

rekonq (0.6.95) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.2

- What I was doing when the application crashed:

One more crash on closing the browser window.

-- Backtrace (Reduced):
#6  0x00000032c79aa869 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3172640, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x00000032c79aa8e9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3172640, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#8  0x00000032c79c4ed2 in QWidgetBackingStore::~QWidgetBackingStore (this=0x3713b80, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x00000032c78021b9 in QWidgetBackingStoreTracker::destroy (this=0x4aafa90) at kernel/qwidget.cpp:210
#10 0x00000032c7802309 in QWidgetPrivate::deleteExtra (this=0x43e2740) at kernel/qwidget.cpp:1776
Comment 2 Alberto Mattea 2011-04-03 22:19:46 UTC
Created attachment 58552 [details]
New crash information added by DrKonqi

rekonq (0.7.0) on KDE Platform 4.6.1 (4.6.1) using Qt 4.7.0

- What I was doing when the application crashed:

Just closing the browser with the X button. There was a single tab opened.

-- Backtrace (Reduced):
#6  0x00007f9ae0d210c9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x26149f0, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x00007f9ae0d3ce82 in QWidgetBackingStore::~QWidgetBackingStore (this=0x2733a70, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#8  0x00007f9ae0b58fa9 in QWidgetBackingStoreTracker::destroy (this=0x2734610) at kernel/qwidget.cpp:205
#9  0x00007f9ae0b5ad79 in QWidgetPrivate::deleteExtra (this=0x26bdf80) at kernel/qwidget.cpp:1739
#10 0x00007f9ae0b5b56d in QWidgetPrivate::~QWidgetPrivate (this=0x26bdf80, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:318
Comment 3 José Manuel Santamaría Lema 2011-04-05 02:49:56 UTC

*** This bug has been marked as a duplicate of bug 269490 ***