Bug 271559 - Crash upon closing by clicking the 'x' button of the window of the application.
Summary: Crash upon closing by clicking the 'x' button of the window of the application.
Status: RESOLVED DUPLICATE of bug 269490
Alias: None
Product: rekonq
Classification: Applications
Component: general (show other bugs)
Version: 0.7.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-23 15:55 UTC by kivech.brach
Modified: 2011-05-08 23:41 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.02 KB, text/plain)
2011-05-03 16:02 UTC, marvin
Details
New crash information added by DrKonqi (15.83 KB, text/plain)
2011-05-04 15:30 UTC, sotas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kivech.brach 2011-04-23 15:55:41 UTC
Application: rekonq (0.7.0)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
As the title suggests, this crash always happens when I close reconq by clicking on the 'x' close button.

I'm working with the build of 23rd of April of Kubuntu 11.4.

The crash can be reproduced every time.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5ce6764780 (LWP 3862))]

Thread 6 (Thread 0x7f5cd0e78700 (LWP 3863)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5ce51de832 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f5ce0966d8c in start_thread (arg=0x7f5cd0e78700) at pthread_create.c:304
#3  0x00007f5ce5fc804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f5ccf885700 (LWP 3864)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5ce5bba2a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f5ce5ed3180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f5ce5bba2d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f5ce5ee1254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f5ce0966d8c in start_thread (arg=0x7f5ccf885700) at pthread_create.c:304
#4  0x00007f5ce5fc804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f5cce392700 (LWP 3865)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5ce117d82b in wait (this=<value optimized out>, mutex=0x19a5810, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x19a5810, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f5ce313d0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x19a4090, th=0x1d8dee0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f5ce313f723 in ThreadWeaver::WorkingHardState::applyForWork (this=0x19a4b30, th=0x1d8dee0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f5ce313e53f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5cce391e20, parent=0x19a4090, th=0x1d8dee0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f5ce313e5cb in ThreadWeaver::Thread::run (this=0x1d8dee0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f5ce117d175 in QThreadPrivate::start (arg=0x1d8dee0) at thread/qthread_unix.cpp:320
#8  0x00007f5ce0966d8c in start_thread (arg=0x7f5cce392700) at pthread_create.c:304
#9  0x00007f5ce5fc804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5ccb641700 (LWP 3867)):
#0  0x00007f5ce09693ce in __pthread_mutex_lock (mutex=0x1e82608) at pthread_mutex_lock.c:62
#1  0x00007f5cdd39e87f in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5cdd39f122 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5cdd39f639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5ce128f446 in QEventDispatcherGlib::processEvents (this=0x1b78b80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f5ce1263882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f5ce1263abc in QEventLoop::exec (this=0x7f5ccb640dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f5ce117a924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007f5ce1245c2f in QInotifyFileSystemWatcherEngine::run (this=0x1e81390) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f5ce117d175 in QThreadPrivate::start (arg=0x1e81390) at thread/qthread_unix.cpp:320
#10 0x00007f5ce0966d8c in start_thread (arg=0x7f5ccb641700) at pthread_create.c:304
#11 0x00007f5ce5fc804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5cc1c57700 (LWP 3893)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5ce117d82b in wait (this=<value optimized out>, mutex=0x19a5810, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x19a5810, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f5ce313d0b4 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x19a4090, th=0x3c1cdf0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f5ce313f723 in ThreadWeaver::WorkingHardState::applyForWork (this=0x19a4b30, th=0x3c1cdf0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f5ce313e53f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5cc1c56e20, parent=0x19a4090, th=0x3c1cdf0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f5ce313e5cb in ThreadWeaver::Thread::run (this=0x3c1cdf0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f5ce117d175 in QThreadPrivate::start (arg=0x3c1cdf0) at thread/qthread_unix.cpp:320
#8  0x00007f5ce0966d8c in start_thread (arg=0x7f5cc1c57700) at pthread_create.c:304
#9  0x00007f5ce5fc804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5ce6764780 (LWP 3862)):
[KCrash Handler]
#6  0x00007f5ce1945fa9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3b6a230, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x00007f5ce1946029 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3b6a230, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#8  0x00007f5ce19605e2 in QWidgetBackingStore::~QWidgetBackingStore (this=0x3b6a9d0, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f5ce179c779 in QWidgetBackingStoreTracker::destroy (this=0x2209740) at kernel/qwidget.cpp:210
#10 0x00007f5ce179c8c9 in QWidgetPrivate::deleteExtra (this=0x1ea16d0) at kernel/qwidget.cpp:1776
#11 0x00007f5ce179cb0c in QWidgetPrivate::~QWidgetPrivate (this=0x1ea16d0, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:337
#12 0x00007f5ce1b96e6d in ~QMenuPrivate (this=0x1ea16d0, __in_chrg=<value optimized out>) at widgets/qmenu_p.h:171
#13 QMenuPrivate::~QMenuPrivate (this=0x1ea16d0, __in_chrg=<value optimized out>) at widgets/qmenu_p.h:183
#14 0x00007f5ce127b645 in cleanup (this=0x1ea1670, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x1ea1670, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x1ea1670, __in_chrg=<value optimized out>) at kernel/qobject.cpp:818
#17 0x00007f5ce179ef70 in QWidget::~QWidget (this=0x1ea1670, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1508
#18 0x00007f5ce3d4c119 in KMenu::~KMenu (this=0x1ea1670, __in_chrg=<value optimized out>) at ../../kdeui/widgets/kmenu.cpp:167
#19 0x00007f5ce3ba9546 in KActionMenu::~KActionMenu (this=0x1ea06b0, __in_chrg=<value optimized out>) at ../../kdeui/actions/kactionmenu.cpp:77
#20 0x00007f5ce375a9e9 in KBookmarkActionMenu::~KBookmarkActionMenu (this=0x1ea06b0, __in_chrg=<value optimized out>) at ../../kio/bookmarks/kbookmarkmenu.cc:763
#21 0x00007f5ce1276c14 in QObjectPrivate::deleteChildren (this=0x1b8eeb0) at kernel/qobject.cpp:1964
#22 0x00007f5ce127b5f4 in QObject::~QObject (this=0x1b8ee70, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#23 0x00007f5ce631fcf9 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_rekonq.so
#24 0x00007f5ce1276c14 in QObjectPrivate::deleteChildren (this=0x18dda80) at kernel/qobject.cpp:1964
#25 0x00007f5ce127b5f4 in QObject::~QObject (this=0x7fffa69f8f90, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#26 0x00007f5ce175c112 in QApplication::~QApplication (this=0x7fffa69f8f90, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1080
#27 0x00007f5ce62d126f in Application::~Application() () from /usr/lib/kde4/libkdeinit/libkdeinit4_rekonq.so
#28 0x00007f5ce6355900 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_rekonq.so
#29 0x00007f5ce5f00eff in __libc_start_main (main=0x400730 <_start+256>, argc=1, ubp_av=0x7fffa69f9918, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffa69f9908) at libc-start.c:226
#30 0x0000000000400659 in _start ()

This bug may be a duplicate of or related to bug 269490.

Possible duplicates by query: bug 269671, bug 269490, bug 268936, bug 255081.

Reported using DrKonqi
Comment 1 marvin 2011-05-03 16:02:24 UTC
Created attachment 59579 [details]
New crash information added by DrKonqi

rekonq (0.7.0) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

When i click on the button 'x' of the windows, the software crash.

-- Backtrace (Reduced):
#7  0x049349ca in QRasterWindowSurface::~QRasterWindowSurface (this=0x8c28678, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#8  0x04934a62 in QRasterWindowSurface::~QRasterWindowSurface (this=0x8c28678, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#9  0x04950631 in QWidgetBackingStore::~QWidgetBackingStore (this=0x8c3eae0, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#10 0x0477586b in QWidgetBackingStoreTracker::destroy (this=0x8ef9d38) at kernel/qwidget.cpp:210
#11 0x047759c1 in QWidgetPrivate::deleteExtra (this=0x8be5e60) at kernel/qwidget.cpp:1776
Comment 2 sotas 2011-05-04 15:30:40 UTC
Created attachment 59613 [details]
New crash information added by DrKonqi

rekonq (0.7.0) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
As the title suggests, this crash always happens when I close reconq by clicking on the 'x' close button.

I'm working with the build of 27rd of April of Kubuntu 11.4.

-- Backtrace (Reduced):
#7  0x02d5a9ca in QRasterWindowSurface::~QRasterWindowSurface (this=0x9c15258, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#8  0x02d5aa62 in QRasterWindowSurface::~QRasterWindowSurface (this=0x9c15258, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#9  0x02d76631 in QWidgetBackingStore::~QWidgetBackingStore (this=0x95f3a80, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#10 0x02b9b86b in QWidgetBackingStoreTracker::destroy (this=0xafd2f58) at kernel/qwidget.cpp:210
#11 0x02b9b9c1 in QWidgetPrivate::deleteExtra (this=0x96e9370) at kernel/qwidget.cpp:1776
Comment 3 Dario Andres 2011-05-08 23:41:51 UTC
[Comment from a bug triager]
The bug was fixed recently in rekonqi. The issue was being tracked at bug 269490, merging.
Thanks

*** This bug has been marked as a duplicate of bug 269490 ***