Bug 296851 - general crash - unclear circumstances
Summary: general crash - unclear circumstances
Status: RESOLVED DUPLICATE of bug 271889
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-27 03:15 UTC by Axel Krebs
Modified: 2012-03-27 14:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Krebs 2012-03-27 03:15:32 UTC
Application: ksysguard (4.8.1 (4.8.1))
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
running bleachbit, searching dublettes with fslint and re-creating thumbnails with digikam 2.5

-- Backtrace:
Application: Systemmonitor (ksysguard), signal: Bus error
[Current thread is 1 (Thread 0x7f3b9b6fa7a0 (LWP 2130))]

Thread 2 (Thread 0x7f3b8527b700 (LWP 2405)):
#0  0x00007f3b9afd1473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3b92511f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3b92512429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3b98c2bc26 in QEventDispatcherGlib::processEvents (this=0xdd2450, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f3b98bfb402 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3b98bfb657 in QEventLoop::exec (this=0x7f3b8527adb0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f3b98afb067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f3b98bdb17f in QInotifyFileSystemWatcherEngine::run (this=0xe0a090) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f3b98afe08b in QThreadPrivate::start (arg=0xe0a090) at thread/qthread_unix.cpp:298
#9  0x00007f3b93222efc in start_thread (arg=0x7f3b8527b700) at pthread_create.c:304
#10 0x00007f3b9afdd59d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3b9b6fa7a0 (LWP 2130)):
[KCrash Handler]
#6  0x00007f3b9940af37 in lock (this=0x736bf0) at ../../kdecore/util/kshareddatacache.cpp:1123
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff92663dd0) at ../../kdecore/util/kshareddatacache.cpp:1146
#8  0x00007f3b99407169 in CacheLocker (_d=<optimized out>, this=0x7fff92663dd0) at ../../kdecore/util/kshareddatacache.cpp:1170
#9  KSharedDataCache::find (this=0x77ba20, key=..., destination=0x7fff92663ea0) at ../../kdecore/util/kshareddatacache.cpp:1492
#10 0x00007f3b99882e39 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x7448e0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:860
#11 0x00007f3b99883151 in KIconLoader::loadIcon (this=0x741b00, _name=<optimized out>, group=KIconLoader::Small, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=true) at ../../kdeui/icons/kiconloader.cpp:1222
#12 0x00007f3b99a0a89c in KWindowSystem::icon (win=20971617, width=16, height=16, scale=true, flags=15) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:688
#13 0x00007f3b99a0b063 in KWindowSystem::icon (win=<optimized out>, width=<optimized out>, height=<optimized out>, scale=<optimized out>) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:621
#14 0x00007f3b9acd9537 in ProcessModelPrivate::updateWindowInfo (this=0x834f00, wid=20971617, properties=12681216, newWindow=<optimized out>) at ../../../../libs/ksysguard/processui/ProcessModel.cpp:541
#15 0x00007f3b9acda244 in ProcessModelPrivate::qt_metacall (this=0x834f00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff92664810) at ./ProcessModel_p.moc:92
#16 0x00007f3b98c10c09 in QMetaObject::activate (sender=0x8b30d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff92664810) at kernel/qobject.cpp:3566
#17 0x00007f3b99a0c152 in KWindowSystem::windowAdded (this=<optimized out>, _t1=20971617) at ./kwindowsystem.moc:129
#18 0x00007f3b99a0c779 in KWindowSystemPrivate::addClient (this=0x736270, w=20971617) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:269
#19 0x00007f3b99a1b0b6 in NETRootInfo::update (this=0x736298, dirty_props=<optimized out>) at ../../kdeui/windowmanagement/netwm.cpp:2227
#20 0x00007f3b99a1bd33 in NETRootInfo::event (this=0x736298, event=0x7fff92664b60, properties=0x7fff92664a70, properties_size=5) at ../../kdeui/windowmanagement/netwm.cpp:2099
#21 0x00007f3b99a0e423 in KWindowSystemPrivate::x11Event (this=0x736270, ev=0x7fff92664b60) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:172
#22 0x00007f3b998fd956 in publicX11Event (e=0x7fff92664b60, this=<optimized out>) at ../../kdeui/kernel/ksystemeventfilter.cpp:43
#23 KSystemEventFilterPrivate::filterEvent (this=0x88c530, message=0x7fff92664b60) at ../../kdeui/kernel/ksystemeventfilter.cpp:102
#24 0x00007f3b98bef36e in QAbstractEventDispatcher::filterEvent (this=<optimized out>, message=<optimized out>) at kernel/qabstracteventdispatcher.cpp:539
#25 0x00007f3b98027578 in x11EventSourceDispatch (s=0x6cc3a0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:143
#26 0x00007f3b92511a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f3b92512258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f3b92512429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f3b98c2bbbf in QEventDispatcherGlib::processEvents (this=0x6a84b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#30 0x00007f3b9802728e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f3b98bfb402 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f3b98bfb657 in QEventLoop::exec (this=0x7fff92664f30, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007f3b98c006e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#34 0x00007f3b9b303df1 in kdemain (argc=1, argv=<optimized out>) at ../../../ksysguard/gui/ksysguard.cpp:582
#35 0x00007f3b9af1b30d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff92665488, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff92665478) at libc-start.c:226
#36 0x0000000000400671 in _start ()

Possible duplicates by query: bug 284821, bug 284819, bug 284770.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-27 14:00:15 UTC

*** This bug has been marked as a duplicate of bug 271889 ***