Bug 271873 - Kwin crashes when closing a full screen flash video
Summary: Kwin crashes when closing a full screen flash video
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-27 22:09 UTC by maurizio
Modified: 2011-04-27 22:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description maurizio 2011-04-27 22:09:12 UTC
Application: kwin (4.6.00 (4.6.0) "release 6")
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
Kwin crashed when I close a full screen flash video streaming from a website, it first freezes than crashes.
I have an ASUS pro31f with opensuse11.4

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb249cac0 (LWP 3286))]

Thread 2 (Thread 0xae21eb70 (LWP 3338)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb61e9105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7545aec in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb6bdce17 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb6cf31a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb6bdce5f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb6cf31a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb61e4b05 in start_thread () from /lib/libpthread.so.0
#6  0xb7537d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb249cac0 (LWP 3286)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x8147800, region=0x0, flag=2) at intel_regions.c:514
#8  0xaf4b593a in intelClearWithBlit (ctx=0x8147800, mask=2) at intel_blit.c:262
#9  0xaf4adf2d in intelClear (ctx=0x8147800, mask=2) at intel_clear.c:177
#10 0xaf66e018 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0xb76a2ebb in KWin::SceneOpenGL::paintBackground (this=0x846dd80, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#12 0xb769932c in KWin::Scene::paintGenericScreen (this=0x846dd80, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
#13 0xb76a30d1 in KWin::SceneOpenGL::paintGenericScreen (this=0x846dd80, mask=32, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:909
#14 0xb7696110 in KWin::Scene::finalPaintScreen (this=0x846dd80, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:178
#15 0xb76b7c45 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:173
#16 0xae2b8796 in KWin::StartupFeedbackEffect::paintScreen (this=0x84e6b20, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#18 0xb69c7d7a in KWin::Effect::paintScreen (this=0x84e62c0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#19 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#20 0xae256cb2 in KWin::LogoutEffect::paintScreen (this=0x8503450, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/logout/logout.cpp:207
#21 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#22 0xae27381f in KWin::ShadowEffect::paintScreen (this=0x8520ec8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/shadow/shadow.cpp:189
#23 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#24 0xae25bda4 in KWin::PresentWindowsEffect::paintScreen (this=0x84b7e98, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/presentwindows/presentwindows.cpp:205
#25 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#26 0xb69c7d7a in KWin::Effect::paintScreen (this=0x84e2568, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#27 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#28 0xb69c7d7a in KWin::Effect::paintScreen (this=0x8503178, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#29 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#30 0xb69c7d7a in KWin::Effect::paintScreen (this=0x84e24e0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#31 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#32 0xb69c7d7a in KWin::Effect::paintScreen (this=0x84bf658, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#33 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#34 0xb69c7d7a in KWin::Effect::paintScreen (this=0x84dcb70, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#35 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#36 0xb69c7d7a in KWin::Effect::paintScreen (this=0x84b32e0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#37 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#38 0xb69c7d7a in KWin::Effect::paintScreen (this=0x84d3aa0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#39 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#40 0xae2a8bca in KWin::FlipSwitchEffect::paintScreen (this=0x84ba518, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/flipswitch/flipswitch.cpp:148
#41 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#42 0xae240e64 in KWin::DesktopGridEffect::paintScreen (this=0x85262f0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/desktopgrid/desktopgrid.cpp:155
#43 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#44 0xb69c7d7a in KWin::Effect::paintScreen (this=0x85007e0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#45 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#46 0xae238dec in KWin::BoxSwitchEffect::paintScreen (this=0x850c9a8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:143
#47 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#48 0xb69c7d7a in KWin::Effect::paintScreen (this=0x8521978, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#49 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#50 0xb69c7d7a in KWin::Effect::paintScreen (this=0x85020f0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#51 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#52 0xae2904da in KWin::CoverSwitchEffect::paintScreen (this=0x84e6c38, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/coverswitch/coverswitch.cpp:126
#53 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#54 0xb69c7d7a in KWin::Effect::paintScreen (this=0x84b34e0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#55 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#56 0xb69c7d7a in KWin::Effect::paintScreen (this=0x84dfb08, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#57 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#58 0xae281ea3 in KWin::ThumbnailAsideEffect::paintScreen (this=0x850b0e8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/thumbnailaside/thumbnailaside.cpp:56
#59 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#60 0xb69c7d7a in KWin::Effect::paintScreen (this=0x85011e0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#61 0xb76b7cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x8458de8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#62 0xb7698a09 in KWin::Scene::paintScreen (this=0x846dd80, mask=0xbfce9220, region=0xbfce92c0) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:137
#63 0xb76ae17a in KWin::SceneOpenGL::paint (this=0x846dd80, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:772
#64 0xb7693213 in KWin::Workspace::performCompositing (this=0x84728d8) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/composite.cpp:448
#65 0xb63713f4 in QObject::event (this=0x84728d8, e=0xbfce980c) at kernel/qobject.cpp:1175
#66 0xb5869414 in QApplicationPrivate::notify_helper (this=0x8071510, receiver=0x84728d8, e=0xbfce980c) at kernel/qapplication.cpp:4445
#67 0xb58720c7 in QApplication::notify (this=0xbfce9b44, receiver=0x84728d8, e=0xbfce980c) at kernel/qapplication.cpp:3845
#68 0xb717e1f1 in KApplication::notify (this=0xbfce9b44, receiver=0x84728d8, event=0xbfce980c) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#69 0xb761f131 in KWin::Application::notify (this=0xbfce9b44, o=0x84728d8, e=0xbfce980c) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:376
#70 0xb635bfde in QCoreApplication::notifyInternal (this=0xbfce9b44, receiver=0x84728d8, event=0xbfce980c) at kernel/qcoreapplication.cpp:732
#71 0xb638d379 in sendEvent (this=0x8071c98) at kernel/qcoreapplication.h:215
#72 QTimerInfoList::activateTimers (this=0x8071c98) at kernel/qeventdispatcher_unix.cpp:618
#73 0xb638db1d in QEventDispatcherUNIX::processEvents (this=0x8054d88, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#74 0xb592064a in QEventDispatcherX11::processEvents (this=0x8054d88, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#75 0xb635b2bd in QEventLoop::processEvents (this=0xbfce9a74, flags=...) at kernel/qeventloop.cpp:149
#76 0xb635b4e9 in QEventLoop::exec (this=0xbfce9a74, flags=...) at kernel/qeventloop.cpp:201
#77 0xb635ff90 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#78 0xb5867104 in QApplication::exec () at kernel/qapplication.cpp:3719
#79 0xb7621bc7 in kdemain (argc=3, argv=0xbfce9db4) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:542
#80 0x0804860b in main (argc=3, argv=0xbfce9db4) at /usr/src/debug/kdebase-workspace-4.6.0/build/kwin/kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 271574, bug 271452, bug 271396, bug 270557, bug 269938.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-04-27 22:17:56 UTC
driver bug, see dupe

*** This bug has been marked as a duplicate of bug 252817 ***