Bug 271396 - KWin crashes
Summary: KWin crashes
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-21 02:30 UTC by dimaborger
Modified: 2011-04-21 06:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dimaborger 2011-04-21 02:30:40 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu Natty (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

I was watching youtube video through vk.com using google chrome.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb789c720 (LWP 1377))]

Thread 3 (Thread 0xb2f4bb70 (LWP 1442)):
#0  0x02098d41 in clock_gettime (clock_id=1, tp=0xb2f4b120) at ../sysdeps/unix/clock_gettime.c:116
#1  0x03196dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x032634f2 in updateCurrentTime (this=0x9e57398, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x9e57398, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x032653a3 in QEventDispatcherUNIX::processEvents (this=0x9eb0ad8, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0x03234289 in QEventLoop::processEvents (this=0xb2f4b280, flags=...) at kernel/qeventloop.cpp:149
#7  0x03234522 in QEventLoop::exec (this=0xb2f4b280, flags=...) at kernel/qeventloop.cpp:201
#8  0x0313e2a0 in QThread::exec (this=0x9c3bb18) at thread/qthread.cpp:492
#9  0x03215fdb in QInotifyFileSystemWatcherEngine::run (this=0x9c3bb18) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x03140da2 in QThreadPrivate::start (arg=0x9c3bb18) at thread/qthread_unix.cpp:320
#11 0x08932e99 in start_thread (arg=0xb2f4bb70) at pthread_create.c:304
#12 0x001e073e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb2742b70 (LWP 1443)):
#0  0x00352416 in __kernel_vsyscall ()
#1  0x0893748c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x001ee3fd in __pthread_cond_wait (cond=0x11012b0, mutex=0x1101298) at forward.c:139
#3  0x00fe8817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x10fc1c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00fe8851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x10fc1c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x08932e99 in start_thread (arg=0xb2742b70) at pthread_create.c:304
#6  0x001e073e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb789c720 (LWP 1377)):
[KCrash Handler]
#7  0x025af2e0 in intel_region_buffer () from /usr/lib/dri/i965_dri.so
#8  0x025a0ce2 in intelClearWithBlit () from /usr/lib/dri/i965_dri.so
#9  0x025a34c0 in ?? () from /usr/lib/dri/i965_dri.so
#10 0x02749512 in _mesa_Clear () from /usr/lib/dri/libdricore.so
#11 0x0060584b in KWin::SceneOpenGL::paintBackground (this=0x987e6c0, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x005fc562 in KWin::Scene::paintGenericScreen (this=0x987e6c0, orig_mask=32) at ../../kwin/scene.cpp:188
#13 0x00605a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x987e6c0, mask=32, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x005f97c0 in KWin::Scene::finalPaintScreen (this=0x987e6c0, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x0061b0fc in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x02ca50e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x9dcbb80, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x00302256 in KWin::Effect::paintScreen (this=0x9cc1710, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x02c4707f in KWin::LogoutEffect::paintScreen (this=0x9ceb330, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x02c62b10 in KWin::ShadowEffect::paintScreen (this=0x9d77d60, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x02c77013 in KWin::BlurEffect::paintScreen (this=0x9c0c9d8, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x02c4be6f in KWin::PresentWindowsEffect::paintScreen (this=0x9c0f6a8, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x00302256 in KWin::Effect::paintScreen (this=0x9ceb418, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x00302256 in KWin::Effect::paintScreen (this=0x9d97bf0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x00302256 in KWin::Effect::paintScreen (this=0x9c7e100, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x00302256 in KWin::Effect::paintScreen (this=0x9c609b8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x02c327e9 in KWin::DesktopGridEffect::paintScreen (this=0x9beac00, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x02c2b799 in KWin::BoxSwitchEffect::paintScreen (this=0x9cce578, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#39 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x02c85bcc in KWin::CubeEffect::paintScreen (this=0x9e29c18, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#41 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x00302256 in KWin::Effect::paintScreen (this=0x9dc46d8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#43 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x02c8edf0 in KWin::CubeSlideEffect::paintScreen (this=0x9ceb0c8, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#45 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x00302256 in KWin::Effect::paintScreen (this=0x9d4c3a8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x00302256 in KWin::Effect::paintScreen (this=0x9c6cea0, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x02c7ea0c in KWin::CoverSwitchEffect::paintScreen (this=0x9cfbfa0, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#51 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x00302256 in KWin::Effect::paintScreen (this=0x9c0bce8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x00302256 in KWin::Effect::paintScreen (this=0x9daaa40, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x02c740c1 in KWin::ZoomEffect::paintScreen (this=0x9d960f0, mask=0, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#57 0x0061b172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9a09260, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x005fa98c in KWin::Scene::paintScreen (this=0x987e6c0, mask=0xbfa99dc8, region=0xbfa99e50) at ../../kwin/scene.cpp:137
#59 0x00611962 in KWin::SceneOpenGL::paint (this=0x987e6c0, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#60 0x005f6886 in KWin::Workspace::performCompositing (this=0x9baa4b8) at ../../kwin/composite.cpp:448
#61 0x0324a214 in QObject::event (this=0x9baa4b8, e=0xbfa9a37c) at kernel/qobject.cpp:1190
#62 0x047fbd24 in QApplicationPrivate::notify_helper (this=0x97c1da8, receiver=0x9baa4b8, e=0xbfa9a37c) at kernel/qapplication.cpp:4462
#63 0x048008ce in QApplication::notify (this=0xbfa9a694, receiver=0x9baa4b8, e=0xbfa9a37c) at kernel/qapplication.cpp:3862
#64 0x008313ca in KApplication::notify (this=0xbfa9a694, receiver=0x9baa4b8, event=0xbfa9a37c) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x00585abf in KWin::Application::notify (this=0xbfa9a694, o=0x9baa4b8, e=0xbfa9a37c) at ../../kwin/main.cpp:376
#66 0x032350bb in QCoreApplication::notifyInternal (this=0xbfa9a694, receiver=0x9baa4b8, event=0xbfa9a37c) at kernel/qcoreapplication.cpp:731
#67 0x032651e4 in sendEvent (this=0x97c33c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x97c33c0) at kernel/qeventdispatcher_unix.cpp:604
#69 0x03265338 in QEventDispatcherUNIX::processEvents (this=0x9780aa8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#70 0x048b07ea in QEventDispatcherX11::processEvents (this=0x9780aa8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0x03234289 in QEventLoop::processEvents (this=0xbfa9a5d4, flags=...) at kernel/qeventloop.cpp:149
#72 0x03234522 in QEventLoop::exec (this=0xbfa9a5d4, flags=...) at kernel/qeventloop.cpp:201
#73 0x03238ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#74 0x047f98e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#75 0x005885b2 in kdemain (argc=3, argv=0xbfa9a914) at ../../kwin/main.cpp:542
#76 0x080485bb in main (argc=3, argv=0xbfa9a914) at kwin_dummy.cpp:3

Possible duplicates by query: bug 270557, bug 269938, bug 269889, bug 269314, bug 264258.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-04-21 06:53:22 UTC

*** This bug has been marked as a duplicate of bug 252817 ***