Bug 270557 - reproduccion de flash se congelo al interferir Kwin en el video
Summary: reproduccion de flash se congelo al interferir Kwin en el video
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-10 08:31 UTC by croses
Modified: 2011-04-10 08:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description croses 2011-04-10 08:31:44 UTC
Application: kwin (4.6.00 (4.6.0) "release 6")
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
Estaba viendo un video en pantalla completa en Youtube con Flash plugins.

- Unusual behavior I noticed:
Cuando moví la rueda de volumen e intentó aparecer la grafica de volumen sobre el video este se congelo.

- Custom settings of the application:
ninguna.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2559ac0 (LWP 9576))]

Thread 2 (Thread 0xadde3b70 (LWP 9641)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb62a6105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7602aec in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb6c99e17 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb6db01a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb6c99e5f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb6db01a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb62a1b05 in start_thread () from /lib/libpthread.so.0
#6  0xb75f4d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb2559ac0 (LWP 9576)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x81410d0, region=0x0, flag=2) at intel_regions.c:514
#8  0xaf39216a in intelClearWithBlit (ctx=0x81410d0, mask=2) at intel_blit.c:262
#9  0xaf39490d in intelClear (ctx=0x81410d0, mask=2) at intel_clear.c:177
#10 0xaf592698 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0xb775febb in KWin::SceneOpenGL::paintBackground (this=0x813fe18, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#12 0xb775632c in KWin::Scene::paintGenericScreen (this=0x813fe18, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
#13 0xb77600d1 in KWin::SceneOpenGL::paintGenericScreen (this=0x813fe18, mask=32, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:909
#14 0xb7753110 in KWin::Scene::finalPaintScreen (this=0x813fe18, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:178
#15 0xb7774c45 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:173
#16 0xadf58796 in KWin::StartupFeedbackEffect::paintScreen (this=0x85d2070, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#18 0xb6a84d7a in KWin::Effect::paintScreen (this=0x87edcd0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#19 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#20 0xadef6cb2 in KWin::LogoutEffect::paintScreen (this=0x87bafa8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/logout/logout.cpp:207
#21 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#22 0xadf1381f in KWin::ShadowEffect::paintScreen (this=0x87bba70, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/shadow/shadow.cpp:189
#23 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#24 0xadf288d1 in KWin::BlurEffect::paintScreen (this=0x84bfef8, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/blur/blur.cpp:230
#25 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#26 0xadefbda4 in KWin::PresentWindowsEffect::paintScreen (this=0x84cd068, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/presentwindows/presentwindows.cpp:205
#27 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#28 0xb6a84d7a in KWin::Effect::paintScreen (this=0x881e258, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#29 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#30 0xb6a84d7a in KWin::Effect::paintScreen (this=0x87e9810, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#31 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#32 0xb6a84d7a in KWin::Effect::paintScreen (this=0x87f6ba8, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#33 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#34 0xb6a84d7a in KWin::Effect::paintScreen (this=0x855ffd0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#35 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#36 0xadee0e64 in KWin::DesktopGridEffect::paintScreen (this=0x84c8dd0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#38 0xadf1ae3d in KWin::SlideEffect::paintScreen (this=0x854e118, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/slide/slide.cpp:86
#39 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#40 0xaded8dec in KWin::BoxSwitchEffect::paintScreen (this=0x85210c0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:143
#41 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#42 0xb6a84d7a in KWin::Effect::paintScreen (this=0x87eee10, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#43 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#44 0xb6a84d7a in KWin::Effect::paintScreen (this=0x87eae60, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#45 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#46 0xb6a84d7a in KWin::Effect::paintScreen (this=0x86e8e08, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#47 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#48 0xb6a84d7a in KWin::Effect::paintScreen (this=0x84bf708, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#49 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#50 0xb6a84d7a in KWin::Effect::paintScreen (this=0x8781c88, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#51 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#52 0xadf25760 in KWin::ZoomEffect::paintScreen (this=0x857c160, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/zoom/zoom.cpp:341
#53 0xb7774cc7 in KWin::EffectsHandlerImpl::paintScreen (this=0x84729a0, mask=0, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#54 0xb7755a09 in KWin::Scene::paintScreen (this=0x813fe18, mask=0xbf881490, region=0xbf881530) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:137
#55 0xb776b17a in KWin::SceneOpenGL::paint (this=0x813fe18, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:772
#56 0xb7750213 in KWin::Workspace::performCompositing (this=0xaf737c70) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/composite.cpp:448
#57 0xb642e3f4 in QObject::event (this=0xaf737c70, e=0xbf881a7c) at kernel/qobject.cpp:1175
#58 0xb5926414 in QApplicationPrivate::notify_helper (this=0x80713b0, receiver=0xaf737c70, e=0xbf881a7c) at kernel/qapplication.cpp:4445
#59 0xb592f0c7 in QApplication::notify (this=0xbf881db4, receiver=0xaf737c70, e=0xbf881a7c) at kernel/qapplication.cpp:3845
#60 0xb723b1f1 in KApplication::notify (this=0xbf881db4, receiver=0xaf737c70, event=0xbf881a7c) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#61 0xb76dc131 in KWin::Application::notify (this=0xbf881db4, o=0xaf737c70, e=0xbf881a7c) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:376
#62 0xb6418fde in QCoreApplication::notifyInternal (this=0xbf881db4, receiver=0xaf737c70, event=0xbf881a7c) at kernel/qcoreapplication.cpp:732
#63 0xb644a379 in sendEvent (this=0x8071b38) at kernel/qcoreapplication.h:215
#64 QTimerInfoList::activateTimers (this=0x8071b38) at kernel/qeventdispatcher_unix.cpp:618
#65 0xb644ab1d in QEventDispatcherUNIX::processEvents (this=0x8054d88, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#66 0xb59dd64a in QEventDispatcherX11::processEvents (this=0x8054d88, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#67 0xb64182bd in QEventLoop::processEvents (this=0xbf881ce4, flags=...) at kernel/qeventloop.cpp:149
#68 0xb64184e9 in QEventLoop::exec (this=0xbf881ce4, flags=...) at kernel/qeventloop.cpp:201
#69 0xb641cf90 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#70 0xb5924104 in QApplication::exec () at kernel/qapplication.cpp:3719
#71 0xb76debc7 in kdemain (argc=1, argv=0xbf882024) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:542
#72 0x0804860b in main (argc=1, argv=0xbf882024) at /usr/src/debug/kdebase-workspace-4.6.0/build/kwin/kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 269562, bug 266132.

Possible duplicates by query: bug 269938, bug 269895, bug 269889, bug 269562, bug 269314.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-04-10 08:41:25 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***