Bug 271452 - KWin crashes
Summary: KWin crashes
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-21 22:47 UTC by dimaborger
Modified: 2011-04-21 23:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dimaborger 2011-04-21 22:47:58 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu Natty (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

kwin crashes when i trying to make flash player fullscreen in google chrome.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d5720 (LWP 1376))]

Thread 3 (Thread 0xb2e83b70 (LWP 1440)):
#0  0x00e01d41 in clock_gettime (clock_id=1, tp=0xb2e83120) at ../sysdeps/unix/clock_gettime.c:116
#1  0x08aa6dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x08b734f2 in updateCurrentTime (this=0x90518e0, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x90518e0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x08b753a3 in QEventDispatcherUNIX::processEvents (this=0x96dc088, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0x08b44289 in QEventLoop::processEvents (this=0xb2e83280, flags=...) at kernel/qeventloop.cpp:149
#7  0x08b44522 in QEventLoop::exec (this=0xb2e83280, flags=...) at kernel/qeventloop.cpp:201
#8  0x08a4e2a0 in QThread::exec (this=0x904f800) at thread/qthread.cpp:492
#9  0x08b25fdb in QInotifyFileSystemWatcherEngine::run (this=0x904f800) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x08a50da2 in QThreadPrivate::start (arg=0x904f800) at thread/qthread_unix.cpp:320
#11 0x06046e99 in start_thread (arg=0xb2e83b70) at pthread_create.c:304
#12 0x00a0873e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb267ab70 (LWP 1441)):
#0  0x00d7d416 in __kernel_vsyscall ()
#1  0x0604b48c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x00a163fd in __pthread_cond_wait (cond=0xd392b0, mutex=0xd39298) at forward.c:139
#3  0x00c20817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xd341c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x00c20851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xd341c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x06046e99 in start_thread (arg=0xb267ab70) at pthread_create.c:304
#6  0x00a0873e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77d5720 (LWP 1376)):
[KCrash Handler]
#7  0x032322e0 in intel_region_buffer () from /usr/lib/dri/i965_dri.so
#8  0x03223ce2 in intelClearWithBlit () from /usr/lib/dri/i965_dri.so
#9  0x032264c0 in ?? () from /usr/lib/dri/i965_dri.so
#10 0x047b2512 in _mesa_Clear () from /usr/lib/dri/libdricore.so
#11 0x0056884b in KWin::SceneOpenGL::paintBackground (this=0x90bd0b8, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x0055f562 in KWin::Scene::paintGenericScreen (this=0x90bd0b8, orig_mask=40) at ../../kwin/scene.cpp:188
#13 0x00568a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x90bd0b8, mask=40, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x0055c7c0 in KWin::Scene::finalPaintScreen (this=0x90bd0b8, mask=40, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x0057e0fc in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x054c20e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x9537dc8, mask=40, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x00e33256 in KWin::Effect::paintScreen (this=0x95b8fb0, mask=40, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x0546407f in KWin::LogoutEffect::paintScreen (this=0x961fdb0, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x0547fb10 in KWin::ShadowEffect::paintScreen (this=0x95b6090, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=40, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x05494013 in KWin::BlurEffect::paintScreen (this=0x94478e8, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x05468e6f in KWin::PresentWindowsEffect::paintScreen (this=0x944c7b0, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x00e33256 in KWin::Effect::paintScreen (this=0x94be888, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x00e33256 in KWin::Effect::paintScreen (this=0x955ffc8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x00e33256 in KWin::Effect::paintScreen (this=0x9427ab8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x00e33256 in KWin::Effect::paintScreen (this=0x94a2f70, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x0544f7e9 in KWin::DesktopGridEffect::paintScreen (this=0x944c0d0, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#37 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x05448799 in KWin::BoxSwitchEffect::paintScreen (this=0x959c648, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#39 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x054a2bcc in KWin::CubeEffect::paintScreen (this=0x9603898, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#41 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x00e33256 in KWin::Effect::paintScreen (this=0x94f79c8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#43 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x054abdf0 in KWin::CubeSlideEffect::paintScreen (this=0x961fbe8, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#45 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x00e33256 in KWin::Effect::paintScreen (this=0x9566420, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#47 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x00e33256 in KWin::Effect::paintScreen (this=0x9609fc8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x0549ba0c in KWin::CoverSwitchEffect::paintScreen (this=0x94e17e0, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#51 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x00e33256 in KWin::Effect::paintScreen (this=0x944a348, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#53 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x00e33256 in KWin::Effect::paintScreen (this=0x95b9440, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x054910c1 in KWin::ZoomEffect::paintScreen (this=0x9539ba8, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#57 0x0057e172 in KWin::EffectsHandlerImpl::paintScreen (this=0x9249dc0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x0055d98c in KWin::Scene::paintScreen (this=0x90bd0b8, mask=0xbf8c3658, region=0xbf8c36e0) at ../../kwin/scene.cpp:137
#59 0x00574962 in KWin::SceneOpenGL::paint (this=0x90bd0b8, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#60 0x00559886 in KWin::Workspace::performCompositing (this=0x93e8660) at ../../kwin/composite.cpp:448
#61 0x08b5a214 in QObject::event (this=0x93e8660, e=0xbf8c3c0c) at kernel/qobject.cpp:1190
#62 0x01619d24 in QApplicationPrivate::notify_helper (this=0x8ffe460, receiver=0x93e8660, e=0xbf8c3c0c) at kernel/qapplication.cpp:4462
#63 0x0161e8ce in QApplication::notify (this=0xbf8c3f24, receiver=0x93e8660, e=0xbf8c3c0c) at kernel/qapplication.cpp:3862
#64 0x010b13ca in KApplication::notify (this=0xbf8c3f24, receiver=0x93e8660, event=0xbf8c3c0c) at ../../kdeui/kernel/kapplication.cpp:311
#65 0x004e8abf in KWin::Application::notify (this=0xbf8c3f24, o=0x93e8660, e=0xbf8c3c0c) at ../../kwin/main.cpp:376
#66 0x08b450bb in QCoreApplication::notifyInternal (this=0xbf8c3f24, receiver=0x93e8660, event=0xbf8c3c0c) at kernel/qcoreapplication.cpp:731
#67 0x08b751e4 in sendEvent (this=0x90003b8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#68 QTimerInfoList::activateTimers (this=0x90003b8) at kernel/qeventdispatcher_unix.cpp:604
#69 0x08b75338 in QEventDispatcherUNIX::processEvents (this=0x8fbdaa8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#70 0x016ce7ea in QEventDispatcherX11::processEvents (this=0x8fbdaa8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#71 0x08b44289 in QEventLoop::processEvents (this=0xbf8c3e64, flags=...) at kernel/qeventloop.cpp:149
#72 0x08b44522 in QEventLoop::exec (this=0xbf8c3e64, flags=...) at kernel/qeventloop.cpp:201
#73 0x08b48ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#74 0x016178e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#75 0x004eb5b2 in kdemain (argc=3, argv=0xbf8c41a4) at ../../kwin/main.cpp:542
#76 0x080485bb in main (argc=3, argv=0xbf8c41a4) at kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 271396, bug 270557, bug 269938, bug 269889, bug 269314.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-04-21 23:15:25 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***