Bug 271666 - Break Down of Kde NetworkManager
Summary: Break Down of Kde NetworkManager
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-25 07:34 UTC by r-kloeppelt
Modified: 2011-04-25 19:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description r-kloeppelt 2011-04-25 07:34:23 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.7-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
I wanted to change the domain the computer belongs to

The crash can be reproduced every time.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  ref (this=0x814fc80) at /usr/include/QtCore/qatomic_i386.h:120
#7  QString (this=0x814fc80) at /usr/include/QtCore/qstring.h:715
#8  Knm::Activatable::deviceUni (this=0x814fc80) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#9  0xb6f4c970 in compareDevices (first=0x814fc80, second=0x814fb28) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:262
#10 0xb6f4ccd2 in activatableLessThan (first=0x814fc80, second=0x814fb28) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:172
#11 0xb6f4d7e0 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x81246b4, lessThan=0xb6f4cca0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:356
#12 0xb6f4d5f3 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8153a00, activatable=0x81be300)
    at /usr/include/QtCore/qalgorithms.h:187
#13 SortedActivatableList::handleAdd (this=0x8153a00, activatable=0x81be300) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#14 0xb6f3c1d4 in ActivatableList::notifyOnAddActivatable (this=0x8130958, activatable=0x81be300) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:99
#15 0xb6f3c253 in ActivatableList::addActivatable (this=0x8130958, activatable=0x81be300) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:83
#16 0xb6f40126 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x8138cb0, addedConnection=0x8152660)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#17 0xb6f3d8e9 in NetworkInterfaceActivatableProvider::init (this=0x8138cb0) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#18 0xb6f3cccd in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x81256f8, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:79
#19 0xb6f37b65 in NetworkInterfaceMonitor::qt_metacall (this=0x81256f8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd90af8)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#20 0xb6d19efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#21 0xb6d28fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#22 0xb6ec0195 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x813c810, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager.moc:107
#23 0xb6ec07cc in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x813c810, uni=...) at /usr/src/debug/kdebase-workspace-4.4.4/libs/solid/control/networkmanager.cpp:197
#24 0xb6ec084e in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x813c810, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd90c58)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager_p.moc:81
#25 0xb6d19efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#26 0xb6d28fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#27 0xb396a135 in NMNetworkManager::networkInterfaceAdded (this=0x811e258, _t1=...) at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:134
#28 0xb396f72a in NMNetworkManager::deviceAdded (this=0x811e258, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.4/solid/networkmanager-0.7/manager.cpp:199
#29 0xb3979f73 in NMNetworkManager::qt_metacall (this=0x811e258, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfd90dd8)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:111
#30 0xb6d19efd in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#31 0xb6d28fe8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#32 0xb396b745 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x8149ff0, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#33 0xb3974b7f in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x8149ff0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd9100c)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#34 0xb6e4ea37 in QDBusConnectionPrivate::deliverCall (this=0x811e870, object=0x8149ff0, msg=..., metaTypes=..., slotIdx=-1076296100) at qdbusintegrator.cpp:904
#35 0xb6e5c536 in QDBusCallDeliveryEvent::placeMetaCall (this=0x81e7cf0, object=0x8149ff0) at qdbusintegrator_p.h:101
#36 0xb6d2693f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#37 0xb6268c64 in QApplicationPrivate::notify_helper (this=0x80953f0, receiver=0x8149ff0, e=0x81e7cf0) at kernel/qapplication.cpp:4302
#38 0xb6270bf7 in QApplication::notify (this=0xbfd91870, receiver=0x8149ff0, e=0x81e7cf0) at kernel/qapplication.cpp:3706
#39 0xb71de9d1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#40 0xb6d13e0e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#41 0xb6d179b4 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#42 0xb6d17b9c in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#43 0xb6d3f83d in ?? () from /usr/lib/libQtCore.so.4
#44 0xb5a07b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#45 0xb5a08350 in ?? () from /usr/lib/libglib-2.0.so.0
#46 0xb5a0860e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#47 0xb6d3fd4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0xb631919a in QGuiEventDispatcherGlib::processEvents (this=0x8078610, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0xb6d1311d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#50 0xb6d13319 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#51 0xb6d17c70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#52 0xb6266164 in QApplication::exec () at kernel/qapplication.cpp:3581
#53 0x08053e59 in _start ()

Possible duplicates by query: bug 267500, bug 265797, bug 260637, bug 259221, bug 258762.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-04-25 19:56:49 UTC
This particular crash when NetworkManager restart is already fixed. There are still other more rare crashes yet to fix that are much more difficult to solve. Anyway, you must upgrade your Plasma NM package. I am afraid there is no OpenSuse 11.3 package upgrade with this particular crash fixed. The one used in OpenSuse 11.4 contains the fix, but it is also old (from November of last year) and contains other bugs (including crashes) that are already fixed in the repository. I think it would be better if you contact OpenSuse to ask them if there is a update with the critical bugs fixed.

*** This bug has been marked as a duplicate of bug 210878 ***