Bug 267500 - network manager fails to reconect after kdm restart (logoff + logon)
Summary: network manager fails to reconect after kdm restart (logoff + logon)
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-02 21:10 UTC by shani
Modified: 2011-03-03 05:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shani 2011-03-02 21:10:48 UTC
Application: kded4 ($Id: kded.cpp 1204125 2010-12-06 11:17:10Z dfaure $)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.38-5-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: i loged of and on and found out that the network interface fails to reconnect ... so i restarted network-manager (sudo restart network-manager). the wlan0 reconected but the system told me that it crashed.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7873930 (LWP 1554))]

Thread 3 (Thread 0xb4413b70 (LWP 1557)):
#0  0x00799e36 in clock_gettime () from /lib/librt.so.1
#1  0x00b2550b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x00bfc6e5 in QTimerInfoList::updateCurrentTime (this=0x919c934) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00bfc72a in QTimerInfoList::timerWait (this=0x919c934, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00bfa7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb44130cc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00bfa83d in timerSourcePrepare (source=0x0, timeout=0x79dff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x03ad9e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x03ada279 in ?? () from /lib/libglib-2.0.so.0
#9  0x03ada848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x00bfa59f in QEventDispatcherGlib::processEvents (this=0x919a9c8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x00bca609 in QEventLoop::processEvents (this=0xb44132a0, flags=) at kernel/qeventloop.cpp:149
#12 0x00bcaa8a in QEventLoop::exec (this=0xb44132a0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00ac6b7e in QThread::exec (this=0x9056d80) at thread/qthread.cpp:490
#14 0x089e9eb6 in ?? () from /usr/lib/kde4/kded_bluedevil.so
#15 0x00ac9df9 in QThreadPrivate::start (arg=0x9056d80) at thread/qthread_unix.cpp:266
#16 0x05975cc9 in start_thread () from /lib/libpthread.so.0
#17 0x0557969e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb3affb70 (LWP 1562)):
#0  0x0558715f in ?? () from /lib/libc.so.6
#1  0x0556ae08 in poll () from /lib/libc.so.6
#2  0x03ae7a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0x03ada43c in ?? () from /lib/libglib-2.0.so.0
#4  0x03ada848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x00bfa59f in QEventDispatcherGlib::processEvents (this=0x919caa8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x00bca609 in QEventLoop::processEvents (this=0xb3aff290, flags=) at kernel/qeventloop.cpp:149
#7  0x00bcaa8a in QEventLoop::exec (this=0xb3aff290, flags=...) at kernel/qeventloop.cpp:201
#8  0x00ac6b7e in QThread::exec (this=0xb3b03460) at thread/qthread.cpp:490
#9  0x00ba935b in QInotifyFileSystemWatcherEngine::run (this=0xb3b03460) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00ac9df9 in QThreadPrivate::start (arg=0xb3b03460) at thread/qthread_unix.cpp:266
#11 0x05975cc9 in start_thread () from /lib/libpthread.so.0
#12 0x0557969e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7873930 (LWP 1554)):
[KCrash Handler]
#7  ref (this=0x9271a40) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#8  QString (this=0x9271a40) at /usr/include/qt4/QtCore/qstring.h:728
#9  Knm::Activatable::deviceUni (this=0x9271a40) at ../../../libs/internals/activatable.cpp:51
#10 0x06a99300 in compareDevices (first=0x92093e8, second=0x9271a40) at ../../../libs/service/sortedactivatablelist.cpp:263
#11 0x06a9940c in activatableLessThan (first=0x92093e8, second=0x9271a40) at ../../../libs/service/sortedactivatablelist.cpp:172
#12 0x06a9968e in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=) at /usr/include/qt4/QtCore/qalgorithms.h:351
#13 0x06a99982 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x91ff4b8, activatable=0x92093e8) at /usr/include/qt4/QtCore/qalgorithms.h:187
#14 SortedActivatableList::handleAdd (this=0x91ff4b8, activatable=0x92093e8) at ../../../libs/service/sortedactivatablelist.cpp:96
#15 0x06a87ac3 in ActivatableList::notifyOnAddActivatable (this=0x91deb20, activatable=0x92093e8) at ../../../libs/service/activatablelist.cpp:99
#16 0x06a88318 in ActivatableList::addActivatable (this=0x91deb20, activatable=0x92093e8) at ../../../libs/service/activatablelist.cpp:83
#17 0x06a8c5c6 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x92061d0, addedConnection=0x9202b98) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#18 0x06a8b5c4 in WirelessNetworkInterfaceActivatableProvider::networkAppeared (this=0x92061d0, ssid=...) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:176
#19 0x06a8bf71 in WirelessNetworkInterfaceActivatableProvider::WirelessNetworkInterfaceActivatableProvider (this=0x92061d0, connectionList=0x91b76d0, activatableList=0x91deb20, interface=0x9270b18, parent=0x91b3100, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:76
#20 0x06a88a1c in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x91b3100, uni=...) at ../../../libs/service/networkinterfacemonitor.cpp:75
#21 0x06a820eb in NetworkInterfaceMonitor::qt_metacall (this=0x91b3100, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbff9baf8) at moc_networkinterfacemonitor.cpp:75
#22 0x00bd18ca in QMetaObject::metacall (object=0x91b3100, cl=3220812936, idx=4, argv=0xbff9baf8) at kernel/qmetaobject.cpp:237
#23 0x00be46ad in QMetaObject::activate (sender=0x91ec228, m=0x3034580, local_signal_index=1, argv=0xbff9b518) at kernel/qobject.cpp:3280
#24 0x03015893 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x91ec228, _t1=...) at ./networkmanager.moc:110
#25 0x03016376 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x91ec228, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:199
#26 0x030163f7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x91ec228, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbff9bc68) at ./networkmanager_p.moc:81
#27 0x00bd18ca in QMetaObject::metacall (object=0x91ec228, cl=3220812936, idx=11, argv=0xbff9bc68) at kernel/qmetaobject.cpp:237
#28 0x00be46ad in QMetaObject::activate (sender=0x91f3a88, m=0x661e838, local_signal_index=1, argv=0xbff9b518) at kernel/qobject.cpp:3280
#29 0x0661b423 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x91f3a88, _t1=...) at ./networkmanager.moc:118
#30 0x088072ea in NMNetworkManager::deviceAdded (this=0x91f3a88, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:214
#31 0x0880b595 in NMNetworkManager::qt_metacall (this=0x91f3a88, _c=QMetaObject::InvokeMetaMethod, _id=16, _a=0xbff9be08) at ./manager.moc:95
#32 0x00bd18ca in QMetaObject::metacall (object=0x91f3a88, cl=3220812936, idx=16, argv=0xbff9be08) at kernel/qmetaobject.cpp:237
#33 0x00be46ad in QMetaObject::activate (sender=0x919eca8, m=0x8821a80, local_signal_index=0, argv=0xbff9b518) at kernel/qobject.cpp:3280
#34 0x08816be3 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x919eca8, _t1=...) at ./nm-manager-clientinterface.moc:161
#35 0x088170ed in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x919eca8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbff9c07c) at ./nm-manager-clientinterface.moc:105
#36 0x070049dc in QDBusConnectionPrivate::deliverCall (this=0x918a0a0, object=0x919eca8, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:919
#37 0x070101f7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9202378, object=0x919eca8) at qdbusintegrator_p.h:103
#38 0x00bde6a2 in QObject::event (this=0x919eca8, e=0x0) at kernel/qobject.cpp:1219
#39 0x00f5efdc in QApplicationPrivate::notify_helper (this=0x90cc5f0, receiver=0x919eca8, e=0x9202378) at kernel/qapplication.cpp:4396
#40 0x00f6504e in QApplication::notify (this=0xbff9c950, receiver=0x919eca8, e=0x9202378) at kernel/qapplication.cpp:3798
#41 0x00319f7a in KApplication::notify (this=0xbff9c950, receiver=0x919eca8, event=0x9202378) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x00bcbb3b in QCoreApplication::notifyInternal (this=0xbff9c950, receiver=0x919eca8, event=0x9202378) at kernel/qcoreapplication.cpp:732
#43 0x00bced8b in sendEvent (receiver=0x0, event_type=0, data=0x902af20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x902af20) at kernel/qcoreapplication.cpp:1373
#45 0x00bcef4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#46 0x00bfaa74 in sendPostedEvents (s=0x90ce910) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#47 postEventSourceDispatch (s=0x90ce910) at kernel/qeventdispatcher_glib.cpp:277
#48 0x03ad6855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#49 0x03ada668 in ?? () from /lib/libglib-2.0.so.0
#50 0x03ada848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#51 0x00bfa565 in QEventDispatcherGlib::processEvents (this=0x90bdfc0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#52 0x01020be5 in QGuiEventDispatcherGlib::processEvents (this=0x90bdfc0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x00bca609 in QEventLoop::processEvents (this=0xbff9c8a4, flags=) at kernel/qeventloop.cpp:149
#54 0x00bcaa8a in QEventLoop::exec (this=0xbff9c8a4, flags=...) at kernel/qeventloop.cpp:201
#55 0x00bcf00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#56 0x00f5de07 in QApplication::exec () at kernel/qapplication.cpp:3672
#57 0x072ed9b7 in kdemain (argc=1, argv=0x907a5e8) at ../../kded/kded.cpp:925
#58 0x0804e739 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x0, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x8051c2b "0") at ../../kinit/kinit.cpp:742
#59 0x08050899 in main (argc=4, argv=0xbff9d124, envp=0xbff9d138) at ../../kinit/kinit.cpp:1857

Possible duplicates by query: bug 257453, bug 256779.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-03-03 05:27:34 UTC

*** This bug has been marked as a duplicate of bug 210878 ***