Bug 265797 - KnetworkManager Crash
Summary: KnetworkManager Crash
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-08 14:05 UTC by sz.zoli1990
Modified: 2011-02-08 16:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sz.zoli1990 2011-02-08 14:05:22 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.7-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
From the yast2 menu I choose the install hypervisor. The yast2 all packages are downloaded and installed. After that the yast2 run something "Network bridge setup" And the network manager crashed.

-- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4ebb710 (LWP 2605))]

Thread 2 (Thread 0xb26f4b70 (LWP 2623)):
#0  0xb595822b in clock_gettime () from /lib/librt.so.1
#1  0xb6c8e265 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6d61d26 in updateCurrentTime (this=0x814e8bc, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x814e8bc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb6d6055b in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb26f411c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb6d605fd in timerSourcePrepare (source=0x814e888, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb58ac0c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#8  0xb58acf22 in ?? () from /usr/lib/libglib-2.0.so.0
#9  0xb58ad60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#10 0xb6d60da7 in QEventDispatcherGlib::processEvents (this=0x816ddc0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb6d3189d in QEventLoop::processEvents (this=0xb26f42b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb6d31ac9 in QEventLoop::exec (this=0xb26f42b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb6c307a9 in QThread::exec (this=0x8160cd8) at thread/qthread.cpp:490
#14 0xb6d114ad in QInotifyFileSystemWatcherEngine::run (this=0x8160cd8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6c3339a in QThreadPrivate::start (arg=0x8160cd8) at thread/qthread_unix.cpp:285
#16 0xb5e99b25 in start_thread () from /lib/libpthread.so.0
#17 0xb5f8246e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb4ebb710 (LWP 2605)):
[KCrash Handler]
#7  ref (this=0x81c1538) at /usr/include/QtCore/qatomic_i386.h:120
#8  QString (this=0x81c1538) at /usr/include/QtCore/qstring.h:729
#9  Knm::Activatable::deviceUni (this=0x81c1538) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#10 0xb6f91fbb in compareDevices (first=0x81c3788, second=0x81c1538) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:264
#11 0xb6f922f2 in activatableLessThan (first=0x81c3788, second=0x81c1538) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:173
#12 0xb6f92db5 in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x81433bc, lessThan=0xb6f922c0 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:351
#13 0xb6f92663 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x813ef38, activatable=0x81c3788)
    at /usr/include/QtCore/qalgorithms.h:187
#14 SortedActivatableList::handleAdd (this=0x813ef38, activatable=0x81c3788) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#15 0xb6f80444 in ActivatableList::notifyOnAddActivatable (this=0x814ba80, activatable=0x81c3788) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:120
#16 0xb6f804c3 in ActivatableList::addActivatable (this=0x814ba80, activatable=0x81c3788) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:104
#17 0xb6f84756 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x834be08, addedConnection=0x81c3950)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#18 0xb6f820d9 in NetworkInterfaceActivatableProvider::init (this=0x834be08) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#19 0xb6f812be in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x816fee8, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:87
#20 0xb6f7ba45 in NetworkInterfaceMonitor::qt_metacall (this=0x816fee8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfbb6a68)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#21 0xb6d38e5d in QMetaObject::metacall (object=0x816fee8, cl=QMetaObject::InvokeMetaMethod, idx=4, argv=0xbfbb6a68) at kernel/qmetaobject.cpp:237
#22 0xb6d48ffc in QMetaObject::activate (sender=0x81547e0, m=0xb6f21580, local_signal_index=1, argv=0xbfbb6a68) at kernel/qobject.cpp:3272
#23 0xb6f00ea5 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x81547e0, _t1=...) at /usr/src/debug/kdebase-workspace-4.6.0/build/libs/solid/control/networkmanager.moc:110
#24 0xb6f0155c in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x81547e0, uni=...) at /usr/src/debug/kdebase-workspace-4.6.0/libs/solid/control/networkmanager.cpp:199
#25 0xb6f015de in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x81547e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfbb6bc8)
    at /usr/src/debug/kdebase-workspace-4.6.0/build/libs/solid/control/networkmanager_p.moc:81
#26 0xb6d38e5d in QMetaObject::metacall (object=0x81547e0, cl=QMetaObject::InvokeMetaMethod, idx=11, argv=0xbfbb6bc8) at kernel/qmetaobject.cpp:237
#27 0xb6d48ffc in QMetaObject::activate (sender=0x812e710, m=0xb27b4838, local_signal_index=1, argv=0xbfbb6bc8) at kernel/qobject.cpp:3272
#28 0xb27b08c5 in Solid::Control::Ifaces::NetworkManager::networkInterfaceAdded (this=0x812e710, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/build/libs/solid/control/ifaces/networkmanager.moc:118
#29 0xb27dce3a in NMNetworkManager::deviceAdded (this=0x812e710, objpath=...) at /usr/src/debug/kdebase-workspace-4.6.0/solid/networkmanager-0.7/manager.cpp:214
#30 0xb27e02db in NMNetworkManager::qt_metacall (this=0x812e710, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfbb6d48)
    at /usr/src/debug/kdebase-workspace-4.6.0/build/solid/networkmanager-0.7/manager.moc:95
#31 0xb6d38e5d in QMetaObject::metacall (object=0x812e710, cl=QMetaObject::InvokeMetaMethod, idx=16, argv=0xbfbb6d48) at kernel/qmetaobject.cpp:237
#32 0xb6d48ffc in QMetaObject::activate (sender=0x81627a0, m=0xb27f9a80, local_signal_index=0, argv=0xbfbb6d48) at kernel/qobject.cpp:3272
#33 0xb27eabf5 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x81627a0, _t1=...)
    at /usr/src/debug/kdebase-workspace-4.6.0/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:161
#34 0xb27eb0d7 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x81627a0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfbb6f9c)
    at /usr/src/debug/kdebase-workspace-4.6.0/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:105
#35 0xb6e8ce17 in QDBusConnectionPrivate::deliverCall (this=0x814c5d0, object=0x81627a0, msg=..., metaTypes=..., slotIdx=-1078237752) at qdbusintegrator.cpp:919
#36 0xb6e998d6 in QDBusCallDeliveryEvent::placeMetaCall (this=0x820e6b8, object=0x81627a0) at qdbusintegrator_p.h:103
#37 0xb6d47b7f in QObject::event (this=0x81627a0, e=0x820e6b8) at kernel/qobject.cpp:1211
#38 0xb624a414 in QApplicationPrivate::notify_helper (this=0x8098b68, receiver=0x81627a0, e=0x820e6b8) at kernel/qapplication.cpp:4445
#39 0xb6253137 in QApplication::notify (this=0xbfbb7800, receiver=0x81627a0, e=0x820e6b8) at kernel/qapplication.cpp:3845
#40 0xb723e6c1 in KApplication::notify (this=0xbfbb7800, receiver=0x81627a0, event=0x820e6b8) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#41 0xb6d325be in QCoreApplication::notifyInternal (this=0xbfbb7800, receiver=0x81627a0, event=0x820e6b8) at kernel/qcoreapplication.cpp:732
#42 0xb6d3634c in sendEvent (receiver=0x0, event_type=0, data=0x8075e48) at kernel/qcoreapplication.h:215
#43 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8075e48) at kernel/qcoreapplication.cpp:1373
#44 0xb6d3649c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#45 0xb6d60bd4 in sendPostedEvents (s=0x809af10) at kernel/qcoreapplication.h:220
#46 postEventSourceDispatch (s=0x809af10) at kernel/qeventdispatcher_glib.cpp:277
#47 0xb58acb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#48 0xb58ad350 in ?? () from /usr/lib/libglib-2.0.so.0
#49 0xb58ad60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#50 0xb6d60d5b in QEventDispatcherGlib::processEvents (this=0x8079650, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#51 0xb63009aa in QGuiEventDispatcherGlib::processEvents (this=0x8079650, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0xb6d3189d in QEventLoop::processEvents (this=0xbfbb7764, flags=...) at kernel/qeventloop.cpp:149
#53 0xb6d31ac9 in QEventLoop::exec (this=0xbfbb7764, flags=...) at kernel/qeventloop.cpp:201
#54 0xb6d36570 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#55 0xb6248114 in QApplication::exec () at kernel/qapplication.cpp:3719
#56 0x08054275 in _start ()

Possible duplicates by query: bug 260637, bug 259221, bug 258762, bug 257453, bug 256900.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-02-08 16:08:21 UTC

*** This bug has been marked as a duplicate of bug 210878 ***