Bug 259221 - network management crash
Summary: network management crash
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-08 16:57 UTC by Babak Nayebi
Modified: 2010-12-17 17:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Babak Nayebi 2010-12-08 16:57:29 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
Ikann not configure my usb wlan network toconnect to internet

The crash can be reproduced some of the time.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#5  ref (this=0x8762f0) at /usr/include/QtCore/qatomic_x86_64.h:121
#6  QString (this=0x8762f0) at /usr/include/QtCore/qstring.h:715
#7  Knm::Activatable::deviceUni (this=0x8762f0) at /usr/src/debug/networkmanagement/libs/internals/activatable.cpp:51
#8  0x00007f714b811718 in compareDevices (first=0x8762f0, second=0xb2f8d0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:262
#9  0x00007f714b811a43 in activatableLessThan (first=0x8762f0, second=0xb2f8d0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:172
#10 0x00007f714b81255a in QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=..., end=..., 
    t=@0x7c41d0, lessThan=0x7f714b811a20 <activatableLessThan(Knm::Activatable const*, Knm::Activatable const*)>) at /usr/include/QtCore/qalgorithms.h:356
#11 0x00007f714b812307 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x7533f0, activatable=0x7c1ae0)
    at /usr/include/QtCore/qalgorithms.h:187
#12 SortedActivatableList::handleAdd (this=0x7533f0, activatable=0x7c1ae0) at /usr/src/debug/networkmanagement/libs/service/sortedactivatablelist.cpp:96
#13 0x00007f714b802f53 in ActivatableList::notifyOnAddActivatable (this=<value optimized out>, activatable=0x7c1ae0) at /usr/src/debug/networkmanagement/libs/service/activatablelist.cpp:99
#14 0x00007f714b80685e in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=<value optimized out>, addedConnection=<value optimized out>)
    at /usr/src/debug/networkmanagement/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x00007f714b80445d in NetworkInterfaceActivatableProvider::init (this=0xc99830) at /usr/src/debug/networkmanagement/libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x00007f714b80399d in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...) at /usr/src/debug/networkmanagement/libs/service/networkinterfacemonitor.cpp:79
#17 0x00007f714b7fefbd in NetworkInterfaceMonitor::qt_metacall (this=0x755760, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffeed891a0)
    at /usr/src/debug/networkmanagement/build/libs/service/moc_networkinterfacemonitor.cpp:75
#18 0x00007f714adf2a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#19 0x00007f714b385945 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager.moc:107
#20 0x00007f714b385f17 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x715720, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffeed892c0)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/libs/solid/control/networkmanager_p.moc:81
#21 0x00007f714adf2a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#22 0x00007f714118d375 in NMNetworkManager::networkInterfaceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:134
#23 0x00007f7141191bea in NMNetworkManager::deviceAdded (this=0x7424f0, objpath=...) at /usr/src/debug/kdebase-workspace-4.4.4/solid/networkmanager-0.7/manager.cpp:199
#24 0x00007f714119b7c9 in NMNetworkManager::qt_metacall (this=0x7424f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffeed89480)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/manager.moc:111
#25 0x00007f714adf2a1f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#26 0x00007f714118e382 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:155
#27 0x00007f7141195b94 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x6fd310, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffeed898c0)
    at /usr/src/debug/kdebase-workspace-4.4.4/build/solid/networkmanager-0.7/nm-manager-clientinterface.moc:102
#28 0x00007f714b116188 in QDBusConnectionPrivate::deliverCall (this=0x733090, object=0x6fd310, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#29 0x00007f714b122ecf in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:101
#30 0x00007f714adf0509 in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#31 0x00007f714a1d04d4 in QApplicationPrivate::notify_helper (this=0x65bd60, receiver=0x6fd310, e=0xc56c40) at kernel/qapplication.cpp:4302
#32 0x00007f714a1d8aca in QApplication::notify (this=<value optimized out>, receiver=0x6fd310, e=0xc56c40) at kernel/qapplication.cpp:4185
#33 0x00007f714c0f2c06 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#34 0x00007f714addee4c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#35 0x00007f714ade25ba in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#36 0x00007f714ae07173 in ?? () from /usr/lib64/libQtCore.so.4
#37 0x00007f71462a1a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#38 0x00007f71462a2270 in ?? () from /usr/lib64/libglib-2.0.so.0
#39 0x00007f71462a2510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#40 0x00007f714ae0767f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007f714a27114e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00007f714adde292 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#43 0x00007f714adde495 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#44 0x00007f714ade288b in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#45 0x000000000040e88f in _start ()

Possible duplicates by query: bug 258762, bug 257453, bug 256900, bug 256779, bug 256631.

Reported using DrKonqi
Comment 1 Dario Andres 2010-12-17 17:22:23 UTC
[Comment from a bug triager]
This crash is being tracked at bug 210878. Merging. Thanks

*** This bug has been marked as a duplicate of bug 210878 ***