Bug 271038 - Crash when navigate on rekon
Summary: Crash when navigate on rekon
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-15 16:04 UTC by Alexandre Beaudoin
Modified: 2011-04-16 00:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Beaudoin 2011-04-15 16:04:00 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed : just navigate on rekon and I got the message that plasmoïde have crash

-- Backtrace:
Application: Espace de travail Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f44fb2cf7a0 (LWP 1548))]

Thread 2 (Thread 0x7f44d6077700 (LWP 1551)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f44d6076990 in ?? ()
#2  0x00007fffb4dff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f44fb2cf7a0 (LWP 1548)):
[KCrash Handler]
#6  0x00007f44f8931304 in KJob::isAutoDelete (this=0x3cf59a0) at ../../kdecore/jobs/kjob.cpp:353
#7  0x00007f44f89319b8 in KJob::emitResult (this=0x3cf59a0) at ../../kdecore/jobs/kjob.cpp:314
#8  0x00007f44db8dec73 in StatusNotifierItemJob::contextMenuReady (this=0x3cf59a0, menu=0x3c4bc80) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f44db8dece0 in StatusNotifierItemJob::qt_metacall (this=0x3cf59a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb4d5a850) at ./statusnotifieritemjob.moc:75
#10 0x00007f44f8278b27 in QMetaObject::activate (sender=0x2e019e0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f44f8593120) at kernel/qobject.cpp:3280
#11 0x00007f44db8d8c7f in StatusNotifierItemSource::contextMenuReady (this=0x3cf59a0, _t1=0x3c4bc80) at ./statusnotifieritemsource.moc:109
#12 0x00007f44db8ddbe4 in StatusNotifierItemSource::qt_metacall (this=0x2e019e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb4d5a940) at ./statusnotifieritemsource.moc:90
#13 0x00007f44f8278b27 in QMetaObject::activate (sender=0x2fea1c0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f44f8593120) at kernel/qobject.cpp:3280
#14 0x00007f44f0ae789c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007f44f0ae8a5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#16 0x00007f44f8278b27 in QMetaObject::activate (sender=0x3c4bc80, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f44f8593120) at kernel/qobject.cpp:3280
#17 0x00007f44f7810f40 in QMenu::qt_metacall (this=0x3c4bc80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb4d5adc0) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007f44f8269bf9 in QMetaMethod::invoke (this=0x7fffb4d5b070, object=0x3c4bc80, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#19 0x00007f44f826b306 in QMetaObject::invokeMethod (obj=0x3c4bc80, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#20 0x00007f44f0ae27c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#21 0x00007f44db8da1bb in StatusNotifierItemSource::contextMenu (this=0x2e019e0, x=1168, y=881) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#22 0x00007f44db8e02d8 in StatusNotifierItemJob::start (this=0x3cf59a0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#23 0x00007f44fa7b1b21 in Plasma::ServiceJob::qt_metacall (this=0x3cf59a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#24 0x00007f44db8decc0 in StatusNotifierItemJob::qt_metacall (this=0x3cf59a0, _c=QMetaObject::InvokeMetaMethod, _id=43047824, _a=0x7f44f8593120) at ./statusnotifieritemjob.moc:70
#25 0x00007f44f8272bde in QObject::event (this=0x3cf59a0, e=0x3cf59a0) at kernel/qobject.cpp:1219
#26 0x00007f44f73aafdc in QApplicationPrivate::notify_helper (this=0x2122e80, receiver=0x3cf59a0, e=0x2bde550) at kernel/qapplication.cpp:4396
#27 0x00007f44f73b0aed in QApplication::notify (this=0x2109300, receiver=0x3cf59a0, e=0x2bde550) at kernel/qapplication.cpp:4277
#28 0x00007f44f8efc156 in KApplication::notify (this=0x2109300, receiver=0x3cf59a0, event=0x2bde550) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x00007f44f8260cdc in QCoreApplication::notifyInternal (this=0x2109300, receiver=0x3cf59a0, event=0x2bde550) at kernel/qcoreapplication.cpp:732
#30 0x00007f44f8263c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x20b2560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x20b2560) at kernel/qcoreapplication.cpp:1373
#32 0x00007f44f828d653 in sendPostedEvents (s=0x21265e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0x21265e0) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f44ef7be342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f44ef7c22a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f44ef7c245c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f44f828d193 in QEventDispatcherGlib::processEvents (this=0x20b2070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f44f745da4e in QGuiEventDispatcherGlib::processEvents (this=0x3cf59a0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f44f825fa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f44f825fdec in QEventLoop::exec (this=0x7fffb4d5c300, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f44f8263ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f44faebba56 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f44fab1cd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffb4d5c6c8) at libc-start.c:226
#44 0x0000000000400669 in _start ()

Possible duplicates by query: bug 269604, bug 267737, bug 267524, bug 266351, bug 264910.

Reported using DrKonqi
Comment 1 Dario Andres 2011-04-16 00:12:21 UTC
Fixed in KDE SC 4.6: bug 241562

*** This bug has been marked as a duplicate of bug 241562 ***