Bug 266351 - Plasma crashed when updating rekonq
Summary: Plasma crashed when updating rekonq
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-15 03:56 UTC by Trent
Modified: 2011-03-06 22:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trent 2011-02-15 03:56:08 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I was updating rekonq after a new install of kubuntu-desktop onto Ubuntu.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f85286867a0 (LWP 2170))]

Thread 7 (Thread 0x7f84fffff700 (LWP 2172)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f84ffffe990 in ?? ()
#2  0x00007fffc55ff852 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 6 (Thread 0x7f84fa35f700 (LWP 2455)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f8522973334 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f8522c7e160) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f8522973369 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f8522c8c234) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f85201df953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f85252a2971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#5  0x00007f8527fa492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f8506fdb700 (LWP 3469)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f852552de3b in wait (this=<value optimized out>, mutex=0x187d890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x187d890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8521e2c524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1882450, th=0x3df9b30) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8521e2f72b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1882a80, th=0x3df9b30) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8521e2dc9f in ThreadWeaver::ThreadRunHelper::run (this=0x7f8506fdad00, parent=0x1882450, th=0x3df9b30) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f8521e2e1f8 in ThreadWeaver::Thread::run (this=0x3df9b30) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f852552d27e in QThreadPrivate::start (arg=0x3df9b30) at thread/qthread_unix.cpp:266
#8  0x00007f85201df953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f85252a2971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f8527fa492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f84eb9fd700 (LWP 3470)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f852552de3b in wait (this=<value optimized out>, mutex=0x187d890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x187d890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8521e2c524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1882450, th=0x2da09a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8521e2f72b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1882a80, th=0x2da09a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8521e2dc9f in ThreadWeaver::ThreadRunHelper::run (this=0x7f84eb9fcd00, parent=0x1882450, th=0x2da09a0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f8521e2e1f8 in ThreadWeaver::Thread::run (this=0x2da09a0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f852552d27e in QThreadPrivate::start (arg=0x2da09a0) at thread/qthread_unix.cpp:266
#8  0x00007f85201df953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f85252a2971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f8527fa492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f84eb1fc700 (LWP 3471)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f852552de3b in wait (this=<value optimized out>, mutex=0x187d890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x187d890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8521e2c524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1882450, th=0x3f2fc00) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8521e2f72b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1882a80, th=0x3f2fc00) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8521e2dc9f in ThreadWeaver::ThreadRunHelper::run (this=0x7f84eb1fbd00, parent=0x1882450, th=0x3f2fc00) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f8521e2e1f8 in ThreadWeaver::Thread::run (this=0x3f2fc00) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f852552d27e in QThreadPrivate::start (arg=0x3f2fc00) at thread/qthread_unix.cpp:266
#8  0x00007f85201df953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f85252a2971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f8527fa492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f84ea9fb700 (LWP 3472)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f852552de3b in wait (this=<value optimized out>, mutex=0x187d890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x187d890, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f8521e2c524 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1882450, th=0x3de66f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f8521e2f72b in ThreadWeaver::WorkingHardState::applyForWork (this=0x1882a80, th=0x3de66f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f8521e2dc9f in ThreadWeaver::ThreadRunHelper::run (this=0x7f84ea9fad00, parent=0x1882450, th=0x3de66f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f8521e2e1f8 in ThreadWeaver::Thread::run (this=0x3de66f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f852552d27e in QThreadPrivate::start (arg=0x3de66f0) at thread/qthread_unix.cpp:266
#8  0x00007f85201df953 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f85252a2971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f8527fa492d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f85286867a0 (LWP 2170)):
[KCrash Handler]
#6  0x00007f8525cf1304 in KJob::isAutoDelete (this=0x2d5b2a0) at ../../kdecore/jobs/kjob.cpp:353
#7  0x00007f8525cf19b8 in KJob::emitResult (this=0x2d5b2a0) at ../../kdecore/jobs/kjob.cpp:314
#8  0x00007f8508dcdc73 in StatusNotifierItemJob::contextMenuReady (this=0x2d5b2a0, menu=0x2e09060) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f8508dcdce0 in StatusNotifierItemJob::qt_metacall (this=0x2d5b2a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc54787a0) at ./statusnotifieritemjob.moc:75
#10 0x00007f8525638b27 in QMetaObject::activate (sender=0x2dd4320, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f8525953120) at kernel/qobject.cpp:3280
#11 0x00007f8508dc7c7f in StatusNotifierItemSource::contextMenuReady (this=0x2d5b2a0, _t1=0x2e09060) at ./statusnotifieritemsource.moc:109
#12 0x00007f8508dccbe4 in StatusNotifierItemSource::qt_metacall (this=0x2dd4320, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc5478890) at ./statusnotifieritemsource.moc:90
#13 0x00007f8525638b27 in QMetaObject::activate (sender=0x2aa39f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f8525953120) at kernel/qobject.cpp:3280
#14 0x00007f851dea789c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007f851dea8a5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#16 0x00007f8525638b27 in QMetaObject::activate (sender=0x2e09060, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f8525953120) at kernel/qobject.cpp:3280
#17 0x00007f8524bd0f40 in QMenu::qt_metacall (this=0x2e09060, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffc5478d10) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007f8525629bf9 in QMetaMethod::invoke (this=0x7fffc5478fc0, object=0x2e09060, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#19 0x00007f852562b306 in QMetaObject::invokeMethod (obj=0x2e09060, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#20 0x00007f851dea27c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#21 0x00007f8508dc91bb in StatusNotifierItemSource::contextMenu (this=0x2dd4320, x=1473, y=1030) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#22 0x00007f8508dcf2d8 in StatusNotifierItemJob::start (this=0x2d5b2a0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#23 0x00007f8527b71b21 in Plasma::ServiceJob::qt_metacall (this=0x2d5b2a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#24 0x00007f8508dcdcc0 in StatusNotifierItemJob::qt_metacall (this=0x2d5b2a0, _c=QMetaObject::InvokeMetaMethod, _id=13389280, _a=0x7f8525953120) at ./statusnotifieritemjob.moc:70
#25 0x00007f8525632bde in QObject::event (this=0x2d5b2a0, e=0x2d5b2a0) at kernel/qobject.cpp:1219
#26 0x00007f852476afdc in QApplicationPrivate::notify_helper (this=0xbda320, receiver=0x2d5b2a0, e=0x1491650) at kernel/qapplication.cpp:4396
#27 0x00007f8524770aed in QApplication::notify (this=0xbca350, receiver=0x2d5b2a0, e=0x1491650) at kernel/qapplication.cpp:4277
#28 0x00007f85262bc156 in KApplication::notify (this=0xbca350, receiver=0x2d5b2a0, event=0x1491650) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x00007f8525620cdc in QCoreApplication::notifyInternal (this=0xbca350, receiver=0x2d5b2a0, event=0x1491650) at kernel/qcoreapplication.cpp:732
#30 0x00007f8525623c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xb73560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xb73560) at kernel/qcoreapplication.cpp:1373
#32 0x00007f852564d653 in sendPostedEvents (s=0xbdda80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0xbdda80) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f851cb7e342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f851cb822a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f851cb8245c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f852564d193 in QEventDispatcherGlib::processEvents (this=0xb73070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f852481da4e in QGuiEventDispatcherGlib::processEvents (this=0x2d5b2a0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f852561fa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f852561fdec in QEventLoop::exec (this=0x7fffc547a250, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f8525623ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f852827ba56 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f8527edcd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffc547a618) at libc-start.c:226
#44 0x0000000000400669 in _start ()

Possible duplicates by query: bug 264910, bug 262582, bug 261018, bug 260710, bug 260279.

Reported using DrKonqi
Comment 1 Dario Andres 2011-03-06 22:13:37 UTC

*** This bug has been marked as a duplicate of bug 241562 ***