Bug 267737 - KPACKAGEKIT crash
Summary: KPACKAGEKIT crash
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-05 20:20 UTC by ARVIND RATHORE
Modified: 2011-03-06 22:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ARVIND RATHORE 2011-03-05 20:20:07 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-27-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

updating through kpackagekit.
The laptop is hp pavillion dv6 2005ax with amd.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f730e7e2780 (LWP 1810))]

Thread 2 (Thread 0x7f72e7fff700 (LWP 1814)):
#0  0x00007f730e1f3203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f7302f09009 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f7302f0945c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f730b8a81e6 in QEventDispatcherGlib::processEvents (this=0x1899e40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#4  0x00007f730b87aa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f730b87adec in QEventLoop::exec (this=0x7f72e7ffed90, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f730b7852fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f730b85a5f8 in QInotifyFileSystemWatcherEngine::run (this=0x1899350) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f730b78827e in QThreadPrivate::start (arg=0x1899350) at thread/qthread_unix.cpp:266
#9  0x00007f730b4fd971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#10 0x00007f730e1ff92d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f730e7e2780 (LWP 1810)):
[KCrash Handler]
#6  0x00007f730bf4c304 in KJob::isAutoDelete (this=0x2740370) at ../../kdecore/jobs/kjob.cpp:353
#7  0x00007f730bf4c9b8 in KJob::emitResult (this=0x2740370) at ../../kdecore/jobs/kjob.cpp:314
#8  0x00007f72f0f0fc73 in StatusNotifierItemJob::contextMenuReady (this=0x2740370, menu=0x26daa20) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f72f0f0fce0 in StatusNotifierItemJob::qt_metacall (this=0x2740370, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff448c03a0) at ./statusnotifieritemjob.moc:75
#10 0x00007f730b893b27 in QMetaObject::activate (sender=0x26e37d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f730bbae120) at kernel/qobject.cpp:3280
#11 0x00007f72f0f09c7f in StatusNotifierItemSource::contextMenuReady (this=0x2740370, _t1=0x26daa20) at ./statusnotifieritemsource.moc:109
#12 0x00007f72f0f0ebe4 in StatusNotifierItemSource::qt_metacall (this=0x26e37d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff448c0490) at ./statusnotifieritemsource.moc:90
#13 0x00007f730b893b27 in QMetaObject::activate (sender=0x272c3e0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f730bbae120) at kernel/qobject.cpp:3280
#14 0x00007f730422e89c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/libdbusmenu-qt.so.2
#15 0x00007f730422fa5c in DBusMenuImporter::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libdbusmenu-qt.so.2
#16 0x00007f730b893b27 in QMetaObject::activate (sender=0x26daa20, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7f730bbae120) at kernel/qobject.cpp:3280
#17 0x00007f730ae2bf40 in QMenu::qt_metacall (this=0x26daa20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff448c0910) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007f730b884bf9 in QMetaMethod::invoke (this=0x7fff448c0bc0, object=0x26daa20, connectionType=<value optimized out>, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1575
#19 0x00007f730b886306 in QMetaObject::invokeMethod (obj=0x26daa20, member=<value optimized out>, type=<value optimized out>, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1148
#20 0x00007f73042297c1 in DBusMenuImporter::updateMenu() () from /usr/lib/libdbusmenu-qt.so.2
#21 0x00007f72f0f0b1bb in StatusNotifierItemSource::contextMenu (this=0x26e37d0, x=1101, y=750) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:474
#22 0x00007f72f0f112d8 in StatusNotifierItemJob::start (this=0x2740370) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#23 0x00007f730ddccb21 in Plasma::ServiceJob::qt_metacall (this=0x2740370, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>) at ./servicejob.moc:72
#24 0x00007f72f0f0fcc0 in StatusNotifierItemJob::qt_metacall (this=0x2740370, _c=QMetaObject::InvokeMetaMethod, _id=15191984, _a=0x7f730bbae120) at ./statusnotifieritemjob.moc:70
#25 0x00007f730b88dbde in QObject::event (this=0x2740370, e=0x2740370) at kernel/qobject.cpp:1219
#26 0x00007f730a9c5fdc in QApplicationPrivate::notify_helper (this=0xd8a960, receiver=0x2740370, e=0x26fb800) at kernel/qapplication.cpp:4396
#27 0x00007f730a9cbaed in QApplication::notify (this=0xd7a0e0, receiver=0x2740370, e=0x26fb800) at kernel/qapplication.cpp:4277
#28 0x00007f730c517156 in KApplication::notify (this=0xd7a0e0, receiver=0x2740370, event=0x26fb800) at ../../kdeui/kernel/kapplication.cpp:310
#29 0x00007f730b87bcdc in QCoreApplication::notifyInternal (this=0xd7a0e0, receiver=0x2740370, event=0x26fb800) at kernel/qcoreapplication.cpp:732
#30 0x00007f730b87ec22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xd5f560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xd5f560) at kernel/qcoreapplication.cpp:1373
#32 0x00007f730b8a8653 in sendPostedEvents (s=0xd8d160) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#33 postEventSourceDispatch (s=0xd8d160) at kernel/qeventdispatcher_glib.cpp:277
#34 0x00007f7302f05342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f7302f092a8 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f7302f0945c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f730b8a8193 in QEventDispatcherGlib::processEvents (this=0xd5f070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#38 0x00007f730aa78a4e in QGuiEventDispatcherGlib::processEvents (this=0x2740370, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f730b87aa02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f730b87adec in QEventLoop::exec (this=0x7fff448c1e50, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f730b87eebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#42 0x00007f730e4d6a56 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#43 0x00007f730e137d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff448c2218) at libc-start.c:226
#44 0x0000000000400669 in _start ()

Possible duplicates by query: bug 267524, bug 266351, bug 264910, bug 262582, bug 261018.

Reported using DrKonqi
Comment 1 Dario Andres 2011-03-06 22:13:42 UTC
[Comment from a bug triager]
This is fixed in KDE SC 4.6.0 and later
Merging with bug 241562. Thanks

*** This bug has been marked as a duplicate of bug 241562 ***