Bug 269604 - Plasma en ocasiones no reconoce los eventos del mouse
Summary: Plasma en ocasiones no reconoce los eventos del mouse
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-28 12:29 UTC by Jeison Pacateque
Modified: 2011-04-11 23:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeison Pacateque 2011-03-28 12:29:08 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-default x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Cuando estoy trabajando, plasma deja de reconocer eventos del mouse asigandos al panel principal (Bandeja del sistemas, gestor de tareas y lanzador de aplicaciones)
Sucede cuando le doy a la opción desbloquear elementos gráficos.
- Unusual behavior I noticed:

-- Backtrace:
Application: Shell de escritorio Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7aa8c8b760 (LWP 2311))]

Thread 2 (Thread 0x7f7a8c294700 (LWP 2329)):
#0  0x00007f7aa6389503 in poll () from /lib64/libc.so.6
#1  0x00007f7aa31fb114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007f7aa31fb650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007f7aa797a976 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f7aa794f052 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f7aa794f265 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f7aa78641e4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f7aa7930968 in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f7aa7866a5e in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f7aa75d7a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f7aa639267d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7aa8c8b760 (LWP 2311)):
[KCrash Handler]
#6  KJob::isAutoDelete (this=0x28b6080) at /usr/src/debug/kdelibs-4.6.0/kdecore/jobs/kjob.cpp:353
#7  0x00007f7aa7d443a8 in KJob::emitResult (this=0x28b6080) at /usr/src/debug/kdelibs-4.6.0/kdecore/jobs/kjob.cpp:314
#8  0x00007f7a8ef23533 in StatusNotifierItemJob::contextMenuReady (this=0x28b6080, menu=0x22dea10) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f7a8ef235a0 in StatusNotifierItemJob::qt_metacall (this=0x28b6080, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff00d1c8d0) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.moc:75
#10 0x00007f7aa7964def in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#11 0x00007f7a8ef1ec1f in StatusNotifierItemSource::contextMenuReady (this=<value optimized out>, _t1=0x22dea10) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:109
#12 0x00007f7a8ef2226c in StatusNotifierItemSource::qt_metacall (this=0x72b7a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff00d1c9a0) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:90
#13 0x00007f7aa7964def in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#14 0x00007f7aa52353f0 in DBusMenuImporter::slotMenuAboutToShow (this=0x249b4d0) at /usr/src/debug/libdbusmenu-qt-0.6.6/src/dbusmenuimporter.cpp:518
#15 0x00007f7aa523a51c in DBusMenuImporter::qt_metacall (this=0x249b4d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff00d1ccb0) at /usr/src/debug/libdbusmenu-qt-0.6.6/build/src/dbusmenuimporter.moc:104
#16 0x00007f7aa7964def in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#17 0x00007f7aa6f34688 in QMenu::qt_metacall (this=0x22dea10, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff00d1cdd0) at .moc/release-shared/moc_qmenu.cpp:97
#18 0x00007f7aa79580cf in QMetaMethod::invoke(QObject*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) const () from /usr/lib64/libQtCore.so.4
#19 0x00007f7aa7959580 in QMetaObject::invokeMethod(QObject*, char const*, Qt::ConnectionType, QGenericReturnArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument, QGenericArgument) () from /usr/lib64/libQtCore.so.4
#20 0x00007f7aa5234b81 in invokeMethod (this=<value optimized out>) at /usr/include/QtCore/qobjectdefs.h:424
#21 DBusMenuImporter::updateMenu (this=<value optimized out>) at /usr/src/debug/libdbusmenu-qt-0.6.6/src/dbusmenuimporter.cpp:451
#22 0x00007f7a8ef1e80b in StatusNotifierItemSource::contextMenu (this=0x72b7a0, x=1122, y=6) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#23 0x00007f7a8ef23e57 in StatusNotifierItemJob::start (this=0x28b6080) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#24 0x00007f7a9e741115 in slotStart (this=0x28b6080, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x28ba730) at /usr/src/debug/kdelibs-4.6.0/plasma/servicejob.cpp:37
#25 Plasma::ServiceJob::qt_metacall (this=0x28b6080, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x28ba730) at /usr/src/debug/kdelibs-4.6.0/build/plasma/servicejob.moc:82
#26 0x00007f7a8ef23580 in StatusNotifierItemJob::qt_metacall (this=0x28b6080, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x28ba730) at /usr/src/debug/kdebase-workspace-4.6.0/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.moc:70
#27 0x00007f7aa7963a6a in QObject::event(QEvent*) () from /usr/lib64/libQtCore.so.4
#28 0x00007f7aa6afed14 in QApplicationPrivate::notify_helper (this=0x6a96e0, receiver=0x28b6080, e=0x28cf530) at kernel/qapplication.cpp:4445
#29 0x00007f7aa6b0722a in QApplication::notify (this=<value optimized out>, receiver=0x28b6080, e=0x28cf530) at kernel/qapplication.cpp:4324
#30 0x00007f7aa85f39e6 in KApplication::notify (this=0x69f680, receiver=0x28b6080, event=0x28cf530) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#31 0x00007f7aa794fbfc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/libQtCore.so.4
#32 0x00007f7aa79533f5 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/libQtCore.so.4
#33 0x00007f7aa797a783 in ?? () from /usr/lib64/libQtCore.so.4
#34 0x00007f7aa31fabd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#35 0x00007f7aa31fb3b0 in ?? () from /lib64/libglib-2.0.so.0
#36 0x00007f7aa31fb650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#37 0x00007f7aa797a91f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#38 0x00007f7aa6ba3d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f7aa794f052 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#40 0x00007f7aa794f265 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#41 0x00007f7aa79536ab in QCoreApplication::exec() () from /usr/lib64/libQtCore.so.4
#42 0x00007f7a97ff8da8 in kdemain (argc=1, argv=0x697770) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#43 0x00000000004075e9 in _start ()

Possible duplicates by query: bug 267737, bug 267524, bug 266351, bug 264910, bug 262582.

Reported using DrKonqi
Comment 1 Dario Andres 2011-04-09 14:05:46 UTC
The backtrace looks related to the one in bug 241562, but in KDE SC 4.6.0; it may be a new case.
Comment 2 Dario Andres 2011-04-09 14:07:11 UTC
@Traslantion from Spanish:
- What I was doing when the application crashed:
When I am working, Plasma stops processing mouse events for the main panel (system tray, task manager, application launchers). It usually happens when I unlock plasma widgets
Comment 3 Beat Wolf 2011-04-11 23:06:43 UTC

*** This bug has been marked as a duplicate of bug 241562 ***