Bug 270818 - Segfault in KWin::ARBBlurShader::init
Summary: Segfault in KWin::ARBBlurShader::init
Status: RESOLVED DOWNSTREAM
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 273694 274090 275325 279597 280337 281540 281692 281799 284307 284308 284375 284656 286479 287609 289910 290325 290390 290693 291743 292071 297632 299184 301054 302495 303995 306972 309625 311930 313923 319520 321613 321790 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-13 11:29 UTC by kovrov
Modified: 2013-06-30 13:11 UTC (History)
39 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
glxinfo (20.39 KB, text/plain)
2011-04-13 21:52 UTC, kovrov
Details
glxinfo (11.92 KB, text/plain)
2011-04-14 00:05 UTC, kovrov
Details
New crash information added by DrKonqi (27.13 KB, text/plain)
2012-01-15 17:43 UTC, rudolfwetzels
Details
New crash information added by DrKonqi (2.35 KB, text/plain)
2012-02-10 06:14 UTC, Hendy Irawan
Details
New crash information added by DrKonqi (7.33 KB, text/plain)
2012-04-20 10:31 UTC, asbaz
Details
New crash information added by DrKonqi (2.47 KB, text/plain)
2012-05-10 17:29 UTC, Valentin
Details
New crash information added by DrKonqi (2.50 KB, text/plain)
2012-06-10 10:48 UTC, darkfish
Details
New crash information added by DrKonqi (6.44 KB, text/plain)
2012-12-21 01:30 UTC, Sylvain Ste-Marie
Details
New crash information added by DrKonqi (2.70 KB, text/plain)
2013-03-02 00:23 UTC, Leo Flerlage
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kovrov 2011-04-13 11:29:25 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu Natty (development branch)

-- Information about the crash:
Kwin crashed on session start after cold boot. 

Related to Bug 270746 .

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9e3819b7a0 (LWP 1527))]

Thread 3 (Thread 0x7f9e1ce80700 (LWP 1531)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f9e1ce7fbd0 in ?? ()
#2  0x00007fff771ff7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f9e16fbf700 (LWP 1532)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9e3684d2a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9e36b66180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f9e3684d2d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f9e36b74254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f9e2e3cbd8c in start_thread (arg=0x7f9e16fbf700) at pthread_create.c:304
#4  0x00007f9e379ee04d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9e3819b7a0 (LWP 1527)):
[KCrash Handler]
#6  memcpy () at ../sysdeps/x86_64/memcpy.S:267
#7  0x00007f9e35287618 in __indirect_glProgramParameters4fvNV (target=1, index=17882580, num=17712064, params=<value optimized out>) at /usr/include/bits/string3.h:52
#8  0x00007f9e15e6826a in KWin::ARBBlurShader::init (this=0x110ddc0) at ../../../kwin/effects/blur/blurshader.cpp:473
#9  0x00007f9e15e65072 in KWin::BlurEffect::reconfigure (this=0x110dc10, flags=<value optimized out>) at ../../../kwin/effects/blur/blur.cpp:76
#10 0x00007f9e15e651d7 in KWin::BlurEffect::BlurEffect (this=0x110dc10) at ../../../kwin/effects/blur/blur.cpp:48
#11 0x00007f9e15e65286 in KWin::effect_create_kwin4_effect_blur () at ../../../kwin/effects/blur/blur.cpp:29
#12 0x00007f9e37d7a1eb in KWin::EffectsHandlerImpl::loadEffect (this=0xdfe6a0, name=...) at ../../kwin/effects.cpp:1128
#13 0x00007f9e37d7b3d1 in KWin::EffectsHandlerImpl::reconfigure (this=0xdfe6a0) at ../../kwin/effects.cpp:143
#14 0x00007f9e37d5604c in KWin::Workspace::setupCompositing (this=0xddf120) at ../../kwin/composite.cpp:216
#15 0x00007f9e37cd86b3 in KWin::Workspace::qt_metacall (this=0xddf120, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xdf9150) at ./workspace.moc:604
#16 0x00007f9e33dd349a in QObject::event (this=0xddf120, e=<value optimized out>) at kernel/qobject.cpp:1226
#17 0x00007f9e331809e4 in QApplicationPrivate::notify_helper (this=0xd10d20, receiver=0xddf120, e=0xdf1d40) at kernel/qapplication.cpp:4462
#18 0x00007f9e331853aa in QApplication::notify (this=<value optimized out>, receiver=0xddf120, e=0xdf1d40) at kernel/qapplication.cpp:4341
#19 0x00007f9e374e9866 in KApplication::notify (this=0x7fff771c4fd0, receiver=0xddf120, event=0xdf1d40) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007f9e33dbf49c in QCoreApplication::notifyInternal (this=0x7fff771c4fd0, receiver=0xddf120, event=0xdf1d40) at kernel/qcoreapplication.cpp:731
#21 0x00007f9e33dc2c25 in sendEvent (receiver=0x0, event_type=0, data=0xcb6b60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xcb6b60) at kernel/qcoreapplication.cpp:1372
#23 0x00007f9e33228a0d in sendPostedEvents (this=0xcb6340, flags=...) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#24 QEventDispatcherX11::processEvents (this=0xcb6340, flags=...) at kernel/qeventdispatcher_x11.cpp:75
#25 0x00007f9e33dbe882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f9e33dbeabc in QEventLoop::exec (this=0x7fff771c4f10, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007f9e33dc2ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#28 0x00007f9e37cf51ec in kdemain (argc=<value optimized out>, argv=0x7fff771c5668) at ../../kwin/main.cpp:542
#29 0x00007f9e37926eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff771c5668, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff771c5658) at libc-start.c:226
#30 0x0000000000400669 in _start ()

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-04-13 18:03:14 UTC
crashes in glGenProgramsARB(1, &program);
either the driver claims ARB shader support but doesn't actually provide or this is a memory corruption.

a) the crash occurs in the blur effect, so disbale blurring to workaround it
b) please specify your GPU, driver and mesa version (in doubt attach a dump of "glxinfo > my.glxinfo.txt")
c) there's a memory corruption prone statement in the lanczos filter, so set the scale method to "smooth" ("kcmshell4 kwincompositing" / "advanced" tab)
Comment 2 kovrov 2011-04-13 21:52:13 UTC
Created attachment 58927 [details]
glxinfo

(In reply to comment #1)
Comment 3 kovrov 2011-04-13 22:08:15 UTC
I would guess this is a memory corruption. As you can see I use Kubuntu Natty 64-bit. It was working fine before and got broken at some point around month ago. It's hard to say what exactly was changed - as it is an alpha release, updates happens almost daily. Quite often something breaks, but get fixed very quickly. Usually, but not this time.

I didn't bother to reinstall system, but I have tried daily live cd (same distro - Kubuntu Natty) and kwin crashes there as well.

My best guess that it is memcpy problem discussed here: https://bugzilla.redhat.com/show_bug.cgi?id=638477

Let me know if anything else is needed.
Comment 4 Thomas Lübking 2011-04-13 22:10:14 UTC
"server glx vendor string: SGI"
...
"OpenGL renderer string: Software Rasterizer"

are you running this in VirtualBox or sth. similar?
Comment 5 kovrov 2011-04-13 22:12:34 UTC
(In reply to comment #4)
> "server glx vendor string: SGI"
> ...
> "OpenGL renderer string: Software Rasterizer"
> 
> are you running this in VirtualBox or sth. similar?

No, it is normal (real) installation.
Comment 6 kovrov 2011-04-13 22:15:41 UTC
It is acer extensa 4630 laptop (intel gma 4500)
Comment 7 Martin Flöser 2011-04-13 22:50:47 UTC
could you please start kwin from a command line and paste the log output. The glxinfo does not 
match the crash. If it is software rasterizer OpenGL backend *should* not get enabled.
Comment 8 kovrov 2011-04-14 00:05:31 UTC
Created attachment 58936 [details]
glxinfo

Indeed it was software rendering. After countless removing/installing and reconfiguring packages I got hardware opengl.

KWin still crashes on enabling blur effect. Restarting kwin (with --replace) doesnt provide much info as for some reason it starts without any of desktop effect plugins. And I have no idea how to restart it normally after that.
Comment 9 Thomas Lübking 2011-04-14 20:42:58 UTC
> KWin still crashes on enabling blur effect
With the /very/ same backtrace? Otherwise please attach the current one or make a new bugreport.
Comment 10 kovrov 2011-04-18 20:00:07 UTC
Looks like this issue affects not only me..
http://blog.martin-graesslin.com/blog/2011/04/why-blur-does-not-work-in-kubuntu-natty-with-intel/
Comment 11 Thomas Lübking 2011-04-18 22:02:45 UTC
That's not the same issue as the original bug and you have so far not provided information on the current blur "crash" (if that means a segfault at all)
Comment 12 kovrov 2011-04-21 10:16:05 UTC
Sorry, cannot reproduce this anymore - after last update blur shader starts working for me again..
Comment 13 Thomas Lübking 2011-04-21 12:38:15 UTC
Given the invalid "software rasterizer" thing, the original bug has probably been a downstream issue (wrong/no driver installed or configured by either yourself or your distro)

I assume the follow-up issue was that blurring wasn't activatable (due to the issues in the post you linked. discussion around this is apparently ongoing ;-) and this has also been (temp.) "fixed" by your distro by either patching mesa or kwin. 

So i'll close this one - the other one is dealt as bug #270942
Comment 14 Martin Flöser 2011-05-20 17:30:26 UTC
*** Bug 273694 has been marked as a duplicate of this bug. ***
Comment 15 Thomas Lübking 2011-05-25 15:04:50 UTC
*** Bug 274090 has been marked as a duplicate of this bug. ***
Comment 16 Thomas Lübking 2011-06-10 10:14:29 UTC
*** Bug 275325 has been marked as a duplicate of this bug. ***
Comment 17 Thomas Lübking 2011-08-07 17:33:44 UTC
*** Bug 279597 has been marked as a duplicate of this bug. ***
Comment 18 Thomas Lübking 2011-08-18 13:24:56 UTC
*** Bug 280337 has been marked as a duplicate of this bug. ***
Comment 19 Thomas Lübking 2011-09-07 13:05:39 UTC
*** Bug 281540 has been marked as a duplicate of this bug. ***
Comment 20 Martin Flöser 2011-09-09 15:24:18 UTC
*** Bug 281692 has been marked as a duplicate of this bug. ***
Comment 21 Thomas Lübking 2011-09-11 13:05:16 UTC
*** Bug 281799 has been marked as a duplicate of this bug. ***
Comment 22 Thomas Lübking 2011-10-17 21:43:32 UTC
*** Bug 284307 has been marked as a duplicate of this bug. ***
Comment 23 Thomas Lübking 2011-10-17 22:25:10 UTC
*** Bug 284308 has been marked as a duplicate of this bug. ***
Comment 24 Martin Flöser 2011-10-18 17:11:24 UTC
*** Bug 284375 has been marked as a duplicate of this bug. ***
Comment 25 Thomas Lübking 2011-10-22 04:51:35 UTC
*** Bug 284656 has been marked as a duplicate of this bug. ***
Comment 26 Thomas Lübking 2011-11-13 12:46:03 UTC
*** Bug 286479 has been marked as a duplicate of this bug. ***
Comment 27 Martin Flöser 2011-12-10 09:11:50 UTC
*** Bug 287609 has been marked as a duplicate of this bug. ***
Comment 28 Thomas Lübking 2011-12-27 11:15:36 UTC
*** Bug 289910 has been marked as a duplicate of this bug. ***
Comment 29 Martin Flöser 2011-12-31 07:56:44 UTC
Git commit 8ecd9befaf80cdf5963b7ef24588679db7515b63 by Martin Gräßlin.
Committed on 31/12/2011 at 08:54.
Pushed by graesslin into branch 'KDE/4.8'.

Disable Lanczos and Blur for fglrx

Too many crash reports in the fglrx driver when using ARB shaders.
It's a pity to disable functionality for all fglrx users, but it's
better than crash reports.

Blur effect can still be enabled manually and Lanczos can still be
enabled through the environment variable.

REVIEW: 103556
Related: bug 286795

M  +4    -0    kwin/effects/blur/blur.cpp
M  +4    -0    kwin/lanczosfilter.cpp

http://commits.kde.org/kde-workspace/8ecd9befaf80cdf5963b7ef24588679db7515b63
Comment 30 Martin Flöser 2012-01-01 16:07:31 UTC
*** Bug 290325 has been marked as a duplicate of this bug. ***
Comment 31 Thomas Lübking 2012-01-02 14:59:47 UTC
*** Bug 290390 has been marked as a duplicate of this bug. ***
Comment 32 Thomas Lübking 2012-01-05 14:03:08 UTC
*** Bug 290693 has been marked as a duplicate of this bug. ***
Comment 33 rudolfwetzels 2012-01-15 17:43:10 UTC
Created attachment 67861 [details]
New crash information added by DrKonqi

kwin (4.7.2 (4.7.2) "release 5") on KDE Platform 4.7.2 (4.7.2) "release 5" using Qt 4.7.4

- What I was doing when the application crashed: 
go with the mouse pointer for windows toolbar

-- Backtrace (Reduced):
#7  0x00007faa5786dd05 in __indirect_glProgramParameters4fvNV (target=1, index=11061332, num=1470845824, params=0x7faa562332a0) at /usr/include/bits/string3.h:52
#8  0x00007faa5a3c1ed9 in KWin::LanczosShader::init (this=0xa8c6b0) at /usr/src/debug/kde-workspace-4.7.2/kwin/lanczosfilter.cpp:669
#9  0x00007faa5a3c252c in KWin::LanczosFilter::init (this=0x8dca80) at /usr/src/debug/kde-workspace-4.7.2/kwin/lanczosfilter.cpp:76
#10 0x00007faa5a3c2e10 in KWin::LanczosFilter::performPaint (this=0x8dca80, w=0x9dd5c0, mask=262, region=..., data=...) at /usr/src/debug/kde-workspace-4.7.2/kwin/lanczosfilter.cpp:170
#11 0x00007faa5a3a7257 in KWin::Scene::finalDrawWindow (this=0x8dd1d0, w=0x9dd5c0, mask=262, region=<optimized out>, data=<optimized out>) at /usr/src/debug/kde-workspace-4.7.2/kwin/scene.cpp:319
Comment 34 Thijs 2012-01-17 09:45:52 UTC
*** Bug 291743 has been marked as a duplicate of this bug. ***
Comment 35 Thomas Lübking 2012-01-20 21:56:23 UTC
*** Bug 292071 has been marked as a duplicate of this bug. ***
Comment 36 Hendy Irawan 2012-02-10 06:14:32 UTC
Created attachment 68668 [details]
New crash information added by DrKonqi

kwin (4.8.00 (4.8.0) on KDE Platform 4.8.00 (4.8.0 using Qt 4.7.4

- What I was doing when the application crashed:

Login to KDE Plasma Workspace.
Simply wait...
Then KWin crashes.

However KDE can then be used normally.

-- Backtrace (Reduced):
#6  __memcpy_ssse3_back () at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:1579
[...]
#8  0x00007ff43f5a778f in KWin::ARBBlurShader::init (this=0x2704170) at ../../../kwin/effects/blur/blurshader.cpp:471
#9  0x00007ff43f5a2d19 in KWin::BlurEffect::reconfigure (this=0x2704020, flags=<optimized out>) at ../../../kwin/effects/blur/blur.cpp:85
#10 0x00007ff43f5a2ff7 in KWin::BlurEffect::BlurEffect (this=0x2704020) at ../../../kwin/effects/blur/blur.cpp:53
#11 0x00007ff43f5a30f6 in KWin::effect_create_kwin4_effect_blur () at ../../../kwin/effects/blur/blur.cpp:34
Comment 37 Thomas Lübking 2012-02-10 06:52:50 UTC
"kcmshell4 kwincompositing", disable blur effect (2nd tab) and set the scale method to smooth (3rd tab)
for the records pleaSe also specify your gpu and mesa/driver version - in doubt run "kwin --replace&" fro konsole and post the output
Comment 38 Martin Flöser 2012-04-07 06:34:21 UTC
*** Bug 297632 has been marked as a duplicate of this bug. ***
Comment 39 asbaz 2012-04-20 10:31:19 UTC
Created attachment 70528 [details]
New crash information added by DrKonqi

kwin (4.8.2 (4.8.2)) on KDE Platform 4.8.2 (4.8.2) using Qt 4.8.1

Crashes on Boot. Restart Crashes aswell

-- Backtrace (Reduced):
#6  __memcpy_ssse3_back () at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:1579
[...]
#8  0x00007fdf45b23abf in KWin::ARBBlurShader::init (this=0x2a1a660) at ../../../kwin/effects/blur/blurshader.cpp:471
#9  0x00007fdf45b1f049 in KWin::BlurEffect::reconfigure (this=0x2a43e80, flags=<optimized out>) at ../../../kwin/effects/blur/blur.cpp:85
#10 0x00007fdf45b1f327 in KWin::BlurEffect::BlurEffect (this=0x2a43e80) at ../../../kwin/effects/blur/blur.cpp:53
#11 0x00007fdf45b1f426 in KWin::effect_create_kwin4_effect_blur () at ../../../kwin/effects/blur/blur.cpp:34
Comment 40 Martin Flöser 2012-05-01 17:27:40 UTC
*** Bug 299184 has been marked as a duplicate of this bug. ***
Comment 41 Valentin 2012-05-10 17:29:29 UTC
Created attachment 71003 [details]
New crash information added by DrKonqi

kwin (4.8.2 (4.8.2)) on KDE Platform 4.8.2 (4.8.2) using Qt 4.8.1

- What I was doing when the application crashed:
KWin sometimes crash after reboot or wake up.

-- Backtrace (Reduced):
#6  __memcpy_ssse3_back () at ../sysdeps/x86_64/multiarch/memcpy-ssse3-back.S:1516
#7  0x00007fd33f0a7846 in __indirect_glProgramParameters4fvNV (target=1, index=17650916, num=1124882296, params=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/string3.h:52
#8  0x00007fd32747714f in KWin::ARBBlurShader::init (this=0x10d54d0) at ../../../kwin/effects/blur/blurshader.cpp:471
#9  0x00007fd3274726d9 in KWin::BlurEffect::reconfigure (this=0x10d5380, flags=...) at ../../../kwin/effects/blur/blur.cpp:85
#10 0x00007fd3274729b7 in KWin::BlurEffect::BlurEffect (this=0x10d5380) at ../../../kwin/effects/blur/blur.cpp:53
Comment 42 Thomas Lübking 2012-06-02 13:45:08 UTC
*** Bug 301054 has been marked as a duplicate of this bug. ***
Comment 43 darkfish 2012-06-10 10:48:51 UTC
Created attachment 71695 [details]
New crash information added by DrKonqi

kwin (4.8.3 (4.8.3)) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.1

- What I was doing when the application crashed:

This has started happening since the past few days, every time I boot/restart my machine.
My current installation has the latest proprietary graphics driver from AMD instead of the fglrx found in the repos.

-- Backtrace (Reduced):
#6  __memcpy_ssse3 () at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:2822
[...]
#8  0x00007f4b16ec118f in KWin::ARBBlurShader::init (this=0x22b6c60) at ../../../kwin/effects/blur/blurshader.cpp:471
#9  0x00007f4b16ebc719 in KWin::BlurEffect::reconfigure (this=0x22b6b20, flags=...) at ../../../kwin/effects/blur/blur.cpp:85
#10 0x00007f4b16ebc9f7 in KWin::BlurEffect::BlurEffect (this=0x22b6b20) at ../../../kwin/effects/blur/blur.cpp:53
#11 0x00007f4b16ebcaf6 in KWin::effect_create_kwin4_effect_blur () at ../../../kwin/effects/blur/blur.cpp:34
Comment 44 Thomas Lübking 2012-06-10 10:57:00 UTC
fglrx users may:

- try the radeon driver (xf86-video-ati/ati-dri)
- try fglx with enforced direct rendering (late versions have been reported to be reliable) "KWIN_DIRECT_GL=1 kwin --replace &"
- remain staying away from the ARB shader using code (disable blur effect and set the scale method to smooth and esp. NOT accurate)
- ensure that this issue in fglrx is not caused by it's setup demands (afaik one has to run some script after un/installing it)
Comment 45 Thomas Lübking 2012-06-25 10:58:17 UTC
*** Bug 302495 has been marked as a duplicate of this bug. ***
Comment 46 Thomas Lübking 2012-07-24 10:25:27 UTC
*** Bug 303995 has been marked as a duplicate of this bug. ***
Comment 47 sophia 2012-08-10 09:23:50 UTC
1) What's the platform, ASIC, OS, driver you use? And how many displays connected to the ASIC?
2) How can I reproduce this issue? Can you provide the detailed steps?
As this issue occurs while enable Lanczos and Blur effects.
Blur effects can be enabled in the Desktop Effects. But how can I enable Lanczos through the environment variable?
3) Does the crash definitely can be seen while reboot the system? If not, is there any way that can increase the rate of the crash?
Comment 48 Thomas Lübking 2012-08-10 09:41:58 UTC
lanczos filter is enabled by setting the scale method to "accurate" (3rd tab in kwincompositing kcm)
Comment 49 Thomas Lübking 2012-09-18 12:43:59 UTC
*** Bug 306972 has been marked as a duplicate of this bug. ***
Comment 50 Martin Flöser 2012-10-25 09:33:06 UTC
Git commit 965892bf9737b6d4a3f7fcadc58ecf75c8bb2cf0 by Martin Gräßlin.
Committed on 09/10/2012 at 19:46.
Pushed by graesslin into branch 'master'.

Re-enable Blur/Lanczos for Catalyst on OpenGL 2

Given that the Catalyst driver is now supporting direct rendering and by
that can use the OpenGL 2 code path we do no longer need to force
disable the Blur effect and Lanczos filters which used to crash in the
ARB shader path.

The ARB shader path - which can only be used in OpenGL 1 - is kept
disabled for Catalyst.
Related: bug 286795
REVIEW: 106798

M  +1    -1    kwin/effects/blur/blur.cpp
M  +2    -2    kwin/lanczosfilter.cpp

http://commits.kde.org/kde-workspace/965892bf9737b6d4a3f7fcadc58ecf75c8bb2cf0
Comment 51 Martin Flöser 2012-11-06 05:26:18 UTC
*** Bug 309625 has been marked as a duplicate of this bug. ***
Comment 52 Thomas Lübking 2012-12-19 12:37:29 UTC
*** Bug 311930 has been marked as a duplicate of this bug. ***
Comment 53 Sylvain Ste-Marie 2012-12-21 01:30:37 UTC
Created attachment 75949 [details]
New crash information added by DrKonqi

kwin (4.8.5 (4.8.5)) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:login

- Unusual behavior I noticed: sometime i can restart with hotkey alt-shift F12, sometimes not

- Custom settings of the application: none

-- Backtrace (Reduced):
#6  __memcpy_sse2 () at ../sysdeps/x86_64/multiarch/../memcpy.S:377
#7  0x00007f110285f856 in __indirect_glProgramParameters4fvNV (target=1, index=27019012, num=109586296, params=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/string3.h:52
#8  0x00007f10e971020f in KWin::ARBBlurShader::init (this=0x19c46f0) at ../../../kwin/effects/blur/blurshader.cpp:471
#9  0x00007f10e970b799 in KWin::BlurEffect::reconfigure (this=0x19beec0, flags=...) at ../../../kwin/effects/blur/blur.cpp:85
#10 0x00007f10e970ba77 in KWin::BlurEffect::BlurEffect (this=0x19beec0) at ../../../kwin/effects/blur/blur.cpp:53
Comment 54 Martin Flöser 2013-01-26 15:01:02 UTC
*** Bug 313923 has been marked as a duplicate of this bug. ***
Comment 55 Leo Flerlage 2013-03-02 00:23:10 UTC
Created attachment 77677 [details]
New crash information added by DrKonqi

kwin (4.8.5 (4.8.5) "release 2") on KDE Platform 4.8.5 (4.8.5) "release 2" using Qt 4.8.1

- What I was doing when the application crashed:

Crashes on a fresh login.  Will happen after I do a fresh reboot as well.

-- Backtrace (Reduced):
#6  0x00007f8030572d1b in memcpy (__len=<optimized out>, __src=<optimized out>, __dest=<optimized out>) at /usr/include/bits/string3.h:52
#7  __indirect_glProgramParameters4fvNV (target=881938112, index=24104944, num=1166358624, params=0x180000) at indirect.c:9317
#8  0x00007f801a4fb48e in KWin::ARBBlurShader::init (this=0x16b39e0) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects/blur/blurshader.cpp:471
#9  0x00007f801a4f6b77 in KWin::BlurEffect::reconfigure (this=this@entry=0x16b6670, flags=...) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects/blur/blur.cpp:85
#10 0x00007f801a4f6e07 in KWin::BlurEffect::BlurEffect (this=0x16b6670) at /usr/src/debug/kde-workspace-4.8.5/kwin/effects/blur/blur.cpp:53
Comment 56 pyotr 2013-03-02 09:31:57 UTC
First of all, this bug is not solved. This bug does not even exist, to say.
It's a generic "common" bug. There are many causes, and every time we get here.

I think KDE needs to implement some other triggers or some other separation, so the proper bugs will be fixed or dealt with. We still get crashes, and they have nothing to do with the original crash.

Could you guys fix this?
Comment 57 Thomas Lübking 2013-03-02 10:33:52 UTC
the bug is in mesa and exposed by using arb shaders on indirect contexts.

the only two occasions are software rasterizers (which you rather don't want to use) and older versions of fglrx (where direct rendering was broken then as indirect rendering is in other occasions now)

if you run into it, there's a good chance of a misconfigured system (running the vesa driver) what also was the case for the original bug (thus marked as downstream)

The fix from kwin *could* be to block all shader invocation for indirect contexts (mostly affecting the blur effect anyway - so simply disable it to bypass the problem and for < 4.10 ensure to set the scale method to smooth) but as mentioned, the

   proper fix is -quite likely- to install proper and current drivers for your GPU
Comment 58 Martin Flöser 2013-05-08 13:13:03 UTC
*** Bug 319520 has been marked as a duplicate of this bug. ***
Comment 59 Thomas Lübking 2013-06-25 21:06:17 UTC
*** Bug 321613 has been marked as a duplicate of this bug. ***
Comment 60 Thomas Lübking 2013-06-30 13:11:48 UTC
*** Bug 321790 has been marked as a duplicate of this bug. ***