Bug 286479 - trying to use kwin 4.7.3 with fglrx 11.10
Summary: trying to use kwin 4.7.3 with fglrx 11.10
Status: RESOLVED DUPLICATE of bug 270818
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-13 11:42 UTC by Bruno Friedmann
Modified: 2011-12-25 16:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (2.62 KB, text/plain)
2011-12-25 16:40 UTC, demopley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2011-11-13 11:42:36 UTC
Application: kwin (4.7.3 (4.7.3))
KDE Platform Version: 4.7.3 (4.7.3)
Qt Version: 4.7.4
Operating System: Linux 3.1.0-2-desktop x86_64
Distribution: "openSUSE 12.1 RC 1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Trying to use direct rendering (enable direct rendering, and check disable functionality test)

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f5a16f28b7b in __memcpy_sse2 () from /lib64/libc.so.6
#7  0x00007f5a147bcd05 in __indirect_glProgramParameters4fvNV (target=1, index=9310804, num=1162167621, params=0x0) at /usr/include/bits/string3.h:52
#8  0x00007f59ff17edcf in KWin::ARBBlurShader::init (this=0x8e1240) at /usr/src/debug/kde-workspace-4.7.3/kwin/effects/blur/blurshader.cpp:463
#9  0x00007f59ff17bc15 in KWin::BlurEffect::reconfigure (this=0x8de8c0, flags=<optimized out>) at /usr/src/debug/kde-workspace-4.7.3/kwin/effects/blur/blur.cpp:83
#10 0x00007f59ff17bdac in KWin::BlurEffect::BlurEffect (this=0x8de8c0) at /usr/src/debug/kde-workspace-4.7.3/kwin/effects/blur/blur.cpp:53
#11 0x00007f59ff17be96 in KWin::effect_create_kwin4_effect_blur () at /usr/src/debug/kde-workspace-4.7.3/kwin/effects/blur/blur.cpp:33
#12 0x00007f5a1731a752 in KWin::EffectsHandlerImpl::loadEffect (this=0x9911f0, name=..., checkDefault=false) at /usr/src/debug/kde-workspace-4.7.3/kwin/effects.cpp:1125
#13 0x00007f5a1731baaa in KWin::EffectsHandlerImpl::reconfigure (this=0x9911f0) at /usr/src/debug/kde-workspace-4.7.3/kwin/effects.cpp:189
#14 0x00007f5a1731bfb8 in KWin::EffectsHandlerImpl::EffectsHandlerImpl (this=0x9911f0, type=<optimized out>) at /usr/src/debug/kde-workspace-4.7.3/kwin/effects.cpp:121
#15 0x00007f5a172f13dd in KWin::Workspace::setupCompositing (this=0x836340) at /usr/src/debug/kde-workspace-4.7.3/kwin/composite.cpp:180
#16 0x00007f5a172f1e65 in KWin::Workspace::setupCompositing (this=<optimized out>) at /usr/src/debug/kde-workspace-4.7.3/kwin/composite.cpp:94
#17 0x00007f5a172756b6 in KWin::Workspace::Workspace (this=0x836340, restore=false) at /usr/src/debug/kde-workspace-4.7.3/kwin/workspace.cpp:225
#18 0x00007f5a1728d59c in KWin::Application::Application (this=<optimized out>) at /usr/src/debug/kde-workspace-4.7.3/kwin/main.cpp:320
#19 0x00007f5a1728f24b in kdemain (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kde-workspace-4.7.3/kwin/main.cpp:491
#20 0x00007f5a16ec31bd in __libc_start_main () from /lib64/libc.so.6
#21 0x0000000000400681 in _start () at ../sysdeps/x86_64/elf/start.S:113

This bug may be a duplicate of or related to bug 270942.

Possible duplicates by query: bug 284656, bug 284375, bug 284308, bug 284307, bug 281540.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-11-13 12:46:03 UTC
driver bug
disable blurring, down- or upgrade mesa, or force direct rendering

export KWIN_DIRECT_GL=1

depending on your GPU/driver this might fail elsewhere (esp. w/ fglrx - use the
radeon driver in case and if you can)

*** This bug has been marked as a duplicate of bug 270818 ***
Comment 2 Martin Flöser 2011-11-13 15:15:40 UTC
Just for the record: the checkbox "direct rendering" has been removed in 4.8 
exactly because it is a "break my system" checkbox.

Direct rendering does not work reliable with fglrx and is terribly slow.

You can find some driver recommendations in my "how to improve desktop effects 
performance" tutorial on userbase I wrote yesterday: 
http://userbase.kde.org/User:Mgraesslin/Desktop_Effects_Performance
Comment 3 Thomas Lübking 2011-11-13 16:24:00 UTC
Ok, but 

> Direct rendering does not work reliable with fglrx and is terribly slow.

                        +

> #7  0x00007f5a147bcd05 in __indirect_glProgramParameters4fvNV

                        =

           fglrx does not work with shaders
Comment 4 demopley 2011-12-25 16:40:55 UTC
Created attachment 67100 [details]
New crash information added by DrKonqi

kwin (4.7.4 (4.7.4) "release 11") on KDE Platform 4.7.4 (4.7.4) "release 11" using Qt 4.7.4

- What I was doing when the application crashed: Log on to the system with Desktop Effects enabled

-- Backtrace (Reduced):
#7  0x00007f761d8e6d05 in __indirect_glProgramParameters4fvNV (target=1, index=8965764, num=540376856, params=0xa204b0) at /usr/include/bits/string3.h:52
#8  0x00007f760767536f in KWin::ARBBlurShader::init (this=0x88ce70) at /usr/src/debug/kde-workspace-4.7.4/kwin/effects/blur/blurshader.cpp:463
#9  0x00007f76076721b5 in KWin::BlurEffect::reconfigure (this=0x808750, flags=<optimized out>) at /usr/src/debug/kde-workspace-4.7.4/kwin/effects/blur/blur.cpp:83
#10 0x00007f760767234c in KWin::BlurEffect::BlurEffect (this=0x808750) at /usr/src/debug/kde-workspace-4.7.4/kwin/effects/blur/blur.cpp:53
#11 0x00007f7607672436 in KWin::effect_create_kwin4_effect_blur () at /usr/src/debug/kde-workspace-4.7.4/kwin/effects/blur/blur.cpp:33