Bug 275325 - desktop effects crashes on starting
Summary: desktop effects crashes on starting
Status: RESOLVED DUPLICATE of bug 270818
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-10 09:43 UTC by Mebuntu
Modified: 2011-06-10 11:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
glxinfo (12.14 KB, text/plain)
2011-06-10 10:33 UTC, Mebuntu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mebuntu 2011-06-10 09:43:57 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
I opened desktop effects and the crash report started immediately.

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  memcpy () at ../sysdeps/x86_64/memcpy.S:267
#7  0x00007f96c90a2b38 in __indirect_glProgramParameters4fvNV (target=1, index=15830484, num=15835424, params=<value optimized out>) at /usr/include/bits/string3.h:52
#8  0x00007f96b329226a in KWin::ARBBlurShader::init (this=0xf18dc0) at ../../../kwin/effects/blur/blurshader.cpp:473
#9  0x00007f96b328f072 in KWin::BlurEffect::reconfigure (this=0xf1c420, flags=<value optimized out>) at ../../../kwin/effects/blur/blur.cpp:76
#10 0x00007f96b328f1d7 in KWin::BlurEffect::BlurEffect (this=0xf1c420) at ../../../kwin/effects/blur/blur.cpp:48
#11 0x00007f96b328f286 in KWin::effect_create_kwin4_effect_blur () at ../../../kwin/effects/blur/blur.cpp:29
#12 0x00007f96cbb951eb in KWin::EffectsHandlerImpl::loadEffect (this=0xe8d0b0, name=...) at ../../kwin/effects.cpp:1128
#13 0x00007f96cbb963d1 in KWin::EffectsHandlerImpl::reconfigure (this=0xe8d0b0) at ../../kwin/effects.cpp:143
#14 0x00007f96cbb7104c in KWin::Workspace::setupCompositing (this=0xebc080) at ../../kwin/composite.cpp:216
#15 0x00007f96cbaf6deb in KWin::Workspace::Workspace (this=0xebc080, restore=false) at ../../kwin/workspace.cpp:222
#16 0x00007f96cbb0e38c in KWin::Application::Application (this=<value optimized out>) at ../../kwin/main.cpp:330
#17 0x00007f96cbb0fe7d in kdemain (argc=<value optimized out>, argv=0x7fff7c20d8a8) at ../../kwin/main.cpp:516
#18 0x00007f96cb741eff in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff7c20d8a8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff7c20d898) at libc-start.c:226
#19 0x0000000000400669 in _start ()

Possible duplicates by query: bug 274090, bug 273694, bug 270818.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-06-10 10:14:29 UTC
please have a lok at the dupe, check the output of you glxinfo.
If the bug is reproducable and you don't understand the issues discussed in the dupe, please attach the output of glxinfo.

As a workaround you can disable the blur effect.

*** This bug has been marked as a duplicate of bug 270818 ***
Comment 2 Mebuntu 2011-06-10 10:21:45 UTC
disabled blur and now working.
Comment 3 Thomas Lübking 2011-06-10 10:26:36 UTC
That's hardly a surprise - please ensure you're not somehow using the software renderer.
"glxinfo > my_glxinfo.txt" will dump the relevant information into a text file you can attach.
Comment 4 Mebuntu 2011-06-10 10:33:49 UTC
Created attachment 60857 [details]
glxinfo

as requested.
Comment 5 Thomas Lübking 2011-06-10 10:45:21 UTC
do you have "enable direct rendering" in the 3. tab of "kcmshell4 kwincompositing" checked off?
Comment 6 Mebuntu 2011-06-10 11:20:50 UTC
enable direct rendering is checked