Bug 270705 - kde network manager crash on network-manager restart
Summary: kde network manager crash on network-manager restart
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-11 19:31 UTC by Luis Ehlen
Modified: 2011-04-11 23:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Ehlen 2011-04-11 19:31:00 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-5-686 i686
Distribution: Debian GNU/Linux 6.0.1 (squeeze)

-- Information about the crash:
kde-network-manager crash wen i do:
> /etc/init.d/network.manager stop (dont crash yet)
> /etc/init.d/network.manager start (crash here)
That's all

The crash can be reproduced every time.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0x00000058 in ?? ()
#7  0xb7032eae in qobject_cast<Knm::InterfaceConnection const*> (first=0x806ea00, second=0x8dfbc78) at /usr/include/qt4/QtCore/qobject.h:468
#8  activatableLessThan (first=0x806ea00, second=0x8dfbc78) at ../../../libs/service/sortedactivatablelist.cpp:183
#9  0xb7033142 in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:356
#10 0xb70333f2 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x8db2590, activatable=0x8f776f8)
    at /usr/include/qt4/QtCore/qalgorithms.h:187
#11 SortedActivatableList::handleAdd (this=0x8db2590, activatable=0x8f776f8) at ../../../libs/service/sortedactivatablelist.cpp:96
#12 0xb7021d03 in ActivatableList::notifyOnAddActivatable (this=0x8dc20b8, activatable=0x8f776f8) at ../../../libs/service/activatablelist.cpp:99
#13 0xb7022098 in ActivatableList::addActivatable (this=0x8dc20b8, activatable=0x8f776f8) at ../../../libs/service/activatablelist.cpp:83
#14 0xb7026540 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x8e19358, addedConnection=0x8e00f18) at ../../../libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0xb7023be0 in NetworkInterfaceActivatableProvider::init (this=0x8e19358) at ../../../libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0xb7022aa3 in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x8de1620, uni=...) at ../../../libs/service/networkinterfacemonitor.cpp:79
#17 0xb701d22b in NetworkInterfaceMonitor::qt_metacall (this=0x8de1620, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbffc1598) at moc_networkinterfacemonitor.cpp:75
#18 0xb62937aa in QMetaObject::metacall (object=0x8de1620, cl=150828801, idx=4, argv=0xbffc1598) at kernel/qmetaobject.cpp:237
#19 0xb62a21bb in QMetaObject::activate (sender=0x8dcd4f8, m=0xb6f4d440, local_signal_index=1, argv=0xbffc1598) at kernel/qobject.cpp:3295
#20 0xb6f2e463 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#21 0xb6f2eed6 in ?? () from /usr/lib/libsolidcontrol.so.4
#22 0xb6f2ef57 in ?? () from /usr/lib/libsolidcontrol.so.4
#23 0xb62937aa in QMetaObject::metacall (object=0x8dcd4f8, cl=150828801, idx=0, argv=0x8dcd4f8) at kernel/qmetaobject.cpp:237
#24 0xb62a21bb in QMetaObject::activate (sender=0x8dcab38, m=0xb3cae4d0, local_signal_index=1, argv=0xbffc1708) at kernel/qobject.cpp:3295
#25 0xb3c97613 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#26 0xb3c97efa in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#27 0xb3c9c21d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#28 0xb62937aa in QMetaObject::metacall (object=0x8dcab38, cl=150828801, idx=150518472, argv=0x8dcab38) at kernel/qmetaobject.cpp:237
#29 0xb62a21bb in QMetaObject::activate (sender=0x8dd7760, m=0xb3caf4e0, local_signal_index=0, argv=0xbffc18a8) at kernel/qobject.cpp:3295
#30 0xb3ca6563 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#31 0xb3ca6925 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#32 0xb63c8ac1 in QDBusConnectionPrivate::deliverCall (this=0x8dafe18, object=0x8dd7760, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#33 0xb63d3877 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#34 0xb629edfe in QObject::event (this=0x8dd7760, e=0x8efef28) at kernel/qobject.cpp:1248
#35 0xb65765cc in QApplicationPrivate::notify_helper (this=0x8d35e20, receiver=0x8dd7760, e=0x8efef28) at kernel/qapplication.cpp:4302
#36 0xb657d15e in QApplication::notify (this=0xbffc23a0, receiver=0x8dd7760, e=0x8efef28) at kernel/qapplication.cpp:3706
#37 0xb7388c0a in KApplication::notify (this=0xbffc23a0, receiver=0x8dd7760, event=0x8efef28) at ../../kdeui/kernel/kapplication.cpp:302
#38 0xb628e4cb in QCoreApplication::notifyInternal (this=0xbffc23a0, receiver=0x8dd7760, event=0x8efef28) at kernel/qcoreapplication.cpp:726
#39 0xb6291f2c in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8d18860) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#40 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8d18860) at kernel/qcoreapplication.cpp:1367
#41 0xb62920ad in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#42 0xb62ba57f in QCoreApplication::sendPostedEvents (s=0x8d38b78) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=0x8d38b78) at kernel/qeventdispatcher_glib.cpp:276
#44 0xb5b44305 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#45 0xb5b47fe8 in ?? () from /lib/libglib-2.0.so.0
#46 0xb5b481c8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#47 0xb62ba075 in QEventDispatcherGlib::processEvents (this=0x8d18360, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#48 0xb6634ed5 in QGuiEventDispatcherGlib::processEvents (this=0x8d18360, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0xb628cae9 in QEventLoop::processEvents (this=0xbffc2304, flags=) at kernel/qeventloop.cpp:149
#50 0xb628cf3a in QEventLoop::exec (this=0xbffc2304, flags=...) at kernel/qeventloop.cpp:201
#51 0xb629216f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#52 0xb6576667 in QApplication::exec () at kernel/qapplication.cpp:3581
#53 0x08053ec5 in main (argc=1, argv=0xbffc24f4) at ../../monolithic/main.cpp:45

This bug may be a duplicate of or related to bug 256662.

Possible duplicates by query: bug 269092, bug 267287, bug 264185, bug 263968, bug 263827.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-04-11 23:05:14 UTC

*** This bug has been marked as a duplicate of bug 210878 ***