Bug 270047 - Rekonq crashed while close window
Summary: Rekonq crashed while close window
Status: RESOLVED DUPLICATE of bug 269490
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: 0.6.95
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-04 00:42 UTC by jesus1989_p
Modified: 2011-05-08 23:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jesus1989_p 2011-04-04 00:42:34 UTC
Application: rekonq (0.6.95)
KDE Platform Version: 4.6.1 (4.6.1) "release 390"
Qt Version: 4.7.2
Operating System: Linux 2.6.37.1-1.2-default i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
The browser failed to close the window. With using the Bespin theme the tabs do not displayed clearly.

-- Backtrace:
Application: rekonq (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb580e710 (LWP 29501))]

Thread 7 (Thread 0xaf91fb70 (LWP 29510)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6c66105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb44e0e17 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0xb6c61b05 in start_thread () from /lib/libpthread.so.0
#4  0xb601bd5e in clone () from /lib/libc.so.6

Thread 6 (Thread 0xaeebcb70 (LWP 29514)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6c66105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb35d4ed7 in ?? () from /usr/lib/libQtScript.so.4
#3  0xb35d4f1f in ?? () from /usr/lib/libQtScript.so.4
#4  0xb6c61b05 in start_thread () from /lib/libpthread.so.0
#5  0xb601bd5e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xa5b7fb70 (LWP 30331)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6c66105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6cdf080 in wait (this=0x8184de8, mutex=0x82b3620, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x8184de8, mutex=0x82b3620, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb309a056 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8184dd0, th=0x8eaa6a0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb309d7a7 in waitForAvailableJob (this=0x8184e20, th=0x8eaa6a0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x8eaa6a0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x8eaa6a0, previous=0x0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb309d7c3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x8eaa6a0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:74
#9  0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x8eaa6a0, previous=0x0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb309d7c3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x8eaa6a0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:74
#11 0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x8eaa6a0, previous=0x90b5518) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#12 0xb309a564 in ThreadWeaver::ThreadRunHelper::run (this=0xa5b7f314, parent=0x8184dd0, th=0x8eaa6a0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:87
#13 0xb309a61a in ThreadWeaver::Thread::run (this=0x8eaa6a0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:142
#14 0xb6cde993 in QThreadPrivate::start (arg=0x8eaa6a0) at thread/qthread_unix.cpp:320
#15 0xb6c61b05 in start_thread () from /lib/libpthread.so.0
#16 0xb601bd5e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xa4142b70 (LWP 30396)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6c66105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6cdf080 in wait (this=0x8184de8, mutex=0x82b3620, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x8184de8, mutex=0x82b3620, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb309a056 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8184dd0, th=0x9f6d010) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb309d7a7 in waitForAvailableJob (this=0x8184e20, th=0x9f6d010) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x9f6d010) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x9f6d010, previous=0x0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb309d7c3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x9f6d010) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:74
#9  0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x9f6d010, previous=0x0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb309d7c3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x9f6d010) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:74
#11 0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x9f6d010, previous=0x0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#12 0xb309d7c3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x9f6d010) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:74
#13 0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x9f6d010, previous=0x0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#14 0xb309d7c3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x9f6d010) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:74
#15 0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x9f6d010, previous=0x8d04930) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#16 0xb309a564 in ThreadWeaver::ThreadRunHelper::run (this=0xa4142314, parent=0x8184dd0, th=0x9f6d010) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:87
#17 0xb309a61a in ThreadWeaver::Thread::run (this=0x9f6d010) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:142
#18 0xb6cde993 in QThreadPrivate::start (arg=0x9f6d010) at thread/qthread_unix.cpp:320
#19 0xb6c61b05 in start_thread () from /lib/libpthread.so.0
#20 0xb601bd5e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa373ab70 (LWP 30467)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6c66105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6cdf080 in wait (this=0x8184de8, mutex=0x82b3620, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x8184de8, mutex=0x82b3620, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb309a056 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8184dd0, th=0x89750a8) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb309d7a7 in waitForAvailableJob (this=0x8184e20, th=0x89750a8) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x89750a8) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x89750a8, previous=0x8f58190) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb309a564 in ThreadWeaver::ThreadRunHelper::run (this=0xa373a314, parent=0x8184dd0, th=0x89750a8) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:87
#9  0xb309a61a in ThreadWeaver::Thread::run (this=0x89750a8) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:142
#10 0xb6cde993 in QThreadPrivate::start (arg=0x89750a8) at thread/qthread_unix.cpp:320
#11 0xb6c61b05 in start_thread () from /lib/libpthread.so.0
#12 0xb601bd5e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa5144b70 (LWP 32542)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6c66105 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6cdf080 in wait (this=0x8184de8, mutex=0x82b3620, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x8184de8, mutex=0x82b3620, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0xb309a056 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8184dd0, th=0x97bf470) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0xb309d7a7 in waitForAvailableJob (this=0x8184e20, th=0x97bf470) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:356
#6  ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x97bf470) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x97bf470, previous=0x0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb309d7c3 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8184e20, th=0x97bf470) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WorkingHardState.cpp:74
#9  0xb3099a03 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8184dd0, th=0x97bf470, previous=0x85f2cb0) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb309a564 in ThreadWeaver::ThreadRunHelper::run (this=0xa5144314, parent=0x8184dd0, th=0x97bf470) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:87
#11 0xb309a61a in ThreadWeaver::Thread::run (this=0x97bf470) at /usr/src/debug/kdelibs-4.6.1/threadweaver/Weaver/Thread.cpp:142
#12 0xb6cde993 in QThreadPrivate::start (arg=0x97bf470) at thread/qthread_unix.cpp:320
#13 0xb6c61b05 in start_thread () from /lib/libpthread.so.0
#14 0xb601bd5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb580e710 (LWP 29501)):
[KCrash Handler]
#7  0xb6507e2b in QRasterWindowSurface::~QRasterWindowSurface() () from /usr/lib/libQtGui.so.4
#8  0xb6507ec2 in QRasterWindowSurface::~QRasterWindowSurface() () from /usr/lib/libQtGui.so.4
#9  0xb6528af3 in ?? () from /usr/lib/libQtGui.so.4
#10 0xb6336efc in ?? () from /usr/lib/libQtGui.so.4
#11 0xb6337054 in QWidgetPrivate::deleteExtra() () from /usr/lib/libQtGui.so.4
#12 0xb633726c in QWidgetPrivate::~QWidgetPrivate() () from /usr/lib/libQtGui.so.4
#13 0xb6799efd in ?? () from /usr/lib/libQtGui.so.4
#14 0xb6df4412 in cleanup (this=0x8346b38, __in_chrg=<value optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x8346b38, __in_chrg=<value optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x8346b38, __in_chrg=<value optimized out>) at kernel/qobject.cpp:818
#17 0xb633986c in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#18 0xb679144b in QMenu::~QMenu() () from /usr/lib/libQtGui.so.4
#19 0xb73f30e4 in KMenu::~KMenu() () from /usr/lib/libkdeui.so.5
#20 0xb73f3122 in KMenu::~KMenu() () from /usr/lib/libkdeui.so.5
#21 0xb75935d8 in KActionMenu::~KActionMenu() () from /usr/lib/libkdeui.so.5
#22 0xb54bddce in KBookmarkActionMenu::~KBookmarkActionMenu (this=0x83563a0, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/kio/bookmarks/kbookmarkmenu.cc:761
#23 0xb54bde12 in KBookmarkActionMenu::~KBookmarkActionMenu (this=0x83563a0, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/kio/bookmarks/kbookmarkmenu.cc:763
#24 0xb6def494 in QObjectPrivate::deleteChildren (this=0x8343ed8) at kernel/qobject.cpp:1955
#25 0xb6df43bc in QObject::~QObject (this=0x83434d0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#26 0xb553f3b1 in KBookmarkMenu::~KBookmarkMenu (this=0x83434d0, __in_chrg=<value optimized out>) at /usr/src/debug/kdelibs-4.6.1/kio/bookmarks/kbookmarkmenu.cc:138
#27 0xb243fb06 in ?? () from /usr/lib/libkdeinit4_rekonq.so
#28 0xb243fba2 in ?? () from /usr/lib/libkdeinit4_rekonq.so
#29 0xb243a626 in ?? () from /usr/lib/libkdeinit4_rekonq.so
#30 0xb243a692 in ?? () from /usr/lib/libkdeinit4_rekonq.so
#31 0xb6def494 in QObjectPrivate::deleteChildren (this=0x80dd2e0) at kernel/qobject.cpp:1955
#32 0xb6df43bc in QObject::~QObject (this=0xbfccabd0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#33 0xb6dde830 in QCoreApplication::~QCoreApplication (this=0xbfccabd0, __in_chrg=<value optimized out>) at kernel/qcoreapplication.cpp:615
#34 0xb62eb9fe in QApplication::~QApplication() () from /usr/lib/libQtGui.so.4
#35 0xb7400af8 in KApplication::~KApplication() () from /usr/lib/libkdeui.so.5
#36 0xb7400b68 in KUniqueApplication::~KUniqueApplication() () from /usr/lib/libkdeui.so.5
#37 0xb23df9e2 in Application::~Application() () from /usr/lib/libkdeinit4_rekonq.so
#38 0xb24780cb in kdemain () from /usr/lib/libkdeinit4_rekonq.so
#39 0x0804e514 in _start ()

This bug may be a duplicate of or related to bug 268936.

Possible duplicates by query: bug 269671, bug 269490, bug 268936, bug 255081.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-08 23:41:49 UTC
[Comment from a bug triager]
The bug was fixed recently in rekonqi. The issue was being tracked at bug 269490, merging.
Thanks

*** This bug has been marked as a duplicate of bug 269490 ***