Bug 269837 - plantage Kstars
Summary: plantage Kstars
Status: RESOLVED DUPLICATE of bug 237124
Alias: None
Product: kstars
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Akarsh Simha
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-31 20:46 UTC by MY
Modified: 2011-07-18 23:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MY 2011-03-31 20:46:15 UTC
Application: kstars (1.6.0)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-5-686 i686
Distribution: Debian GNU/Linux 6.0.1 (squeeze)

-- Information about the crash:
Téléchargement catalogue USNO sur Debian Squeeze . Kstars 1.6.0 sur KDE 4.4.5

 -- Backtrace:
Application: KStars (kstars), signal: Aborted
[KCrash Handler]
#6  0xb78c7424 in __kernel_vsyscall ()
#7  0xb5799751 in raise () from /lib/i686/cmov/libc.so.6
#8  0xb579cb82 in abort () from /lib/i686/cmov/libc.so.6
#9  0xb59b953f in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/libstdc++.so.6
#10 0xb59b7405 in ?? () from /usr/lib/libstdc++.so.6
#11 0xb59b7442 in std::terminate() () from /usr/lib/libstdc++.so.6
#12 0xb59b7581 in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0xb67e77f5 in qBadAlloc () at global/qglobal.cpp:2003
#14 0xb67f46da in QByteArray::resize (this=0xbfc618bc, size=2147483647) at tools/qbytearray.cpp:1371
#15 0xb688040f in QIODevice::read (this=0xaa11dd8, maxSize=2173117930) at io/qiodevice.cpp:950
#16 0xb6f0d845 in KArchiveFile::data (this=0xaa11f58) at ../../kio/kio/karchive.cpp:644
#17 0xb6f0e792 in KArchiveFile::copyTo (this=0xaa11f58, dest=...) at ../../kio/kio/karchive.cpp:665
#18 0xb6f0f802 in KArchiveDirectory::copyTo (this=0xaa8ba38, dest=..., recursiveCopy=true) at ../../kio/kio/karchive.cpp:816
#19 0xb7620c54 in KNS::CoreEngine::install (this=0xa796648, payloadfile=...) at ../../../knewstuff/knewstuff2/core/coreengine.cpp:1474
#20 0xb7622329 in KNS::CoreEngine::slotPayloadResult (this=0xa796648, job=0xaaa74e8) at ../../../knewstuff/knewstuff2/core/coreengine.cpp:448
#21 0xb76238b4 in KNS::CoreEngine::qt_metacall (this=0xa796648, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0xbfc61fe8) at ./coreengine.moc:158
#22 0xb762f71a in KNS::DxsEngine::qt_metacall (this=0xa796648, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0xbfc61fe8) at ./dxsengine.moc:72
#23 0xb7648b8a in KNS::EnginePrivate::qt_metacall (this=0xa796648, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0xbfc61fe8) at ./engine.moc:77
#24 0xb68f27aa in QMetaObject::metacall (object=0xa796648, cl=2976, idx=28, argv=0xbfc61fe8) at kernel/qmetaobject.cpp:237
#25 0xb69011bb in QMetaObject::activate (sender=0xaaa74e8, m=0xb78a2ec8, local_signal_index=3, argv=0xbfc61fe8) at kernel/qobject.cpp:3295
#26 0xb7735d43 in KJob::result (this=0xaaa74e8, _t1=0xaaa74e8) at ./kjob.moc:194
#27 0xb77360a8 in KJob::emitResult (this=0xaaa74e8) at ../../kdecore/jobs/kjob.cpp:312
#28 0xb6f04064 in KIO::FileCopyJob::slotResult (this=0xaaa74e8, job=0xa645358) at ../../kio/kio/job.cpp:2319
#29 0xb6efff32 in KIO::FileCopyJob::qt_metacall (this=0xaaa74e8, _c=QMetaObject::InvokeMetaMethod, _id=32, _a=0xbfc62178) at ./jobclasses.moc:721
#30 0xb68f27aa in QMetaObject::metacall (object=0xaaa74e8, cl=2976, idx=32, argv=0xbfc62178) at kernel/qmetaobject.cpp:237
#31 0xb69011bb in QMetaObject::activate (sender=0xa645358, m=0xb78a2ec8, local_signal_index=3, argv=0xbfc62178) at kernel/qobject.cpp:3295
#32 0xb7735d43 in KJob::result (this=0xa645358, _t1=0xa645358) at ./kjob.moc:194
#33 0xb77360a8 in KJob::emitResult (this=0xa645358) at ../../kdecore/jobs/kjob.cpp:312
#34 0xb6efcd30 in KIO::SimpleJob::slotFinished (this=0xa645358) at ../../kio/kio/job.cpp:517
#35 0xb6efd260 in KIO::TransferJob::slotFinished (this=0xa645358) at ../../kio/kio/job.cpp:1097
#36 0xb6efab93 in KIO::TransferJob::qt_metacall (this=0xa645358, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbfc6240c) at ./jobclasses.moc:367
#37 0xb68f27aa in QMetaObject::metacall (object=0xa645358, cl=2976, idx=47, argv=0xbfc6240c) at kernel/qmetaobject.cpp:237
#38 0xb69011bb in QMetaObject::activate (sender=0xa6d4728, m=0xb70abf64, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3295
#39 0xb6fc84b7 in KIO::SlaveInterface::finished (this=0xa6d4728) at ./slaveinterface.moc:171
#40 0xb6fcb7dd in KIO::SlaveInterface::dispatch (this=0xa6d4728, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#41 0xb6fc8973 in KIO::SlaveInterface::dispatch (this=0xa6d4728) at ../../kio/kio/slaveinterface.cpp:91
#42 0xb6fbbe48 in KIO::Slave::gotInput (this=0xa6d4728) at ../../kio/kio/slave.cpp:324
#43 0xb6fbc053 in KIO::Slave::qt_metacall (this=0xa6d4728, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfc6271c) at ./slave.moc:82
#44 0xb68f27aa in QMetaObject::metacall (object=0xa6d4728, cl=2976, idx=30, argv=0xbfc6271c) at kernel/qmetaobject.cpp:237
#45 0xb69011bb in QMetaObject::activate (sender=0xa6bf098, m=0xb70a8840, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#46 0xb6ec4cc7 in KIO::Connection::readyRead (this=0xa6bf098) at ./connection.moc:92
#47 0xb6ec706e in KIO::ConnectionPrivate::dequeue (this=0xaa1c628) at ../../kio/kio/connection.cpp:82
#48 0xb6ec719e in KIO::Connection::qt_metacall (this=0xa6bf098, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xa9d5e28) at ./connection.moc:79
#49 0xb68f27aa in QMetaObject::metacall (object=0xa6bf098, cl=2976, idx=5, argv=0xa9d5e28) at kernel/qmetaobject.cpp:237
#50 0xb68fcd36 in QMetaCallEvent::placeMetaCall (this=0xaab4670, object=0xa6bf098) at kernel/qobject.cpp:561
#51 0xb68fddfe in QObject::event (this=0xa6bf098, e=0xaab4670) at kernel/qobject.cpp:1248
#52 0xb5e365cc in QApplicationPrivate::notify_helper (this=0x8f87f98, receiver=0xa6bf098, e=0xaab4670) at kernel/qapplication.cpp:4302
#53 0xb5e3d15e in QApplication::notify (this=0xbfc6579c, receiver=0xa6bf098, e=0xaab4670) at kernel/qapplication.cpp:3706
#54 0xb6c5cc0a in KApplication::notify (this=0xbfc6579c, receiver=0xa6bf098, event=0xaab4670) at ../../kdeui/kernel/kapplication.cpp:302
#55 0xb68ed4cb in QCoreApplication::notifyInternal (this=0xbfc6579c, receiver=0xa6bf098, event=0xaab4670) at kernel/qcoreapplication.cpp:726
#56 0xb68f0f2c in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x8f72880) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8f72880) at kernel/qcoreapplication.cpp:1367
#58 0xb68f10ad in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1260
#59 0xb691957f in QCoreApplication::sendPostedEvents (s=0x8f8a310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#60 postEventSourceDispatch (s=0x8f8a310) at kernel/qeventdispatcher_glib.cpp:276
#61 0xb51c5305 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#62 0xb51c8fe8 in ?? () from /lib/libglib-2.0.so.0
#63 0xb51c91c8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#64 0xb6919075 in QEventDispatcherGlib::processEvents (this=0x8f72540, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#65 0xb5ef4ed5 in QGuiEventDispatcherGlib::processEvents (this=0x8f72540, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#66 0xb68ebae9 in QEventLoop::processEvents (this=0xbfc62fe8, flags=) at kernel/qeventloop.cpp:149
#67 0xb68ebf3a in QEventLoop::exec (this=0xbfc62fe8, flags=...) at kernel/qeventloop.cpp:201
#68 0xb764741a in KNS::EnginePrivate::workflow (this=0xa796648) at ../../../knewstuff/knewstuff2/engine.cpp:158
#69 0xb7647bda in KNS::Engine::downloadDialogModal (this=0xbfc6308c, parent=0xa8c7970) at ../../../knewstuff/knewstuff2/engine.cpp:219
#70 0x081db2db in _start ()

This bug may be a duplicate of or related to bug 237124.

Possible duplicates by query: bug 262289, bug 253253, bug 246985, bug 237124.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-07-18 23:59:43 UTC

*** This bug has been marked as a duplicate of bug 237124 ***