Bug 262289 - Attempt to download 1.4 GB USNO NOMAD Catalog
Summary: Attempt to download 1.4 GB USNO NOMAD Catalog
Status: RESOLVED DUPLICATE of bug 237124
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdecore (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-06 11:33 UTC by Craig Van Degrift
Modified: 2011-01-06 11:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Van Degrift 2011-01-06 11:33:53 UTC
Application: kstars (1.6.0)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-27-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Got to about 1 GB and crashed.  More than 5 GB of disk space was available.

 -- Backtrace:
Application: KStars (kstars), signal: Aborted
[Current thread is 1 (Thread 0xb778a710 (LWP 2176))]

Thread 2 (Thread 0xb4f65b70 (LWP 2179)):
#0  0x01fb4416 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#1  0x01fb82d8 in ?? () from /lib/libglib-2.0.so.0
#2  0x01fb84b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x02cb260f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0x02c85059 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0x02c854aa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x02b815a8 in QThread::exec() () from /usr/lib/libQtCore.so.4
#7  0x02c64c1b in ?? () from /usr/lib/libQtCore.so.4
#8  0x02b8432e in ?? () from /usr/lib/libQtCore.so.4
#9  0x0026b96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x01e3ba4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb778a710 (LWP 2176)):
[KCrash Handler]
#6  0x004ff422 in __kernel_vsyscall ()
#7  0x01d98651 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0x01d9ba82 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0x00f2e52f in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/libstdc++.so.6
#10 0x00f2c465 in ?? () from /usr/lib/libstdc++.so.6
#11 0x00f2c4a2 in std::terminate() () from /usr/lib/libstdc++.so.6
#12 0x00f2c5e1 in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0x02b7ab15 in qBadAlloc() () from /usr/lib/libQtCore.so.4
#14 0x02b879ca in QByteArray::resize(int) () from /usr/lib/libQtCore.so.4
#15 0x02c186df in QIODevice::read(long long) () from /usr/lib/libQtCore.so.4
#16 0x00ba1765 in KArchiveFile::data() const () from /usr/lib/libkio.so.5
#17 0x00ba26b2 in KArchiveFile::copyTo(QString const&) const () from /usr/lib/libkio.so.5
#18 0x00ba3712 in KArchiveDirectory::copyTo(QString const&, bool) const () from /usr/lib/libkio.so.5
#19 0x0013fc04 in KNS::CoreEngine::install(QString const&) () from /usr/lib/libknewstuff2.so.4
#20 0x00141301 in KNS::CoreEngine::slotPayloadResult(KJob*) () from /usr/lib/libknewstuff2.so.4
#21 0x00142974 in KNS::CoreEngine::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknewstuff2.so.4
#22 0x0014eada in ?? () from /usr/lib/libknewstuff2.so.4
#23 0x00167eaa in ?? () from /usr/lib/libknewstuff2.so.4
#24 0x02c8bc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#25 0x02c9a3d5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#26 0x0069d1e3 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#27 0x0069d548 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#28 0x00b97f94 in KIO::FileCopyJob::slotResult(KJob*) () from /usr/lib/libkio.so.5
#29 0x00b93e62 in KIO::FileCopyJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#30 0x02c8bc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#31 0x02c9a3d5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#32 0x0069d1e3 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#33 0x0069d548 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#34 0x00b90c60 in KIO::SimpleJob::slotFinished() () from /usr/lib/libkio.so.5
#35 0x00b916a0 in KIO::TransferJob::slotFinished() () from /usr/lib/libkio.so.5
#36 0x00b8eac3 in KIO::TransferJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#37 0x02c8bc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#38 0x02c9a3d5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#39 0x00c5b2a7 in KIO::SlaveInterface::finished() () from /usr/lib/libkio.so.5
#40 0x00c5e5cd in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/libkio.so.5
#41 0x00c5b763 in KIO::SlaveInterface::dispatch() () from /usr/lib/libkio.so.5
#42 0x00c4ec28 in KIO::Slave::gotInput() () from /usr/lib/libkio.so.5
#43 0x00c4ee33 in KIO::Slave::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#44 0x02c8bc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#45 0x02c9a3d5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#46 0x00b58bd7 in KIO::Connection::readyRead() () from /usr/lib/libkio.so.5
#47 0x00b5af8e in ?? () from /usr/lib/libkio.so.5
#48 0x00b5b0be in KIO::Connection::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#49 0x02c8bc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#50 0x02c96336 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#51 0x02c973fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#52 0x04efe4dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#53 0x04f0505e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#54 0x0119140a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#55 0x02c86a3b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#56 0x02c89473 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#57 0x02c895dd in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#58 0x02cb2adf in ?? () from /usr/lib/libQtCore.so.4
#59 0x01fb45e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#60 0x01fb82d8 in ?? () from /lib/libglib-2.0.so.0
#61 0x01fb84b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#62 0x02cb25d5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#63 0x04fbe135 in ?? () from /usr/lib/libQtGui.so.4
#64 0x02c85059 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#65 0x02c854aa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#66 0x0016673a in ?? () from /usr/lib/libknewstuff2.so.4
#67 0x00166efa in KNS::Engine::downloadDialogModal(QWidget*) () from /usr/lib/libknewstuff2.so.4
#68 0x082186db in _start ()

This bug may be a duplicate of or related to bug 237124.

Possible duplicates by query: bug 253253, bug 246985, bug 237124.

Reported using DrKonqi
Comment 1 Pino Toscano 2011-01-06 11:35:18 UTC

*** This bug has been marked as a duplicate of bug 237124 ***