Bug 253253 - KStars breakdown after installing nomad stars
Summary: KStars breakdown after installing nomad stars
Status: RESOLVED DUPLICATE of bug 237124
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdecore (show other bugs)
Version: 4.4
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-04 19:49 UTC by Kenn Larsen
Modified: 2010-10-04 20:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kenn Larsen 2010-10-04 19:49:22 UTC
Application: kstars (1.6.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-25-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
it just said 'im sorry couldnt install, and i restartede the KStars program.

 -- Backtrace:
Application: KStars (kstars), signal: Aborted
[KCrash Handler]
#6  0x003f3422 in __kernel_vsyscall ()
#7  0x01358651 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0x0135ba82 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0x0083652f in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/libstdc++.so.6
#10 0x00834465 in ?? () from /usr/lib/libstdc++.so.6
#11 0x008344a2 in std::terminate() () from /usr/lib/libstdc++.so.6
#12 0x008345e1 in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0x0110cb15 in qBadAlloc() () from /usr/lib/libQtCore.so.4
#14 0x011199ca in QByteArray::resize(int) () from /usr/lib/libQtCore.so.4
#15 0x011aa6df in QIODevice::read(long long) () from /usr/lib/libQtCore.so.4
#16 0x00f09c45 in KArchiveFile::data() const () from /usr/lib/libkio.so.5
#17 0x00f0ab92 in KArchiveFile::copyTo(QString const&) const () from /usr/lib/libkio.so.5
#18 0x00f0bbf2 in KArchiveDirectory::copyTo(QString const&, bool) const () from /usr/lib/libkio.so.5
#19 0x005d0c04 in KNS::CoreEngine::install(QString const&) () from /usr/lib/libknewstuff2.so.4
#20 0x005d2301 in KNS::CoreEngine::slotPayloadResult(KJob*) () from /usr/lib/libknewstuff2.so.4
#21 0x005d3974 in KNS::CoreEngine::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknewstuff2.so.4
#22 0x005dfada in ?? () from /usr/lib/libknewstuff2.so.4
#23 0x005f8eaa in ?? () from /usr/lib/libknewstuff2.so.4
#24 0x0121dc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#25 0x0122c3d5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#26 0x00afd183 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#27 0x00afd4e8 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#28 0x00f00604 in KIO::FileCopyJob::slotResult(KJob*) () from /usr/lib/libkio.so.5
#29 0x00efc112 in KIO::FileCopyJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#30 0x0121dc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#31 0x0122c3d5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#32 0x00afd183 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#33 0x00afd4e8 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#34 0x00ef8f30 in KIO::SimpleJob::slotFinished() () from /usr/lib/libkio.so.5
#35 0x00ef996d in KIO::TransferJob::slotFinished() () from /usr/lib/libkio.so.5
#36 0x00ef7343 in KIO::TransferJob::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#37 0x0121dc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#38 0x0122c3d5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#39 0x00fc3707 in KIO::SlaveInterface::finished() () from /usr/lib/libkio.so.5
#40 0x00fc6a2d in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/libkio.so.5
#41 0x00fc3bc3 in KIO::SlaveInterface::dispatch() () from /usr/lib/libkio.so.5
#42 0x00fb7088 in KIO::Slave::gotInput() () from /usr/lib/libkio.so.5
#43 0x00fb7293 in KIO::Slave::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#44 0x0121dc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#45 0x0122c3d5 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#46 0x00ec1bd7 in KIO::Connection::readyRead() () from /usr/lib/libkio.so.5
#47 0x00ec3f8e in ?? () from /usr/lib/libkio.so.5
#48 0x00ec40be in KIO::Connection::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkio.so.5
#49 0x0121dc9a in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#50 0x01228336 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#51 0x012293fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#52 0x087724dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#53 0x0877905e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#54 0x074c0f2a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#55 0x01218a3b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#56 0x0121b473 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#57 0x0121b5dd in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#58 0x01244adf in ?? () from /usr/lib/libQtCore.so.4
#59 0x02fbd5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#60 0x02fc12d8 in ?? () from /lib/libglib-2.0.so.0
#61 0x02fc14b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#62 0x012445d5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#63 0x08832135 in ?? () from /usr/lib/libQtGui.so.4
#64 0x01217059 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#65 0x012174aa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#66 0x005f773a in ?? () from /usr/lib/libknewstuff2.so.4
#67 0x005f7efa in KNS::Engine::downloadDialogModal(QWidget*) () from /usr/lib/libknewstuff2.so.4
#68 0x005f8482 in KNS::Engine::download() () from /usr/lib/libknewstuff2.so.4
#69 0x081eed64 in _start ()

Possible duplicates by query: bug 246985, bug 237124.

Reported using DrKonqi
Comment 1 Pino Toscano 2010-10-04 20:07:29 UTC

*** This bug has been marked as a duplicate of bug 237124 ***