Bug 246985 - KStars crash after finish downloading USNO Nomad Catalog
Summary: KStars crash after finish downloading USNO Nomad Catalog
Status: RESOLVED DUPLICATE of bug 237124
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdecore (show other bugs)
Version: 4.4
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-07 14:34 UTC by tokyojo
Modified: 2010-10-04 20:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tokyojo 2010-08-07 14:34:06 UTC
Application: kstars (1.6.0)
KDE Platform Version: 4.4.2 (KDE 4.4.2) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
After the catalog finished downloading, there was no activity or dialog boxes on the screen. So I minimized KStars. After a few more seconds the crash notice appeared.

 -- Backtrace:
Application: KStars (kstars), signal: Aborted
[KCrash Handler]
#6  0x00641422 in __kernel_vsyscall ()
#7  0x0137a651 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0x0137da82 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0x0059952f in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/libstdc++.so.6
#10 0x00597465 in ?? () from /usr/lib/libstdc++.so.6
#11 0x005974a2 in std::terminate() () from /usr/lib/libstdc++.so.6
#12 0x005975e1 in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0x015d4b15 in qBadAlloc () at global/qglobal.cpp:2004
#14 0x015e19ca in QByteArray::resize (this=0xbfef92dc, size=2147483647) at tools/qbytearray.cpp:1371
#15 0x016726df in QIODevice::read (this=0xa89de10, maxSize=2173117930) at io/qiodevice.cpp:925
#16 0x00df2c45 in KArchiveFile::data (this=0xa8f9cd0) at ../../kio/kio/karchive.cpp:644
#17 0x00df3b92 in KArchiveFile::copyTo (this=0xa8f9cd0, dest=...) at ../../kio/kio/karchive.cpp:665
#18 0x00df4bf2 in KArchiveDirectory::copyTo (this=0xaea54e8, dest=..., recursiveCopy=true) at ../../kio/kio/karchive.cpp:816
#19 0x004a7c04 in KNS::CoreEngine::install (this=0xac91860, payloadfile=...) at ../../../knewstuff/knewstuff2/core/coreengine.cpp:1474
#20 0x004a9301 in KNS::CoreEngine::slotPayloadResult (this=0xac91860, job=0xaebdd90) at ../../../knewstuff/knewstuff2/core/coreengine.cpp:448
#21 0x004aa974 in KNS::CoreEngine::qt_metacall (this=0xac91860, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0xbfef9a18) at ./coreengine.moc:158
#22 0x004b6ada in KNS::DxsEngine::qt_metacall (this=0xac91860, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0xbfef9a18) at ./dxsengine.moc:72
#23 0x004cfeaa in KNS::EnginePrivate::qt_metacall (this=0xac91860, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0xbfef9a18) at ./engine.moc:77
#24 0x016e5c9a in QMetaObject::metacall (object=0xac91860, cl=1910, idx=28, argv=0xbfef9a18) at kernel/qmetaobject.cpp:237
#25 0x016f43d5 in QMetaObject::activate (sender=0xaebdd90, m=0xb54c88, local_signal_index=3, argv=0xbfef9a18) at kernel/qobject.cpp:3293
#26 0x009e6183 in KJob::result (this=0xaebdd90, _t1=0xaebdd90) at ./kjob.moc:194
#27 0x009e64e8 in KJob::emitResult (this=0xaebdd90) at ../../kdecore/jobs/kjob.cpp:312
#28 0x00de9604 in KIO::FileCopyJob::slotResult (this=0xaebdd90, job=0xab0b5b8) at ../../kio/kio/job.cpp:2280
#29 0x00de5112 in KIO::FileCopyJob::qt_metacall (this=0xaebdd90, _c=QMetaObject::InvokeMetaMethod, _id=32, _a=0xbfef9ba8) at ./jobclasses.moc:721
#30 0x016e5c9a in QMetaObject::metacall (object=0xaebdd90, cl=1910, idx=32, argv=0xbfef9ba8) at kernel/qmetaobject.cpp:237
#31 0x016f43d5 in QMetaObject::activate (sender=0xab0b5b8, m=0xb54c88, local_signal_index=3, argv=0xbfef9ba8) at kernel/qobject.cpp:3293
#32 0x009e6183 in KJob::result (this=0xab0b5b8, _t1=0xab0b5b8) at ./kjob.moc:194
#33 0x009e64e8 in KJob::emitResult (this=0xab0b5b8) at ../../kdecore/jobs/kjob.cpp:312
#34 0x00de1f30 in KIO::SimpleJob::slotFinished (this=0xab0b5b8) at ../../kio/kio/job.cpp:486
#35 0x00de296d in KIO::TransferJob::slotFinished (this=0xab0b5b8) at ../../kio/kio/job.cpp:1058
#36 0x00de0343 in KIO::TransferJob::qt_metacall (this=0xab0b5b8, _c=QMetaObject::InvokeMetaMethod, _id=47, _a=0xbfef9e3c) at ./jobclasses.moc:367
#37 0x016e5c9a in QMetaObject::metacall (object=0xab0b5b8, cl=1910, idx=47, argv=0xbfef9e3c) at kernel/qmetaobject.cpp:237
#38 0x016f43d5 in QMetaObject::activate (sender=0x9461b30, m=0xf90f44, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3293
#39 0x00eac707 in KIO::SlaveInterface::finished (this=0x9461b30) at ./slaveinterface.moc:171
#40 0x00eafa2d in KIO::SlaveInterface::dispatch (this=0x9461b30, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:175
#41 0x00eacbc3 in KIO::SlaveInterface::dispatch (this=0x9461b30) at ../../kio/kio/slaveinterface.cpp:91
#42 0x00ea0088 in KIO::Slave::gotInput (this=0x9461b30) at ../../kio/kio/slave.cpp:324
#43 0x00ea0293 in KIO::Slave::qt_metacall (this=0x9461b30, _c=QMetaObject::InvokeMetaMethod, _id=30, _a=0xbfefa14c) at ./slave.moc:82
#44 0x016e5c9a in QMetaObject::metacall (object=0x9461b30, cl=1910, idx=30, argv=0xbfefa14c) at kernel/qmetaobject.cpp:237
#45 0x016f43d5 in QMetaObject::activate (sender=0x940d100, m=0xf8d820, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#46 0x00daabd7 in KIO::Connection::readyRead (this=0x940d100) at ./connection.moc:92
#47 0x00dacf8e in KIO::ConnectionPrivate::dequeue (this=0x94eb1b8) at ../../kio/kio/connection.cpp:82
#48 0x00dad0be in KIO::Connection::qt_metacall (this=0x940d100, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xadca230) at ./connection.moc:79
#49 0x016e5c9a in QMetaObject::metacall (object=0x940d100, cl=1910, idx=5, argv=0xadca230) at kernel/qmetaobject.cpp:237
#50 0x016f0336 in QMetaCallEvent::placeMetaCall (this=0xadfa768, object=0x940d100) at kernel/qobject.cpp:561
#51 0x016f13fe in QObject::event (this=0x940d100, e=0xadfa768) at kernel/qobject.cpp:1248
#52 0x048424dc in QApplicationPrivate::notify_helper (this=0x92edb30, receiver=0x940d100, e=0xadfa768) at kernel/qapplication.cpp:4300
#53 0x0484905e in QApplication::notify (this=0xbfefd1ec, receiver=0x940d100, e=0xadfa768) at kernel/qapplication.cpp:3704
#54 0x01178f2a in KApplication::notify (this=0xbfefd1ec, receiver=0x940d100, event=0xadfa768) at ../../kdeui/kernel/kapplication.cpp:302
#55 0x016e0a3b in QCoreApplication::notifyInternal (this=0xbfefd1ec, receiver=0x940d100, event=0xadfa768) at kernel/qcoreapplication.cpp:704
#56 0x016e3473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x92d85a8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#57 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x92d85a8) at kernel/qcoreapplication.cpp:1345
#58 0x016e35dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#59 0x0170cadf in QCoreApplication::sendPostedEvents (s=0x92eff10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#60 postEventSourceDispatch (s=0x92eff10) at kernel/qeventdispatcher_glib.cpp:276
#61 0x08c5c5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#62 0x08c602d8 in ?? () from /lib/libglib-2.0.so.0
#63 0x08c604b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#64 0x0170c5d5 in QEventDispatcherGlib::processEvents (this=0x92d82a0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#65 0x04902135 in QGuiEventDispatcherGlib::processEvents (this=0x92d82a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#66 0x016df059 in QEventLoop::processEvents (this=0xbfefaa18, flags=) at kernel/qeventloop.cpp:149
#67 0x016df4aa in QEventLoop::exec (this=0xbfefaa18, flags=...) at kernel/qeventloop.cpp:201
#68 0x004ce73a in KNS::EnginePrivate::workflow (this=0xac91860) at ../../../knewstuff/knewstuff2/engine.cpp:158
#69 0x004ceefa in KNS::Engine::downloadDialogModal (this=0xbfefaabc, parent=0xa957d00) at ../../../knewstuff/knewstuff2/engine.cpp:219
#70 0x0821865b in KSWizard::slotDownload (this=0xa957d00) at ../../../kstars/kstars/kswizard.cpp:188
#71 0x082186f5 in KSWizard::qt_metacall (this=0xa957d00, _c=QMetaObject::InvokeMetaMethod, _id=77, _a=0xbfefabe8) at ./kswizard.moc:235
#72 0x016e5c9a in QMetaObject::metacall (object=0xa957d00, cl=1910, idx=77, argv=0xbfefabe8) at kernel/qmetaobject.cpp:237
#73 0x016f43d5 in QMetaObject::activate (sender=0xabad428, m=0x517d8c4, local_signal_index=2, argv=0xbfefabe8) at kernel/qobject.cpp:3293
#74 0x04f6d479 in QAbstractButton::clicked (this=0xabad428, _t1=false) at .moc/release-shared/moc_qabstractbutton.cpp:206
#75 0x04c4cea9 in QAbstractButtonPrivate::emitClicked (this=0xabafa70) at widgets/qabstractbutton.cpp:546
#76 0x04c4dcf4 in QAbstractButtonPrivate::click (this=0xabafa70) at widgets/qabstractbutton.cpp:539
#77 0x04c4dfae in QAbstractButton::mouseReleaseEvent (this=0xabad428, e=0xbfefb320) at widgets/qabstractbutton.cpp:1121
#78 0x048a07f8 in QWidget::event (this=0xabad428, event=0xbfefb320) at kernel/qwidget.cpp:7998
#79 0x04c4cd4e in QAbstractButton::event (this=0xabad428, e=0x6) at widgets/qabstractbutton.cpp:1080
#80 0x04cf71f2 in QPushButton::event (this=0xabad428, e=0xbfefb320) at widgets/qpushbutton.cpp:679
#81 0x048424dc in QApplicationPrivate::notify_helper (this=0x92edb30, receiver=0xabad428, e=0xbfefb320) at kernel/qapplication.cpp:4300
#82 0x048499f7 in QApplication::notify (this=0xbfefd1ec, receiver=0xabad428, e=0xbfefb320) at kernel/qapplication.cpp:3865
#83 0x01178f2a in KApplication::notify (this=0xbfefd1ec, receiver=0xabad428, event=0xbfefb320) at ../../kdeui/kernel/kapplication.cpp:302
#84 0x016e0a3b in QCoreApplication::notifyInternal (this=0xbfefd1ec, receiver=0xabad428, event=0xbfefb320) at kernel/qcoreapplication.cpp:704
#85 0x04848952 in QCoreApplication::sendEvent (receiver=0xabad428, event=0xbfefb320, alienWidget=0xabad428, nativeWidget=0xa957d00, buttonDown=0x5186058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#86 QApplicationPrivate::sendMouseEvent (receiver=0xabad428, event=0xbfefb320, alienWidget=0xabad428, nativeWidget=0xa957d00, buttonDown=0x5186058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#87 0x048d4088 in QETWidget::translateMouseEvent (this=0xa957d00, event=0xbfefb83c) at kernel/qapplication_x11.cpp:4368
#88 0x048d3511 in QApplication::x11ProcessEvent (this=0xbfefd1ec, event=0xbfefb83c) at kernel/qapplication_x11.cpp:3379
#89 0x0490260a in x11EventSourceDispatch (s=0x92f0da8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#90 0x08c5c5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#91 0x08c602d8 in ?? () from /lib/libglib-2.0.so.0
#92 0x08c604b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#93 0x0170c5d5 in QEventDispatcherGlib::processEvents (this=0x92d82a0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#94 0x04902135 in QGuiEventDispatcherGlib::processEvents (this=0x92d82a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#95 0x016df059 in QEventLoop::processEvents (this=0xbfefbb30, flags=) at kernel/qeventloop.cpp:149
#96 0x016df4aa in QEventLoop::exec (this=0xbfefbb30, flags=...) at kernel/qeventloop.cpp:201
#97 0x04d814f3 in QDialog::exec (this=0xa957d00) at dialogs/qdialog.cpp:546
#98 0x081f0255 in KStars::slotWizard (this=0x9431c88) at ../../../kstars/kstars/kstarsactions.cpp:187
#99 0x081eac8d in KStars::qt_metacall (this=0x9431c88, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfefbd18) at ./kstars.moc:238
#100 0x016e5c9a in QMetaObject::metacall (object=0x9431c88, cl=1910, idx=85, argv=0xbfefbd18) at kernel/qmetaobject.cpp:237
#101 0x016f43d5 in QMetaObject::activate (sender=0xa5e8bb8, m=0x516ad58, local_signal_index=1, argv=0xbfefbd18) at kernel/qobject.cpp:3293
#102 0x0483bbd9 in QAction::triggered (this=0xa5e8bb8, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#103 0x0483ddcc in QAction::activate (this=0xa5e8bb8, event=QAction::Trigger) at kernel/qaction.cpp:1255
#104 0x04ce160c in QMenuPrivate::activateCausedStack (this=0xa683100, causedStack=..., action=0xa5e8bb8, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1011
#105 0x04ce7abb in QMenuPrivate::activateAction (this=0xa683100, action=0xa5e8bb8, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1103
#106 0x04ce8ac7 in QMenu::mouseReleaseEvent (this=0xa68d8d0, e=0xbfefc5b0) at widgets/qmenu.cpp:2312
#107 0x0126ef65 in KMenu::mouseReleaseEvent (this=0xa68d8d0, e=0xbfefc5b0) at ../../kdeui/widgets/kmenu.cpp:471
#108 0x048a07f8 in QWidget::event (this=0xa68d8d0, event=0xbfefc5b0) at kernel/qwidget.cpp:7998
#109 0x04cea0cc in QMenu::event (this=0xa68d8d0, e=0xbfefc5b0) at widgets/qmenu.cpp:2414
#110 0x048424dc in QApplicationPrivate::notify_helper (this=0x92edb30, receiver=0xa68d8d0, e=0xbfefc5b0) at kernel/qapplication.cpp:4300
#111 0x048499f7 in QApplication::notify (this=0xbfefd1ec, receiver=0xa68d8d0, e=0xbfefc5b0) at kernel/qapplication.cpp:3865
#112 0x01178f2a in KApplication::notify (this=0xbfefd1ec, receiver=0xa68d8d0, event=0xbfefc5b0) at ../../kdeui/kernel/kapplication.cpp:302
#113 0x016e0a3b in QCoreApplication::notifyInternal (this=0xbfefd1ec, receiver=0xa68d8d0, event=0xbfefc5b0) at kernel/qcoreapplication.cpp:704
#114 0x04848952 in QCoreApplication::sendEvent (receiver=0xa68d8d0, event=0xbfefc5b0, alienWidget=0x0, nativeWidget=0xa68d8d0, buttonDown=0x5186058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#115 QApplicationPrivate::sendMouseEvent (receiver=0xa68d8d0, event=0xbfefc5b0, alienWidget=0x0, nativeWidget=0xa68d8d0, buttonDown=0x5186058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#116 0x048d45cf in QETWidget::translateMouseEvent (this=0xa68d8d0, event=0xbfefcacc) at kernel/qapplication_x11.cpp:4302
#117 0x048d3511 in QApplication::x11ProcessEvent (this=0xbfefd1ec, event=0xbfefcacc) at kernel/qapplication_x11.cpp:3379
#118 0x0490260a in x11EventSourceDispatch (s=0x92f0da8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#119 0x08c5c5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#120 0x08c602d8 in ?? () from /lib/libglib-2.0.so.0
#121 0x08c604b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#122 0x0170c5d5 in QEventDispatcherGlib::processEvents (this=0x92d82a0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#123 0x04902135 in QGuiEventDispatcherGlib::processEvents (this=0x92d82a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#124 0x016df059 in QEventLoop::processEvents (this=0xbfefcdc4, flags=) at kernel/qeventloop.cpp:149
#125 0x016df4aa in QEventLoop::exec (this=0xbfefcdc4, flags=...) at kernel/qeventloop.cpp:201
#126 0x016e369f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#127 0x04842577 in QApplication::exec () at kernel/qapplication.cpp:3579
#128 0x0821dc23 in main (argc=5, argv=0xbfefd574) at ../../../kstars/kstars/main.cpp:191

This bug may be a duplicate of or related to bug 237124.

Possible duplicates by query: bug 237124.

Reported using DrKonqi
Comment 1 Pino Toscano 2010-10-04 20:07:25 UTC

*** This bug has been marked as a duplicate of bug 237124 ***