Bug 255681 - Marble crashes right after it started
Summary: Marble crashes right after it started
Status: RESOLVED DUPLICATE of bug 240641
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 1.0 (KDE 4.6)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-30 18:41 UTC by torsten.roters
Modified: 2010-11-01 10:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description torsten.roters 2010-10-30 18:41:03 UTC
Application: marble (0.10.1)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed: Starting Marble results in crash right after the program window was shown.

The crash can be reproduced every time.

-- Backtrace:
Application: Marble – Schreibtischglobus (marble), signal: Floating point exception
[Current thread is 1 (Thread 0xb3a18710 (LWP 5374))]

Thread 4 (Thread 0xb143db70 (LWP 5375)):
#0  0xb40ec22b in clock_gettime () from /lib/librt.so.1
#1  0xb69f7004 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6aca816 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6ac905b in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6ac90fd in ?? () from /usr/lib/libQtCore.so.4
#5  0xb40400c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#6  0xb4040f22 in ?? () from /usr/lib/libglib-2.0.so.0
#7  0xb404160e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#8  0xb6ac98a7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0xb6a9a40d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb6a9a639 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb6999689 in QThread::exec() () from /usr/lib/libQtCore.so.4
#12 0xb6a79e5d in ?? () from /usr/lib/libQtCore.so.4
#13 0xb699c27a in ?? () from /usr/lib/libQtCore.so.4
#14 0xb5976b25 in start_thread () from /lib/libpthread.so.0
#15 0xb5bd346e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb0955b70 (LWP 5376)):
#0  0xb40ec22b in clock_gettime () from /lib/librt.so.1
#1  0xb69f7004 in ?? () from /usr/lib/libQtCore.so.4
#2  0xb6aca816 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb6ac905b in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6ac90fd in ?? () from /usr/lib/libQtCore.so.4
#5  0xb40400c0 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#6  0xb4040f22 in ?? () from /usr/lib/libglib-2.0.so.0
#7  0xb404160e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#8  0xb6ac98a7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0xb6a9a40d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0xb6a9a639 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0xb6999689 in QThread::exec() () from /usr/lib/libQtCore.so.4
#12 0xb6a79e5d in ?? () from /usr/lib/libQtCore.so.4
#13 0xb699c27a in ?? () from /usr/lib/libQtCore.so.4
#14 0xb5976b25 in start_thread () from /lib/libpthread.so.0
#15 0xb5bd346e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaf836b70 (LWP 5378)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb597b452 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5be12a4 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb699c90c in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0xb6991cd4 in ?? () from /usr/lib/libQtCore.so.4
#5  0xb699c27a in ?? () from /usr/lib/libQtCore.so.4
#6  0xb5976b25 in start_thread () from /lib/libpthread.so.0
#7  0xb5bd346e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb3a18710 (LWP 5374)):
[KCrash Handler]
#7  0xb766385f in Marble::AbstractScanlineTextureMapper::nextTile (this=0x80e7d60, posX=@0xbffb99b8, posY=@0xbffb99b0)
    at /usr/src/debug/kdeedu-4.5.2/marble/src/lib/AbstractScanlineTextureMapper.cpp:565
#8  0xb76639f8 in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0x80e7d60, lon=-2.8531724910653531, lat=0.63309782186937769, scanLine=0xac4a2aa8)
    at /usr/src/debug/kdeedu-4.5.2/marble/src/lib/AbstractScanlineTextureMapper.cpp:178
#9  0xb7664d8c in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x80e7d60, viewParams=0x81c8014) at /usr/src/debug/kdeedu-4.5.2/marble/src/lib/SphericalScanlineTextureMapper.cpp:202
#10 0xb75d8b77 in Marble::MarbleModel::paintGlobe (this=0x81b4360, painter=0xbffb9e00, width=1178, height=673, viewParams=0x81c8014, redrawBackground=true, dirtyRect=...)
    at /usr/src/debug/kdeedu-4.5.2/marble/src/lib/MarbleModel.cpp:593
#11 0xb75dd64c in Marble::MarbleMapPrivate::paintGround (this=0x81c8000, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.5.2/marble/src/lib/MarbleMap.cpp:247
#12 0xb75cc57f in Marble::MarbleWidget::paintEvent (this=0x81e6b40, evt=0xbffba3a4) at /usr/src/debug/kdeedu-4.5.2/marble/src/lib/MarbleWidget.cpp:815
#13 0xb60123ba in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#14 0xb5fb71a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb5fbfe84 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb6fa69c1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0xb6a9b12e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0xb600f062 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/libQtGui.so.4
#19 0xb61fe5a7 in ?? () from /usr/lib/libQtGui.so.4
#20 0xb600253b in QWidgetPrivate::syncBackingStore() () from /usr/lib/libQtGui.so.4
#21 0xb6012e76 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#22 0xb644448c in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
#23 0xb7066c94 in KMainWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#24 0xb7066f32 in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#25 0xb5fb71a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb5fbfe84 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0xb6fa69c1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#28 0xb6a9b12e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#29 0xb61fab79 in ?? () from /usr/lib/libQtGui.so.4
#30 0xb6003bb2 in QWidget::repaint(QRect const&) () from /usr/lib/libQtGui.so.4
#31 0xb6003cd1 in QWidget::repaint() () from /usr/lib/libQtGui.so.4
#32 0xb75d1211 in Marble::MarbleWidget::setMapThemeId (this=0x81e6b40, mapThemeId=...) at /usr/src/debug/kdeedu-4.5.2/marble/src/lib/MarbleWidget.cpp:895
#33 0x080663e6 in Marble::MarblePart::readSettings (this=0x8183ee8) at /usr/src/debug/kdeedu-4.5.2/marble/src/marble_part.cpp:415
#34 0x0806817b in initObject (this=0x8183ee8, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x82dd3b0) at /usr/src/debug/kdeedu-4.5.2/marble/src/marble_part.cpp:153
#35 Marble::MarblePart::qt_metacall (this=0x8183ee8, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x82dd3b0) at /usr/src/debug/kdeedu-4.5.2/build/marble/src/marble_part.moc:160
#36 0xb6aa196d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#37 0xb6aac465 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#38 0xb6ab069f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#39 0xb5fb71a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#40 0xb5fbfdd7 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#41 0xb6fa69c1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#42 0xb6a9b12e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#43 0xb6a9ee6c in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#44 0xb6a9efbc in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#45 0xb6ac96d4 in ?? () from /usr/lib/libQtCore.so.4
#46 0xb4040b49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#47 0xb4041350 in ?? () from /usr/lib/libglib-2.0.so.0
#48 0xb404160e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#49 0xb6ac985b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#50 0xb606c19a in ?? () from /usr/lib/libQtGui.so.4
#51 0xb6a9a40d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#52 0xb6a9a639 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#53 0xb6a9f090 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#54 0xb5fb4ed4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#55 0x0805c7f5 in main (argc=) at /usr/src/debug/kdeedu-4.5.2/marble/src/kdemain.cpp:291

Possible duplicates by query: bug 252561, bug 247416, bug 240641, bug 235364.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2010-11-01 10:16:14 UTC

*** This bug has been marked as a duplicate of bug 240641 ***