Bug 252561 - marble crashes with restricted maps
Summary: marble crashes with restricted maps
Status: RESOLVED DUPLICATE of bug 240641
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 1.0 (KDE 4.6)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-27 17:28 UTC by saschae
Modified: 2010-09-27 21:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description saschae 2010-09-27 17:28:11 UTC
Application: marble (0.10.1)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.6.3
Operating System: Linux 2.6.31.14-0.1-default i686
Distribution: "openSUSE 11.2 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
It always crashes when I try to open a "german" (Berlin, Sachsen...) map from Bernhards quick and dirty WMS: http://www.gitorious.org/marble-restricted-maps. No problems with maps from Google.

The crash can be reproduced every time.

-- Backtrace:
Application: Marble – Schreibtischglobus (marble), signal: Floating point exception
[Current thread is 1 (Thread 0xb3807700 (LWP 10840))]

Thread 4 (Thread 0xb12cbb70 (LWP 10841)):
#0  0xb584d104 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb5a83484 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0xb41e9905 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb41e9ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb695e3cf in QEventDispatcherGlib::processEvents (this=0x81f0820, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#5  0xb692fd8d in QEventLoop::processEvents (this=0xb12cb2d0, flags=) at kernel/qeventloop.cpp:149
#6  0xb69301d9 in QEventLoop::exec (this=0xb12cb2d0, flags=...) at kernel/qeventloop.cpp:201
#7  0xb68298e3 in QThread::exec (this=0x81788c8) at thread/qthread.cpp:487
#8  0xb690e4fd in QInotifyFileSystemWatcherEngine::run (this=0x81788c8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0xb682c7cf in QThreadPrivate::start (arg=0x81788c8) at thread/qthread_unix.cpp:248
#10 0xb58496e5 in start_thread () from /lib/libpthread.so.0
#11 0xb5849600 in ?? () from /lib/libpthread.so.0

Thread 3 (Thread 0xb08e0b70 (LWP 10842)):
#0  0xb584d104 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb5a83484 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0xb41e960b in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#3  0xb41e9999 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb41e9ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb695e3cf in QEventDispatcherGlib::processEvents (this=0x82f5568, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#6  0xb692fd8d in QEventLoop::processEvents (this=0xb08e02d0, flags=) at kernel/qeventloop.cpp:149
#7  0xb69301d9 in QEventLoop::exec (this=0xb08e02d0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb68298e3 in QThread::exec (this=0x81de8e0) at thread/qthread.cpp:487
#9  0xb690e4fd in QInotifyFileSystemWatcherEngine::run (this=0x81de8e0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb682c7cf in QThreadPrivate::start (arg=0x81de8e0) at thread/qthread_unix.cpp:248
#11 0xb58496e5 in start_thread () from /lib/libpthread.so.0
#12 0xb5849600 in ?? () from /lib/libpthread.so.0

Thread 2 (Thread 0xafad5b70 (LWP 10848)):
#0  0xb42771eb in clock_gettime () from /lib/librt.so.1
#1  0xb695b1cc in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0xb6960616 in QTimerInfoList::updateCurrentTime (this=0x8f4390c) at kernel/qeventdispatcher_unix.cpp:340
#3  0xb696065e in QTimerInfoList::timerWait (this=0x8f4390c, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0xb695e5cb in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xafad510c) at kernel/qeventdispatcher_glib.cpp:136
#5  0xb695e66d in timerSourcePrepare (source=0x0, timeout=0xb427bff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0xb41e9618 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#7  0xb41e9999 in ?? () from /usr/lib/libglib-2.0.so.0
#8  0xb41e9ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#9  0xb695e3cf in QEventDispatcherGlib::processEvents (this=0x845a330, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0xb692fd8d in QEventLoop::processEvents (this=0xafad52a0, flags=) at kernel/qeventloop.cpp:149
#11 0xb69301d9 in QEventLoop::exec (this=0xafad52a0, flags=...) at kernel/qeventloop.cpp:201
#12 0xb68298e3 in QThread::exec (this=0x82a19a8) at thread/qthread.cpp:487
#13 0xb7558338 in Marble::FileStorageWatcher::run (this=0x82a19a8) at /usr/src/debug/kdeedu-4.5.1/marble/src/lib/FileStorageWatcher.cpp:401
#14 0xb682c7cf in QThreadPrivate::start (arg=0x82a19a8) at thread/qthread_unix.cpp:248
#15 0xb58496e5 in start_thread () from /lib/libpthread.so.0
#16 0xb5849600 in ?? () from /lib/libpthread.so.0

Thread 1 (Thread 0xb3807700 (LWP 10840)):
[KCrash Handler]
#7  0xb754a98f in Marble::AbstractScanlineTextureMapper::nextTile (this=0x8d4a9f8, posX=@0xbfbe3738, posY=@0xbfbe3730)
    at /usr/src/debug/kdeedu-4.5.1/marble/src/lib/AbstractScanlineTextureMapper.cpp:565
#8  0xb754b6e8 in Marble::AbstractScanlineTextureMapper::pixelValueF (this=0x8d4a9f8, lon=0.22122854380044624, lat=0.89934733034677206, scanLine=0xaf0d4008)
    at /usr/src/debug/kdeedu-4.5.1/marble/src/lib/AbstractScanlineTextureMapper.cpp:178
#9  0xb754d6da in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x8d4a9f8, viewParams=0x81ef7ec) at /usr/src/debug/kdeedu-4.5.1/marble/src/lib/SphericalScanlineTextureMapper.cpp:202
#10 0xb74bafad in Marble::MarbleModel::paintGlobe (this=0x81d3bd0, painter=0xbfbe3b70, width=832, height=631, viewParams=0x81ef7ec, redrawBackground=true, dirtyRect=...)
    at /usr/src/debug/kdeedu-4.5.1/marble/src/lib/MarbleModel.cpp:593
#11 0xb74c353c in Marble::MarbleMapPrivate::paintGround (this=0x81ef7d8, painter=..., dirtyRect=...) at /usr/src/debug/kdeedu-4.5.1/marble/src/lib/MarbleMap.cpp:247
#12 0xb74b047f in Marble::MarbleWidget::paintEvent (this=0x81d4950, evt=0xbfbe4134) at /usr/src/debug/kdeedu-4.5.1/marble/src/lib/MarbleWidget.cpp:815
#13 0xb5ebb5cf in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#14 0xb5e5ae3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0xb5e61d08 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0xb6e901b1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0xb693171e in QCoreApplication::notifyInternal (this=0xbfbe62c8, receiver=0x81d4950, event=0xbfbe4134) at kernel/qcoreapplication.cpp:726
#18 0xb5ec498c in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/libQtGui.so.4
#19 0xb60a7177 in ?? () from /usr/lib/libQtGui.so.4
#20 0xb5eb4d2b in QWidgetPrivate::syncBackingStore() () from /usr/lib/libQtGui.so.4
#21 0xb5ebbda4 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#22 0xb62e8484 in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
#23 0xb6f53484 in KMainWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#24 0xb6f76702 in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#25 0xb5e5ae3c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#26 0xb5e61d08 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0xb6e901b1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#28 0xb693171e in QCoreApplication::notifyInternal (this=0xbfbe62c8, receiver=0x81264c0, event=0xbfbe4b04) at kernel/qcoreapplication.cpp:726
#29 0xb60a42f9 in ?? () from /usr/lib/libQtGui.so.4
#30 0xb60a7b44 in ?? () from /usr/lib/libQtGui.so.4
#31 0xb5eb7325 in QWidget::repaint(QRect const&) () from /usr/lib/libQtGui.so.4
#32 0xb5eb7441 in QWidget::repaint() () from /usr/lib/libQtGui.so.4
#33 0xb74b5af1 in Marble::MarbleWidget::setMapThemeId (this=0x81d4950, mapThemeId=...) at /usr/src/debug/kdeedu-4.5.1/marble/src/lib/MarbleWidget.cpp:895
#34 0xb74b72dd in Marble::MarbleWidget::qt_metacall (this=0x81d4950, _c=InvokeMetaMethod, _id=54, _a=0xbfbe4de8) at /usr/src/debug/kdeedu-4.5.1/build/marble/src/lib/MarbleWidget.moc:339
#35 0xb6936b2d in QMetaObject::metacall (object=0x81d4950, cl=1796500542, idx=81, argv=0xbfbe4de8) at kernel/qmetaobject.cpp:237
#36 0xb6945d80 in QMetaObject::activate (sender=0x8129728, m=0xb7611ae8, local_signal_index=9, argv=0xbfbe4de8) at kernel/qobject.cpp:3295
#37 0xb74c6a55 in Marble::MarbleControlBox::selectMapTheme (this=0x8129728, _t1=...) at /usr/src/debug/kdeedu-4.5.1/build/marble/src/lib/MarbleControlBox.moc:242
#38 0xb74cbb33 in Marble::MarbleControlBox::qt_metacall (this=0x8129728, _c=InvokeMetaMethod, _id=36, _a=0xbfbe4f28) at /usr/src/debug/kdeedu-4.5.1/build/marble/src/lib/MarbleControlBox.moc:147
#39 0xb6936b2d in QMetaObject::metacall (object=0x8129728, cl=1796500542, idx=36, argv=0xbfbe4f28) at kernel/qmetaobject.cpp:237
#40 0xb6945d80 in QMetaObject::activate (sender=0x818aaf0, m=0xb7611e74, local_signal_index=0, argv=0xbfbe4f28) at kernel/qobject.cpp:3295
#41 0xb74d74e5 in Marble::MarbleThemeSelectView::selectMapTheme (this=0x818aaf0, _t1=...) at /usr/src/debug/kdeedu-4.5.1/build/marble/src/lib/MarbleThemeSelectView.moc:90
#42 0xb74d79d3 in Marble::MarbleThemeSelectView::selectedMapTheme (this=0x818aaf0, index=...) at /usr/src/debug/kdeedu-4.5.1/marble/src/lib/MarbleThemeSelectView.cpp:57
#43 0xb74d7bf7 in Marble::MarbleThemeSelectView::qt_metacall (this=0x818aaf0, _c=InvokeMetaMethod, _id=71, _a=0xbfbe50e8)
    at /usr/src/debug/kdeedu-4.5.1/build/marble/src/lib/MarbleThemeSelectView.moc:78
#44 0xb6936b2d in QMetaObject::metacall (object=0x818aaf0, cl=1796500542, idx=71, argv=0xbfbe50e8) at kernel/qmetaobject.cpp:237
#45 0xb6945d80 in QMetaObject::activate (sender=0x818aaf0, m=0xb67b4104, local_signal_index=0, argv=0xbfbe50e8) at kernel/qobject.cpp:3295
#46 0xb640e7a5 in QAbstractItemView::pressed(QModelIndex const&) () from /usr/lib/libQtGui.so.4
#47 0xb641aba5 in QAbstractItemView::mousePressEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#48 0xb5ebba5d in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#49 0xb62c90e5 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#50 0xb6366041 in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#51 0xb641fd8c in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#52 0xb6368936 in ?? () from /usr/lib/libQtGui.so.4
#53 0xb69309ee in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x80b9a30, receiver=0x8163480, event=0xbfbe5a60) at kernel/qcoreapplication.cpp:841
#54 0xb5e5ae0d in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#55 0xb5e6263e in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#56 0xb6e901b1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#57 0xb693171e in QCoreApplication::notifyInternal (this=0xbfbe62c8, receiver=0x8163480, event=0xbfbe5a60) at kernel/qcoreapplication.cpp:726
#58 0xb5e61584 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#59 0xb5eef41a in ?? () from /usr/lib/libQtGui.so.4
#60 0xb5eee9c4 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#61 0xb5f1c0e8 in ?? () from /usr/lib/libQtGui.so.4
#62 0xb41e64c2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#63 0xb41e9d98 in ?? () from /usr/lib/libglib-2.0.so.0
#64 0xb41e9ebe in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#65 0xb695e381 in QEventDispatcherGlib::processEvents (this=0x80a4970, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#66 0xb5f1bc3a in ?? () from /usr/lib/libQtGui.so.4
#67 0xb692fd8d in QEventLoop::processEvents (this=0xbfbe6224, flags=) at kernel/qeventloop.cpp:149
#68 0xb69301d9 in QEventLoop::exec (this=0xbfbe6224, flags=...) at kernel/qeventloop.cpp:201
#69 0xb6935480 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#70 0xb5e5aee4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#71 0x0805ca65 in main (argc=1, argv=0xbfbe6814) at /usr/src/debug/kdeedu-4.5.1/marble/src/kdemain.cpp:291

Possible duplicates by query: bug 247416, bug 240641, bug 235364.

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2010-09-27 21:52:24 UTC

*** This bug has been marked as a duplicate of bug 240641 ***