Bug 252767 - crash at startup
Summary: crash at startup
Status: RESOLVED DUPLICATE of bug 245266
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-29 16:13 UTC by joao
Modified: 2010-11-18 19:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.43 KB, text/plain)
2010-10-06 20:07 UTC, david a lawson
Details
New crash information added by DrKonqi (6.57 KB, text/plain)
2010-10-11 22:47 UTC, Patrick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joao 2010-09-29 16:13:21 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-25-generic x86_64
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed: I was booting de system, just after to put de user and password of may pc. When kde was booting all the aplications the program crashes. The other times that the aplication was crashed was in the same way.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Adaptador del servei Nepomuk (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7fb0e89760 (LWP 1806))]

Thread 2 (Thread 0x7f7fa0cc6710 (LWP 1953)):
[KCrash Handler]
#6  QMutex::lock (this=0x65007200637588) at thread/qmutex.cpp:151
#7  0x00007f7faa9fb64d in Soprano::Error::ErrorCache::clearError() const () from /usr/lib/libsoprano.so.4
#8  0x00007f7faa9fbc78 in Soprano::Error::ErrorCache::setError(Soprano::Error::Error const&) const () from /usr/lib/libsoprano.so.4
#9  0x00007f7faa78c7ba in Soprano::Client::DBusModel::executeQuery(QString const&, Soprano::Query::QueryLanguage, QString const&) const () from /usr/lib/libsopranoclient.so.1
#10 0x00007f7faf5e79c3 in Nepomuk::MainModel::executeQuery (this=0x1451430, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at ../../nepomuk/core/nepomukmainmodel.cpp:212
#11 0x00007f7faaa0b10c in Soprano::FilterModel::executeQuery(QString const&, Soprano::Query::QueryLanguage, QString const&) const () from /usr/lib/libsoprano.so.4
#12 0x00007f7faf5dbcd7 in Nepomuk::ResourceData::determineUri (this=0x1494700) at ../../nepomuk/core/resourcedata.cpp:580
#13 0x00007f7faf5eb97a in Nepomuk::Resource::determineFinalResourceData (this=0x7f7fa0cc5970) at ../../nepomuk/core/resource.cpp:885
#14 0x00007f7faf5ebc09 in Nepomuk::Resource::exists (this=0x65007200637588) at ../../nepomuk/core/resource.cpp:328
#15 0x00007f7fa0d3cf3c in Nepomuk::MetadataMover::removeMetadata (this=<value optimized out>, url=...) at ../../../../nepomuk/services/filewatch/metadatamover.cpp:180
#16 0x00007f7fa0d3fa2b in Nepomuk::MetadataMover::run (this=0x1431be0) at ../../../../nepomuk/services/filewatch/metadatamover.cpp:142
#17 0x00007f7fb08782ee in QThreadPrivate::start (arg=0x1431be0) at thread/qthread_unix.cpp:266
#18 0x00007f7fb05e69ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#19 0x00007f7fae3046fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7fb0e89760 (LWP 1806)):
#0  0x00007f7fae2f7f83 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f7fa6fe7c60 in ?? () from /lib/libdbus-1.so.3
#2  0x00007f7fa6fe606d in ?? () from /lib/libdbus-1.so.3
#3  0x00007f7fa6fd259e in ?? () from /lib/libdbus-1.so.3
#4  0x00007f7fa6fd2d52 in ?? () from /lib/libdbus-1.so.3
#5  0x00007f7fa6fd4881 in ?? () from /lib/libdbus-1.so.3
#6  0x00007f7fa6fd3f56 in dbus_connection_send_with_reply_and_block () from /lib/libdbus-1.so.3
#7  0x00007f7fb038dc8f in q_dbus_connection_send_with_reply_and_block (this=0x13a2450, message=<value optimized out>, sendMode=<value optimized out>, timeout=-1) at qdbus_symbols_p.h:135
#8  QDBusConnectionPrivate::sendWithReply (this=0x13a2450, message=<value optimized out>, sendMode=<value optimized out>, timeout=-1) at qdbusintegrator.cpp:1844
#9  0x00007f7fb0378c33 in QDBusConnection::call (this=0x145d9f0, message=..., mode=4294967295, timeout=0) at qdbusconnection.cpp:530
#10 0x00007f7fb0398e32 in QDBusAbstractInterface::callWithArgumentList (this=<value optimized out>, mode=QDBus::Block, method=<value optimized out>, args=<value optimized out>)
    at qdbusabstractinterface.cpp:444
#11 0x00007f7faa789b24 in ?? () from /usr/lib/libsopranoclient.so.1
#12 0x00007f7faa78a5dd in Soprano::Client::DBusClient::createModel(QString const&, QList<Soprano::BackendSetting> const&) () from /usr/lib/libsopranoclient.so.1
#13 0x00007f7faf5e6a32 in init (this=0x1459190, forced=true) at ../../nepomuk/core/nepomukmainmodel.cpp:92
#14 0x00007f7faf5ea00a in Nepomuk::MainModel::init (this=0x1451430) at ../../nepomuk/core/nepomukmainmodel.cpp:176
#15 0x00007f7faf5e0584 in Nepomuk::ResourceManager::init (this=0x1455dc0) at ../../nepomuk/core/resourcemanager.cpp:329
#16 0x00007f7faf5e20e5 in Nepomuk::ResourceManagerPrivate::_k_storageServiceInitialized (this=0x145d810, success=<value optimized out>) at ../../nepomuk/core/resourcemanager.cpp:220
#17 0x00007f7faf5e21c5 in Nepomuk::ResourceManager::qt_metacall (this=0x1455dc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff900b67f0) at ./resourcemanager.moc:90
#18 0x00007f7fb038895e in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:919
#19 0x00007f7fb039382f in QDBusCallDeliveryEvent::placeMetaCall (this=0x1, object=0x1) at qdbusintegrator_p.h:103
#20 0x00007f7fb097ce7e in QObject::event (this=0x1455dc0, e=0x7fff900b5bc0) at kernel/qobject.cpp:1219
#21 0x00007f7faea7f6ec in QApplicationPrivate::notify_helper (this=0x1308be0, receiver=0x1455dc0, e=0x1494790) at kernel/qapplication.cpp:4396
#22 0x00007f7faea851dd in QApplication::notify (this=0x7fff900b7400, receiver=0x1455dc0, e=0x1494790) at kernel/qapplication.cpp:4277
#23 0x00007f7fafa72536 in KApplication::notify (this=0x7fff900b7400, receiver=0x1455dc0, event=0x1494790) at ../../kdeui/kernel/kapplication.cpp:310
#24 0x00007f7fb096b0ac in QCoreApplication::notifyInternal (this=0x7fff900b7400, receiver=0x1455dc0, event=0x1494790) at kernel/qcoreapplication.cpp:732
#25 0x00007f7fb096dfd2 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x12f2020) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x12f2020) at kernel/qcoreapplication.cpp:1373
#27 0x00007f7fb0997643 in QCoreApplication::sendPostedEvents (s=0x130c810) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=0x130c810) at kernel/qeventdispatcher_glib.cpp:277
#29 0x00007f7fad7568c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#30 0x00007f7fad75a748 in ?? () from /lib/libglib-2.0.so.0
#31 0x00007f7fad75a8fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#32 0x00007f7fb0997183 in QEventDispatcherGlib::processEvents (this=0x12f1770, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#33 0x00007f7faeb3197e in QGuiEventDispatcherGlib::processEvents (this=0x7fff900b5bc0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f7fb0969dd2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#35 0x00007f7fb096a1bc in QEventLoop::exec (this=0x7fff900b7230, flags=) at kernel/qeventloop.cpp:201
#36 0x00007f7fb096e26b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#37 0x0000000000403efd in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../nepomuk/servicestub/main.cpp:165

Possible duplicates by query: bug 251375, bug 245266, bug 234994.

Reported using DrKonqi
Comment 1 david a lawson 2010-10-06 20:07:54 UTC
Created attachment 52288 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.5.1 (KDE 4.5.1) using Qt 4.7.0

- What I was doing when the application crashed: booting up.
3rd consecutive time it occured

-- Backtrace (Reduced):
#6  QMutex::lock (this=0x65007200630e28) at thread/qmutex.cpp:151
#10 0x00007f42d8d959c3 in Nepomuk::MainModel::executeQuery (this=0x1701520, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at ../../nepomuk/core/nepomukmainmodel.cpp:212
#12 0x00007f42d8d89cd7 in Nepomuk::ResourceData::determineUri (this=0x173b880) at ../../nepomuk/core/resourcedata.cpp:580
#13 0x00007f42d8d9997a in Nepomuk::Resource::determineFinalResourceData (this=0x7f42cab3a970) at ../../nepomuk/core/resource.cpp:885
#14 0x00007f42d8d99c09 in Nepomuk::Resource::exists (this=0x65007200630e28) at ../../nepomuk/core/resource.cpp:328
Comment 2 Patrick 2010-10-11 22:47:21 UTC
Created attachment 52426 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.5.2 (KDE 4.5.2) using Qt 4.7.0

- What I was doing when the application crashed:
booted-up and inserted an SD card in reader (not related, is it?)

-- Backtrace (Reduced):
#6  QMutex::lock (this=0x65007200630948) at thread/qmutex.cpp:151
#10 0x00007fe2daa20624 in Nepomuk::MainModel::executeQuery (this=0x7a4980, query=..., language=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...)
    at /usr/src/debug/kdelibs-4.5.2/nepomuk/core/nepomukmainmodel.cpp:212
#12 0x00007fe2cc93b4f0 in Nepomuk::MetadataMover::removeMetadata (this=<value optimized out>, url=<value optimized out>)
    at /usr/src/debug/kdebase-runtime-4.5.2/nepomuk/services/filewatch/metadatamover.cpp:209
#13 0x00007fe2cc93d7b6 in Nepomuk::MetadataMover::run (this=0x7a7140) at /usr/src/debug/kdebase-runtime-4.5.2/nepomuk/services/filewatch/metadatamover.cpp:142
#14 0x00007fe2dbc428be in QThreadPrivate::start (arg=0x7a7140) at thread/qthread_unix.cpp:266
Comment 3 Dario Andres 2010-11-18 19:01:56 UTC
[Comment from a bug triager]
This issue is being tracked at bug 245266. Merging. Thanks

*** This bug has been marked as a duplicate of bug 245266 ***