Bug 267939 - Kwin freezes when playing flash video on chrome
Summary: Kwin freezes when playing flash video on chrome
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-08 06:12 UTC by notuenmc
Modified: 2011-03-08 15:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description notuenmc 2011-03-08 06:12:01 UTC
Application: kwin (4.6.1 (4.6.1))
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-5-generic x86_64
Distribution: Ubuntu Natty (development branch)

-- Information about the crash:
Watching flash video on chrome.
Kwin crash but chrome remain running.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f02b3b117a0 (LWP 1209))]

Thread 3 (Thread 0x7f029897d700 (LWP 1270)):
#0  0x00007f02b333f223 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f02af72536c in qt_safe_select (nfds=17, fdread=0x28d3140, fdwrite=0x28d33d8, fdexcept=0x28d3670, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007f02af72a410 in QEventDispatcherUNIXPrivate::doSelect (this=0x28d2f80, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f02af72b08a in QEventDispatcherUNIX::processEvents (this=0x2534a60, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#4  0x00007f02af6fc852 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f02af6fca8c in QEventLoop::exec (this=0x7f029897cdb0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f02af613904 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f02af6debdf in QInotifyFileSystemWatcherEngine::run (this=0x25230f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f02af616155 in QThreadPrivate::start (arg=0x25230f0) at thread/qthread_unix.cpp:320
#9  0x00007f02a9d0fd8c in start_thread (arg=0x7f029897d700) at pthread_create.c:304
#10 0x00007f02b334717d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f0293fff700 (LWP 1271)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f02b21a6982 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f02b24c0180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f02b21a69b9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f02b24ce254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f02a9d0fd8c in start_thread (arg=0x7f0293fff700) at pthread_create.c:304
#4  0x00007f02b334717d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f02b3b117a0 (LWP 1209)):
[KCrash Handler]
#6  intel_region_buffer (intel=0x136d410, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f029b6ca552 in intelClearWithBlit (ctx=0x136d410, mask=2) at intel_blit.c:262
#8  0x00007f029b6ccb9a in intelClear (ctx=0x136d410, mask=2) at intel_clear.c:177
#9  0x00007f02b36cfa87 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f02b36c762f in KWin::Scene::paintGenericScreen (this=0x1361810, orig_mask=40) at ../../kwin/scene.cpp:188
#11 0x00007f02b36c4a7a in KWin::Scene::finalPaintScreen (this=0x1361810, mask=40, region=<value optimized out>, data=<value optimized out>) at ../../kwin/scene.cpp:178
#12 0x00007f02b36e2cc9 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:173
#13 0x00007f029a771ed6 in KWin::StartupFeedbackEffect::paintScreen (this=0x2636c70, mask=40, region=<value optimized out>, data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f029a7192ed in KWin::LogoutEffect::paintScreen (this=0x276b6e0, mask=40, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#18 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#19 0x00007f029a73446b in KWin::ShadowEffect::paintScreen (this=0x250b9d0, mask=40, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#20 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=40, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#21 0x00007f029a7468e8 in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#22 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#23 0x00007f029a71dead in KWin::PresentWindowsEffect::paintScreen (this=0x24ec8c0, mask=8, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#25 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#27 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#28 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#29 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#31 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#33 0x00007f029a705325 in KWin::DesktopGridEffect::paintScreen (this=0x24d6cc0, mask=8, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#35 0x00007f029a73aa8f in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/slide/slide.cpp:86
#36 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#37 0x00007f029a6feb8d in KWin::BoxSwitchEffect::paintScreen (this=0x27f73c0, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#39 0x00007f029a754c36 in KWin::CubeEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#40 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#41 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#43 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#45 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#47 0x00007f029a74d7b6 in KWin::CoverSwitchEffect::paintScreen (this=0x269cf10, mask=8, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#48 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#49 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#50 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#51 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#52 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#53 0x00007f02b1790a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#54 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#55 0x00007f029a743e1b in KWin::ZoomEffect::paintScreen (this=0x28242c0, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#56 0x00007f02b36e2d53 in KWin::EffectsHandlerImpl::paintScreen (this=0x24914d0, mask=8, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#57 0x00007f02b36c6e4f in KWin::Scene::paintScreen (this=0x1361810, mask=0x7fffada8ca8c, region=0x7fffada8cb50) at ../../kwin/scene.cpp:137
#58 0x00007f02b36dacb3 in KWin::SceneOpenGL::paint (this=0x1361810, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#59 0x00007f02b36c2196 in KWin::Workspace::performCompositing (this=0x7f0294353bf0) at ../../kwin/composite.cpp:448
#60 0x00007f02af7111a9 in QObject::event (this=0x7f0294353bf0, e=<value optimized out>) at kernel/qobject.cpp:1190
#61 0x00007f02aeabe9e4 in QApplicationPrivate::notify_helper (this=0x1262270, receiver=0x7f0294353bf0, e=0x7fffada8d2e0) at kernel/qapplication.cpp:4462
#62 0x00007f02aeac33aa in QApplication::notify (this=<value optimized out>, receiver=0x7f0294353bf0, e=0x7fffada8d2e0) at kernel/qapplication.cpp:4341
#63 0x00007f02b2e42966 in KApplication::notify (this=0x7fffada8d6e0, receiver=0x7f0294353bf0, event=0x7fffada8d2e0) at ../../kdeui/kernel/kapplication.cpp:311
#64 0x00007f02af6fd46c in QCoreApplication::notifyInternal (this=0x7fffada8d6e0, receiver=0x7f0294353bf0, event=0x7fffada8d2e0) at kernel/qcoreapplication.cpp:731
#65 0x00007f02af72af52 in sendEvent (this=0x1262dc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#66 QTimerInfoList::activateTimers (this=0x1262dc0) at kernel/qeventdispatcher_unix.cpp:604
#67 0x00007f02af72b09b in QEventDispatcherUNIX::processEvents (this=0x1234340, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#68 0x00007f02aeb66b8c in QEventDispatcherX11::processEvents (this=0x1234340, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#69 0x00007f02af6fc852 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#70 0x00007f02af6fca8c in QEventLoop::exec (this=0x7fffada8d620, flags=...) at kernel/qeventloop.cpp:201
#71 0x00007f02af700e9b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#72 0x00007f02b365ff9c in kdemain (argc=<value optimized out>, argv=0x7fffada8dd78) at ../../kwin/main.cpp:542
#73 0x00007f02b327fefe in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fffada8dd78, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffada8dd68) at libc-start.c:226
#74 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 252817.

Possible duplicates by query: bug 266132, bug 264258, bug 257115, bug 256128, bug 252824.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-03-08 15:58:01 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***