Bug 266132 - KWin 4.6 crashes often while playing flash videos (Intel Arrandale)
Summary: KWin 4.6 crashes often while playing flash videos (Intel Arrandale)
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-12 14:05 UTC by timshel
Modified: 2011-02-12 14:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description timshel 2011-02-12 14:05:26 UTC
Application: kwin (4.6.00 (4.6.0))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-20-desktop x86_64
Distribution: "openSUSE 11.4 RC 1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Watching a Flash video. This usually happens when I watch the video in full screen. It doesn't happen all the time but I had this issue at least two times.

- Unusual behavior I noticed:
The taskbar and window borders disappeared and kwin was restarted.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f792c309760 (LWP 1369))]

Thread 2 (Thread 0x7f79122b5700 (LWP 1394)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f792a9d3044 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f792acec180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f792a9d3079 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f792acfa254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f7927bd2a3f in start_thread (arg=0x7f79122b5700) at pthread_create.c:297
#4  0x00007f792bb6567d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f792c309760 (LWP 1369)):
[KCrash Handler]
#6  intel_region_buffer (intel=0xb05400, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f7913eb12e4 in intelClearWithBlit (ctx=0xb05400, mask=2) at intel_blit.c:262
#8  0x00007f7913eb37ea in intelClear (ctx=0xb05400, mask=2) at intel_clear.c:177
#9  0x00007f792beca625 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#10 0x00007f792bec1d96 in KWin::Scene::paintGenericScreen (this=0xc813e0, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
#11 0x00007f792bebeeea in KWin::Scene::finalPaintScreen (this=0xc813e0, mask=40, region=<value optimized out>, data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:178
#12 0x00007f792bedc38f in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:173
#13 0x00007f79125eed7b in KWin::StartupFeedbackEffect::paintScreen (this=0xfa6510, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/startupfeedback/startupfeedback.cpp:166
#14 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#15 0x00007f7929fc1f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#16 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#17 0x00007f7912595f3f in KWin::LogoutEffect::paintScreen (this=0xf4b670, mask=40, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/logout/logout.cpp:207
#18 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#19 0x00007f79125b0b72 in KWin::ShadowEffect::paintScreen (this=0xcbb4d0, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/shadow/shadow.cpp:189
#20 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=40, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#21 0x00007f79125c34fe in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/blur/blur.cpp:230
#22 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#23 0x00007f791259a9c2 in KWin::PresentWindowsEffect::paintScreen (this=0xc5c100, mask=8, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/presentwindows/presentwindows.cpp:205
#24 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#25 0x00007f7929fc1f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#26 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#27 0x00007f7929fc1f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#28 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#29 0x00007f7929fc1f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#30 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#31 0x00007f7929fc1f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#32 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#33 0x00007f79125812a3 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/desktopgrid/desktopgrid.cpp:155
#34 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#35 0x00007f79125b734d in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/slide/slide.cpp:86
#36 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#37 0x00007f7912579e42 in KWin::BoxSwitchEffect::paintScreen (this=0xbe9f50, mask=8, region=..., data=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:143
#38 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#39 0x00007f7929fc1f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#40 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#41 0x00007f7929fc1f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#42 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#43 0x00007f7929fc1f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#44 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#45 0x00007f79125ca384 in KWin::CoverSwitchEffect::paintScreen (this=0xdd9da0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/coverswitch/coverswitch.cpp:126
#46 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#47 0x00007f7929fc1f7f in KWin::Effect::paintScreen (this=<value optimized out>, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/lib/kwineffects.cpp:227
#48 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#49 0x00007f79125c0b7f in KWin::ZoomEffect::paintScreen (this=0xe47030, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/zoom/zoom.cpp:341
#50 0x00007f792bedc41c in KWin::EffectsHandlerImpl::paintScreen (this=0xccbb90, mask=8, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
#51 0x00007f792bebffa5 in KWin::Scene::paintScreen (this=0xc813e0, mask=0x7fffe06987ac, region=0x7fffe06988c0) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:137
#52 0x00007f792bed44e9 in KWin::SceneOpenGL::paint (this=0xc813e0, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:772
#53 0x00007f792bebc5aa in KWin::Workspace::performCompositing (this=0xb035f0) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/composite.cpp:442
#54 0x00007f7927f5e799 in QObject::event (this=0xb035f0, e=<value optimized out>) at kernel/qobject.cpp:1175
#55 0x00007f79270f9d14 in QApplicationPrivate::notify_helper (this=0x6374a0, receiver=0xb035f0, e=0x7fffe06990e0) at kernel/qapplication.cpp:4445
#56 0x00007f792710222a in QApplication::notify (this=<value optimized out>, receiver=0xb035f0, e=0x7fffe06990e0) at kernel/qapplication.cpp:4324
#57 0x00007f792b5dd9e6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#58 0x00007f7927f4abfc in QCoreApplication::notifyInternal (this=0x7fffe06995c0, receiver=0xb035f0, event=0x7fffe06990e0) at kernel/qcoreapplication.cpp:732
#59 0x00007f7927f784d8 in sendEvent (this=0x637eb0) at kernel/qcoreapplication.h:215
#60 QTimerInfoList::activateTimers (this=0x637eb0) at kernel/qeventdispatcher_unix.cpp:618
#61 0x00007f7927f78be0 in QEventDispatcherUNIX::processEvents (this=0x613060, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#62 0x00007f792719fbac in QEventDispatcherX11::processEvents (this=0x613060, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#63 0x00007f7927f4a052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#64 0x00007f7927f4a265 in QEventLoop::exec (this=0x7fffe06994b0, flags=...) at kernel/qeventloop.cpp:201
#65 0x00007f7927f4e6ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#66 0x00007f792be5ac8a in kdemain (argc=<value optimized out>, argv=0x7fffe0699620) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/main.cpp:542
#67 0x00007f792bab0bfd in __libc_start_main (main=0x400770 <main(int, char**)>, argc=3, ubp_av=0x7fffe0699c58, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffe0699c48) at libc-start.c:226
#68 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113

Possible duplicates by query: bug 264258, bug 257115, bug 256128, bug 252824, bug 252817.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-02-12 14:12:51 UTC

*** This bug has been marked as a duplicate of bug 252817 ***