Bug 256128 - Plasma freezes aufter startup
Summary: Plasma freezes aufter startup
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-05 11:20 UTC by Jens Mander
Modified: 2010-11-05 15:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Mander 2010-11-05 11:20:43 UTC
Application: kwin (4.5.3 (KDE 4.5.3) "release 8")
KDE Platform Version: 4.5.3 (KDE 4.5.3) "release 8"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-default i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
I started opensuse

- Unusual behavior I noticed:
Programs still work
All Plasma progs are inaccessable an don't react on mouseclicks (left, right)...
They just don't get the focus.

- Custom settings of the application:
NONE

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#7  intel_region_buffer (intel=0x81c6060, region=0x0, flag=2) at intel_regions.c:498
#8  0xafd7c372 in intelClearWithBlit (ctx=0x81c6060, mask=2) at intel_blit.c:266
#9  0xafd74268 in intelClear (ctx=0x81c6060, mask=2) at intel_clear.c:173
#10 0xafdbae56 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:178
#11 0xb772d28b in KWin::SceneOpenGL::paintBackground (this=0x8181a00, region=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene_opengl.cpp:899
#12 0xb7794974 in KWin::Scene::paintGenericScreen (this=0x8181a00, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene.cpp:187
#13 0xb7761380 in KWin::Scene::finalPaintScreen (this=0x8181a00, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene.cpp:177
#14 0xb7797d63 in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:172
#15 0xaf2b38d2 in KWin::LogoutEffect::paintScreen (this=0x856aae0, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/logout/logout.cpp:207
#16 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#17 0xaf2cf87f in KWin::ShadowEffect::paintScreen (this=0x851c8c8, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/shadow/shadow.cpp:189
#18 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#19 0xaf2df491 in KWin::BlurEffect::paintScreen (this=0x85327a0, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/blur/blur.cpp:235
#20 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#21 0xaf2b88a4 in KWin::PresentWindowsEffect::paintScreen (this=0x857b6b8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/presentwindows/presentwindows.cpp:196
#22 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#23 0xb6e102ca in KWin::Effect::paintScreen (this=0x858c168, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#24 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#25 0xb6e102ca in KWin::Effect::paintScreen (this=0x8569db8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#26 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#27 0xb6e102ca in KWin::Effect::paintScreen (this=0x8563cf8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#28 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#29 0xb6e102ca in KWin::Effect::paintScreen (this=0x8517c08, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#30 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#31 0xb6e102ca in KWin::Effect::paintScreen (this=0x852da50, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#32 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#33 0xb6e102ca in KWin::Effect::paintScreen (this=0x851f308, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#34 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#35 0xb6e102ca in KWin::Effect::paintScreen (this=0x85351e0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#36 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#37 0xaf2fea1a in KWin::FlipSwitchEffect::paintScreen (this=0x8522428, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/flipswitch/flipswitch.cpp:146
#38 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#39 0xaf29771a in KWin::BoxSwitchEffect::paintScreen (this=0x858dfb0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/boxswitch/boxswitch.cpp:142
#40 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#41 0xaf2ee060 in KWin::CubeEffect::paintScreen (this=0x8591d78, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/cube/cube.cpp:697
#42 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#43 0xb6e102ca in KWin::Effect::paintScreen (this=0x8571a20, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#44 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#45 0xaf2f8de7 in KWin::CubeSlideEffect::paintScreen (this=0x8534c30, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/cube/cubeslide.cpp:111
#46 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#47 0xb6e102ca in KWin::Effect::paintScreen (this=0x8599228, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#48 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#49 0xb6e102ca in KWin::Effect::paintScreen (this=0x8573b48, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#50 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#51 0xaf2e6daa in KWin::CoverSwitchEffect::paintScreen (this=0x8594dc8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/coverswitch/coverswitch.cpp:124
#52 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#53 0xb6e102ca in KWin::Effect::paintScreen (this=0x852bd40, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#54 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#55 0xb6e102ca in KWin::Effect::paintScreen (this=0x854eae8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#56 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#57 0xaf30a9e9 in KWin::MouseMarkEffect::paintScreen (this=0x852b530, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/mousemark/mousemark.cpp:78
#58 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#59 0xb6e102ca in KWin::Effect::paintScreen (this=0x8563a78, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#60 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#61 0xaf2ded3a in KWin::ZoomEffect::paintScreen (this=0x858bd18, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/zoom/zoom.cpp:73
#62 0xb7797ddf in KWin::EffectsHandlerImpl::paintScreen (this=0x84eb418, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#63 0xb77937c1 in KWin::Scene::paintScreen (this=0x8181a00, mask=0xbfbab9e4, region=0xbfbabaa4) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene.cpp:137
#64 0xb77a7c7a in KWin::SceneOpenGL::paint (this=0x8181a00, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene_opengl.cpp:755
#65 0xb77ad204 in KWin::Workspace::performCompositing (this=0xb003b640) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/composite.cpp:454
#66 0xb77deb5b in KWin::Workspace::qt_metacall (this=0xb003b640, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfbabbbc)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/kwin/workspace.moc:583
#67 0xb67e0efd in QMetaObject::metacall (object=0xb003b640, cl=QMetaObject::InvokeMetaMethod, idx=190, argv=0xbfbabbbc) at kernel/qmetaobject.cpp:237
#68 0xb67effe8 in QMetaObject::activate (sender=0xb003b8f0, m=0xb68f75a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3295
#69 0xb683ca35 in QTimer::timeout (this=0xb003b8f0) at .moc/release-shared/moc_qtimer.cpp:134
#70 0xb67f58e6 in QTimer::timerEvent (this=0xb003b8f0, e=0xbfbac110) at kernel/qtimer.cpp:271
#71 0xb67ed774 in QObject::event (this=0xb003b8f0, e=0xbfbac110) at kernel/qobject.cpp:1212
#72 0xb5d14c64 in QApplicationPrivate::notify_helper (this=0x80709a8, receiver=0xb003b8f0, e=0xbfbac110) at kernel/qapplication.cpp:4302
#73 0xb5d1cbf7 in QApplication::notify (this=0xbfbac444, receiver=0xb003b8f0, e=0xbfbac110) at kernel/qapplication.cpp:3706
#74 0xb72e0941 in KApplication::notify (this=0xbfbac444, receiver=0xb003b8f0, event=0xbfbac110) at /usr/src/debug/kdelibs-4.5.3/kdeui/kernel/kapplication.cpp:310
#75 0xb773ebff in KWin::Application::notify (this=0xbfbac444, o=0xb003b8f0, e=0xbfbac110) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/main.cpp:372
#76 0xb67dae0e in QCoreApplication::notifyInternal (this=0xbfbac444, receiver=0xb003b8f0, event=0xbfbac110) at kernel/qcoreapplication.cpp:726
#77 0xb680970e in sendEvent (this=0x8071120) at kernel/qcoreapplication.h:215
#78 QTimerInfoList::activateTimers (this=0x8071120) at kernel/qeventdispatcher_unix.cpp:618
#79 0xb6809ffd in QEventDispatcherUNIX::processEvents (this=0x8054b08, flags=...) at kernel/qeventdispatcher_unix.cpp:939
#80 0xb5dc5f5a in QEventDispatcherX11::processEvents (this=0x8054b08, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#81 0xb67da11d in QEventLoop::processEvents (this=0xbfbac394, flags=...) at kernel/qeventloop.cpp:149
#82 0xb67da319 in QEventLoop::exec (this=0xbfbac394, flags=...) at kernel/qeventloop.cpp:201
#83 0xb67dec70 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#84 0xb5d12164 in QApplication::exec () at kernel/qapplication.cpp:3581
#85 0xb77d797b in kdemain (argc=3, argv=0xbfbac694) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/main.cpp:531
#86 0x0804860b in main (argc=3, argv=0xbfbac694) at /usr/src/debug/kdebase-workspace-4.5.3/build/kwin/kwin_dummy.cpp:3

Possible duplicates by query: bug 252824, bug 252817.

Reported using DrKonqi
Comment 1 Thomas Lübking 2010-11-05 15:58:00 UTC
known bug in the intel driver, sorry - cannot be fixed in kwin.

*** This bug has been marked as a duplicate of bug 252817 ***