Bug 257115 - Kwin crashes after OpenGl Screensaver
Summary: Kwin crashes after OpenGl Screensaver
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-17 03:17 UTC by Tobias Peters
Modified: 2011-05-08 02:02 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (14.54 KB, text/plain)
2011-03-16 07:36 UTC, Johannes Engel
Details
New crash information added by DrKonqi (9.89 KB, text/plain)
2011-03-22 00:48 UTC, linuxg33k4life
Details
New crash information added by DrKonqi (11.87 KB, text/plain)
2011-05-08 02:02 UTC, Guillermo Martinez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Peters 2010-11-17 03:17:42 UTC
Application: kwin (4.5.3 (KDE 4.5.3))
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.1
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
I started the screensaver by waiting or pressing the test button at the system configuration. After quitting the screensaver by clicking the left mouse button, kwin crashes.

- Unusual behavior I noticed:
Kwin crashes not everytime, but more than every second time. In the case that it does not crash, the screensaver works and quits as it should.

- Custom settings of the application:
The crash occurs only with OpenGl screensaver. All OpenGl Screensaver I tested have this problem, for example KCometen4, Matrix, Planet, Fliptext, antmaze, etc

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#7  intel_region_buffer (intel=0x8213c80, region=0x0, flag=2) at intel_regions.c:498
#8  0xaff52372 in intelClearWithBlit (ctx=0x8213c80, mask=2) at intel_blit.c:266
#9  0xaff4a268 in intelClear (ctx=0x8213c80, mask=2) at intel_clear.c:173
#10 0xaff90e56 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:178
#11 0xb76d72cb in KWin::SceneOpenGL::paintBackground (this=0x814a7f8, region=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene_opengl.cpp:899
#12 0xb7753324 in KWin::Scene::paintGenericScreen (this=0x814a7f8, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene.cpp:187
#13 0xb770b3c0 in KWin::Scene::finalPaintScreen (this=0x814a7f8, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene.cpp:177
#14 0xb773db73 in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:172
#15 0xaf80dee2 in KWin::LogoutEffect::paintScreen (this=0x8186f98, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/logout/logout.cpp:207
#16 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#17 0xaf83aa11 in KWin::BlurEffect::paintScreen (this=0x812cb38, mask=40, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/blur/blur.cpp:235
#18 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#19 0xaf812ec4 in KWin::PresentWindowsEffect::paintScreen (this=0x81620f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/presentwindows/presentwindows.cpp:196
#20 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#21 0xb6da035a in KWin::Effect::paintScreen (this=0x8138d20, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#22 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#23 0xb6da035a in KWin::Effect::paintScreen (this=0x8134188, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#24 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#25 0xb6da035a in KWin::Effect::paintScreen (this=0x8178818, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#26 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#27 0xb6da035a in KWin::Effect::paintScreen (this=0x81a4128, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#28 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#29 0xaf7f81c6 in KWin::DesktopGridEffect::paintScreen (this=0x816dad8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/desktopgrid/desktopgrid.cpp:155
#30 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#31 0xaf853c97 in KWin::CubeSlideEffect::paintScreen (this=0x8185000, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/cube/cubeslide.cpp:111
#32 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#33 0xb6da035a in KWin::Effect::paintScreen (this=0x8161df8, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#34 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#35 0xaf84239a in KWin::CoverSwitchEffect::paintScreen (this=0x8134068, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/coverswitch/coverswitch.cpp:124
#36 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#37 0xb6da035a in KWin::Effect::paintScreen (this=0x8160238, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/lib/kwineffects.cpp:227
#38 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#39 0xaf83a2ba in KWin::ZoomEffect::paintScreen (this=0x865d278, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects/zoom/zoom.cpp:73
#40 0xb773dbef in KWin::EffectsHandlerImpl::paintScreen (this=0x81641f0, mask=8, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/effects.cpp:168
#41 0xb77375b1 in KWin::Scene::paintScreen (this=0x814a7f8, mask=0xbf9fd704, region=0xbf9fd7c4) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene.cpp:137
#42 0xb7776d2a in KWin::SceneOpenGL::paint (this=0x814a7f8, damage=..., toplevels=...) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/scene_opengl.cpp:755
#43 0xb774efd4 in KWin::Workspace::performCompositing (this=0x814cf40) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/composite.cpp:454
#44 0xb778060b in KWin::Workspace::qt_metacall (this=0x814cf40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbf9fd8dc)
    at /usr/src/debug/kdebase-workspace-4.5.3/build/kwin/workspace.moc:583
#45 0xb6744dad in QMetaObject::metacall (object=0x814cf40, cl=QMetaObject::InvokeMetaMethod, idx=190, argv=0xbf9fd8dc) at kernel/qmetaobject.cpp:237
#46 0xb6754f4c in QMetaObject::activate (sender=0x814d1f0, m=0xb68785a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3272
#47 0xb67a4365 in QTimer::timeout (this=0x814d1f0) at .moc/release-shared/moc_qtimer.cpp:134
#48 0xb675b536 in QTimer::timerEvent (this=0x814d1f0, e=0xbf9fde2c) at kernel/qtimer.cpp:271
#49 0xb6753914 in QObject::event (this=0x814d1f0, e=0xbf9fde2c) at kernel/qobject.cpp:1175
#50 0xb5c3b414 in QApplicationPrivate::notify_helper (this=0x806d730, receiver=0x814d1f0, e=0xbf9fde2c) at kernel/qapplication.cpp:4445
#51 0xb5c44137 in QApplication::notify (this=0xbf9fe144, receiver=0x814d1f0, e=0xbf9fde2c) at kernel/qapplication.cpp:3845
#52 0xb72809a1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#53 0xb76e8c3f in KWin::Application::notify (this=0xbf9fe144, o=0x814d1f0, e=0xbf9fde2c) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/main.cpp:372
#54 0xb673e50e in QCoreApplication::notifyInternal (this=0xbf9fe144, receiver=0x814d1f0, event=0xbf9fde2c) at kernel/qcoreapplication.cpp:732
#55 0xb676f8e8 in sendEvent (this=0x806deb8) at kernel/qcoreapplication.h:215
#56 QTimerInfoList::activateTimers (this=0x806deb8) at kernel/qeventdispatcher_unix.cpp:618
#57 0xb677004d in QEventDispatcherUNIX::processEvents (this=0x8052b98, flags=...) at kernel/qeventdispatcher_unix.cpp:937
#58 0xb5cf2a9a in QEventDispatcherX11::processEvents (this=0x8052b98, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#59 0xb673d7ed in QEventLoop::processEvents (this=0xbf9fe094, flags=...) at kernel/qeventloop.cpp:149
#60 0xb673da19 in QEventLoop::exec (this=0xbf9fe094, flags=...) at kernel/qeventloop.cpp:201
#61 0xb67424c0 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#62 0xb5c39114 in QApplication::exec () at kernel/qapplication.cpp:3719
#63 0xb7788b4b in kdemain (argc=3, argv=0xbf9fe394) at /usr/src/debug/kdebase-workspace-4.5.3/kwin/main.cpp:531
#64 0x0804860b in main (argc=3, argv=0xbf9fe394) at /usr/src/debug/kdebase-workspace-4.5.3/build/kwin/kwin_dummy.cpp:3

Possible duplicates by query: bug 256128, bug 252824, bug 252817.

Reported using DrKonqi
Comment 1 Thomas Lübking 2010-11-17 15:12:04 UTC

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 Johannes Engel 2011-03-16 07:36:18 UTC
Created attachment 58074 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0) "release 6") on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed:
After using OpenGL screensaver KWin crashes (4.6.0)

- Custom settings of the application:
Desktop effects turned on, screensaver using OpenGL

-- Backtrace (Reduced):
#6  intel_region_buffer (intel=0x738ba0, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f5c2f39b2d4 in intelClearWithBlit (ctx=0x738ba0, mask=2) at intel_blit.c:262
#8  0x00007f5c2f39d7da in intelClear (ctx=0x738ba0, mask=2) at intel_clear.c:177
#9  0x00007f5c4756b625 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#10 0x00007f5c47562d96 in KWin::Scene::paintGenericScreen (this=0x6c3a40, orig_mask=32) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
Comment 3 linuxg33k4life 2011-03-22 00:48:10 UTC
Created attachment 58235 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0) "release 6") on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed:
Kwin crashed after logging into KDE from the flux (gl) screen saver.

-- Backtrace (Reduced):
#6  intel_region_buffer (intel=0x761120, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007fbca5c692d4 in intelClearWithBlit (ctx=0x761120, mask=2) at intel_blit.c:262
#8  0x00007fbca5c6b7da in intelClear (ctx=0x761120, mask=2) at intel_clear.c:177
#9  0x00007fbcbdc85625 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921
#10 0x00007fbcbdc7cd96 in KWin::Scene::paintGenericScreen (this=0x72c1a0, orig_mask=40) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene.cpp:188
Comment 4 Guillermo Martinez 2011-05-08 02:02:30 UTC
Created attachment 59754 [details]
New crash information added by DrKonqi

kwin (4.6.2 (4.6.2)) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

I started Kubuntu 11.04 as usual and the screen saver started after some minutes of doing nothing. I configured the screen saver in such way that I must log in, then I wrote my password as always and an error window appear showing me about Kwin crash. This crash has happened to me several times. Sometimes I used Kalarm and when an alarm starts Kwin crash. This only two thing I have noticed makes Kwin crash.

-- Backtrace (Reduced):
#6  intel_region_buffer (intel=0xfec6a0, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f53f7b616c2 in intelClearWithBlit (ctx=0xfec6a0, mask=2) at intel_blit.c:262
#8  0x00007f53f7b63d2a in intelClear (ctx=0xfec6a0, mask=2) at intel_clear.c:177
#9  0x00007f5410282ce7 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:921
#10 0x00007f541027a88f in KWin::Scene::paintGenericScreen (this=0xfeae10, orig_mask=32) at ../../kwin/scene.cpp:188