Bug 266642 - Bookmark Edit crashes when drag/drop bookmarks to a different folder.
Summary: Bookmark Edit crashes when drag/drop bookmarks to a different folder.
Status: RESOLVED DUPLICATE of bug 226187
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-19 05:20 UTC by Jon Wooten
Modified: 2011-02-19 23:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (13.12 KB, text/plain)
2011-02-19 05:25 UTC, Jon Wooten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Wooten 2011-02-19 05:20:05 UTC
Application: keditbookmarks (4.4.5 (KDE 4.4.5))
KDE Platform Version: 4.4.5 (KDE 4.4.5) (Compiled from sources)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-28-generic i686
Distribution: Ubuntu 10.04.2 LTS

-- Information about the crash:
I selected multiple bookmarks (maybe 12) to move from one folder to a different existing folder, dragged them over the target folder and upon release the Edit Bookmark app crashed.

 -- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78d29f0 (LWP 3675))]

Thread 2 (Thread 0xb5407b70 (LWP 3676)):
#0  0x063ce79f in g_main_context_check () from /lib/libglib-2.0.so.0
#1  0x063cf0ce in ?? () from /lib/libglib-2.0.so.0
#2  0x063cf4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x04db660f in QEventDispatcherGlib::processEvents (this=0xa201d00, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#4  0x04d89059 in QEventLoop::processEvents (this=0xb5407290, flags=) at kernel/qeventloop.cpp:149
#5  0x04d894aa in QEventLoop::exec (this=0xb5407290, flags=...) at kernel/qeventloop.cpp:201
#6  0x04c855a8 in QThread::exec (this=0xa1fe7e8) at thread/qthread.cpp:487
#7  0x04d68c1b in QInotifyFileSystemWatcherEngine::run (this=0xa1fe7e8) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x04c8832e in QThreadPrivate::start (arg=0xa1fe7e8) at thread/qthread_unix.cpp:248
#9  0x0044196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x00223a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb78d29f0 (LWP 3675)):
[KCrash Handler]
#6  0x00522d49 in QDomNode (this=0xbf9f9e6c, n=...) at dom/qdom.cpp:2033
#7  0x00524294 in QDomElement (this=0xbf9f9e6c, x=...) at dom/qdom.cpp:4732
#8  0x0014a2dc in KBookmark (this=0x0) at /usr/include/kbookmark.h:34
#9  TreeItem::bookmark (this=0x0) at ../../../apps/keditbookmarks/treeitem.cpp:88
#10 0x001461c0 in KBookmarkModel::bookmarkForIndex (this=0xa058c50, index=...) at ../../../apps/keditbookmarks/bookmarkmodel.cpp:381
#11 0x001477f9 in KBookmarkModel::parent (this=0xa058c50, index=...) at ../../../apps/keditbookmarks/bookmarkmodel.cpp:225
#12 0x018c82f1 in QModelIndex::parent (this=0xa195110, source_parent=...) at ../../include/QtCore/../../src/corelib/kernel/qabstractitemmodel.h:389
#13 QSortFilterProxyModelPrivate::can_create_mapping (this=0xa195110, source_parent=...) at itemviews/qsortfilterproxymodel.cpp:362
#14 0x018c848e in QSortFilterProxyModelPrivate::_q_sourceRowsAboutToBeInserted (this=0xa195110, source_parent=..., start=7, end=7) at itemviews/qsortfilterproxymodel.cpp:1235
#15 0x018ced8f in QSortFilterProxyModel::qt_metacall (this=0xa194bd8, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbf9fa050) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:134
#16 0x001485e2 in BookmarkFolderViewFilterModel::qt_metacall (this=0xa194bd8, _c=QMetaObject::InvokeMetaMethod, _id=36, _a=0xbf9fa050) at ./bookmarklistview.moc:234
#17 0x04d8fc9a in QMetaObject::metacall (object=0xa194bd8, cl=168135760, idx=36, argv=0xbf9fa050) at kernel/qmetaobject.cpp:237
#18 0x04d9e3d5 in QMetaObject::activate (sender=0xa058c50, m=0x4e9e198, local_signal_index=4, argv=0xbf9fa050) at kernel/qobject.cpp:3293
#19 0x04deecef in QAbstractItemModel::rowsAboutToBeInserted (this=0xa058c50, _t1=..., _t2=7, _t3=7) at .moc/release-shared/moc_qabstractitemmodel.cpp:174
#20 0x04d82795 in QAbstractItemModel::beginInsertRows (this=0xa058c50, parent=..., first=7, last=7) at kernel/qabstractitemmodel.cpp:2393
#21 0x0013322c in KBookmarkModelInsertSentry (this=0xada3eb8) at ../../../apps/keditbookmarks/commands.cpp:43
#22 CreateCommand::redo (this=0xada3eb8) at ../../../apps/keditbookmarks/commands.cpp:162
#23 0x0013282c in MoveCommand::redo (this=0xad6e0f0) at ../../../apps/keditbookmarks/commands.cpp:413
#24 0x019a0d03 in QUndoCommand::redo (this=0xad3e7d8) at util/qundostack.cpp:208
#25 0x019a26f5 in QUndoStack::push (this=0xa0020e0, cmd=0xad3e7d8) at util/qundostack.cpp:541
#26 0x0012b053 in CmdHistory::addCommand (this=0xa0020d8, cmd=0xad3e7d8) at ../../../apps/keditbookmarks/commandhistory.cpp:88
#27 0x001472b3 in KBookmarkModel::dropMimeData (this=0xa058c50, data=0xa291090, action=Qt::MoveAction, row=-1, column=-1, parent=...) at ../../../apps/keditbookmarks/bookmarkmodel.cpp:360
#28 0x001484f0 in BookmarkFolderViewFilterModel::dropMimeData (this=0xa194bd8, data=0xa291090, action=Qt::MoveAction, row=-1, column=-1, parent=...)
    at ../../../apps/keditbookmarks/bookmarklistview.cpp:241
#29 0x0182fdc3 in QAbstractItemView::dropEvent (this=0xa191750, event=0xbf9facd0) at itemviews/qabstractitemview.cpp:1969
#30 0x012f17c0 in QWidget::event (this=0xa191750, event=0xbf9facd0) at kernel/qwidget.cpp:8188
#31 0x016edfd3 in QFrame::event (this=0xa191750, e=0xbf9facd0) at widgets/qframe.cpp:557
#32 0x01788382 in QAbstractScrollArea::viewportEvent (this=0xa058c50, e=0xbf9f9e6c) at widgets/qabstractscrollarea.cpp:1036
#33 0x0183cbd7 in QAbstractItemView::viewportEvent (this=0xa191750, event=0xbf9facd0) at itemviews/qabstractitemview.cpp:1610
#34 0x0187df7c in QTreeView::viewportEvent (this=0xa191750, event=0xbf9facd0) at itemviews/qtreeview.cpp:1248
#35 0x0178ac65 in QAbstractScrollAreaPrivate::viewportEvent (this=0xa18cc90, o=0xa191598, e=0xbf9facd0) at widgets/qabstractscrollarea_p.h:100
#36 QAbstractScrollAreaFilter::eventFilter (this=0xa18cc90, o=0xa191598, e=0xbf9facd0) at widgets/qabstractscrollarea_p.h:116
#37 0x04d89cda in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9f67a88, receiver=0xa191598, event=0xbf9facd0) at kernel/qcoreapplication.cpp:819
#38 0x012934b9 in QApplicationPrivate::notify_helper (this=0x9f67a88, receiver=0xa191598, e=0xbf9facd0) at kernel/qapplication.cpp:4296
#39 0x0129a53d in QApplication::notify (this=0xbf9fd094, receiver=0xa191598, e=0xbf9facd0) at kernel/qapplication.cpp:4108
#40 0x00d2a40a in KApplication::notify (this=0xbf9fd094, receiver=0xa191598, event=0xbf9facd0) at ../../kdeui/kernel/kapplication.cpp:302
#41 0x04d8aa3b in QCoreApplication::notifyInternal (this=0xbf9fd094, receiver=0xa191598, event=0xbf9facd0) at kernel/qcoreapplication.cpp:704
#42 0x01333d35 in QCoreApplication::sendEvent (this=0x9f6b4e0, xe=0xbf9fadcc, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#43 QX11Data::xdndHandleDrop (this=0x9f6b4e0, xe=0xbf9fadcc, passive=false) at kernel/qdnd_x11.cpp:1168
#44 0x01334046 in QDragManager::drop (this=0xad964a0) at kernel/qdnd_x11.cpp:1724
#45 0x013362fa in QDragManager::eventFilter (this=0xad964a0, o=0xa290d08, e=0xbf9fb320) at kernel/qdnd_x11.cpp:1297
#46 0x04d89d9c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x9f67a88, receiver=0xa290d08, event=0xbf9fb320) at kernel/qcoreapplication.cpp:800
#47 0x01293463 in QApplicationPrivate::notify_helper (this=0x9f67a88, receiver=0xa290d08, e=0xbf9fb320) at kernel/qapplication.cpp:4275
#48 0x0129a9f7 in QApplication::notify (this=0xbf9fd094, receiver=0xa290d08, e=0xbf9fb320) at kernel/qapplication.cpp:3865
#49 0x00d2a40a in KApplication::notify (this=0xbf9fd094, receiver=0xa290d08, event=0xbf9fb320) at ../../kdeui/kernel/kapplication.cpp:302
#50 0x04d8aa3b in QCoreApplication::notifyInternal (this=0xbf9fd094, receiver=0xa290d08, event=0xbf9fb320) at kernel/qcoreapplication.cpp:704
#51 0x01299952 in QCoreApplication::sendEvent (receiver=0xa290d08, event=0xbf9fb320, alienWidget=0x0, nativeWidget=0xa290d08, buttonDown=0x1bd7058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QApplicationPrivate::sendMouseEvent (receiver=0xa290d08, event=0xbf9fb320, alienWidget=0x0, nativeWidget=0xa290d08, buttonDown=0x1bd7058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#53 0x01325088 in QETWidget::translateMouseEvent (this=0xa290d08, event=0xbf9fb83c) at kernel/qapplication_x11.cpp:4368
#54 0x01324511 in QApplication::x11ProcessEvent (this=0xbf9fd094, event=0xbf9fb83c) at kernel/qapplication_x11.cpp:3379
#55 0x0135360a in x11EventSourceDispatch (s=0x9f6aa40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#56 0x063cb5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#57 0x063cf2d8 in ?? () from /lib/libglib-2.0.so.0
#58 0x063cf4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#59 0x04db65d5 in QEventDispatcherGlib::processEvents (this=0x9f52b60, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#60 0x01353135 in QGuiEventDispatcherGlib::processEvents (this=0x9f52b60, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x04d89059 in QEventLoop::processEvents (this=0xa28a380, flags=) at kernel/qeventloop.cpp:149
#62 0x04d894aa in QEventLoop::exec (this=0xa28a380, flags=...) at kernel/qeventloop.cpp:201
#63 0x0133947d in QDragManager::drag (this=0xad964a0, o=0xa2880b8) at kernel/qdnd_x11.cpp:1984
#64 0x012ab99e in QDrag::exec (this=0xa2880b8, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:282
#65 0x0183a83c in QAbstractItemView::startDrag (this=0xa059120, supportedActions=...) at itemviews/qabstractitemview.cpp:3382
#66 0x018380fa in QAbstractItemView::mouseMoveEvent (this=0xa059120, event=0xbf9fc6b0) at itemviews/qabstractitemview.cpp:1691
#67 0x0187de14 in QTreeView::mouseMoveEvent (this=0xa059120, event=0xbf9fc6b0) at itemviews/qtreeview.cpp:1894
#68 0x012f169a in QWidget::event (this=0xa059120, event=0xbf9fc6b0) at kernel/qwidget.cpp:7983
#69 0x016edfd3 in QFrame::event (this=0xa059120, e=0xbf9fc6b0) at widgets/qframe.cpp:557
#70 0x01788382 in QAbstractScrollArea::viewportEvent (this=0xa058c50, e=0xbf9f9e6c) at widgets/qabstractscrollarea.cpp:1036
#71 0x0183cbd7 in QAbstractItemView::viewportEvent (this=0xa059120, event=0xbf9fc6b0) at itemviews/qabstractitemview.cpp:1610
#72 0x0187df7c in QTreeView::viewportEvent (this=0xa059120, event=0xbf9fc6b0) at itemviews/qtreeview.cpp:1248
#73 0x0178ac65 in QAbstractScrollAreaPrivate::viewportEvent (this=0xa188758, o=0xa059e40, e=0xbf9fc6b0) at widgets/qabstractscrollarea_p.h:100
#74 QAbstractScrollAreaFilter::eventFilter (this=0xa188758, o=0xa059e40, e=0xbf9fc6b0) at widgets/qabstractscrollarea_p.h:116
#75 0x04d89cda in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9f67a88, receiver=0xa059e40, event=0xbf9fc6b0) at kernel/qcoreapplication.cpp:819
#76 0x012934b9 in QApplicationPrivate::notify_helper (this=0x9f67a88, receiver=0xa059e40, e=0xbf9fc6b0) at kernel/qapplication.cpp:4296
#77 0x0129a9f7 in QApplication::notify (this=0xbf9fd094, receiver=0xa059e40, e=0xbf9fc6b0) at kernel/qapplication.cpp:3865
#78 0x00d2a40a in KApplication::notify (this=0xbf9fd094, receiver=0xa059e40, event=0xbf9fc6b0) at ../../kdeui/kernel/kapplication.cpp:302
#79 0x04d8aa3b in QCoreApplication::notifyInternal (this=0xbf9fd094, receiver=0xa059e40, event=0xbf9fc6b0) at kernel/qcoreapplication.cpp:704
#80 0x01299952 in QCoreApplication::sendEvent (receiver=0xa059e40, event=0xbf9fc6b0, alienWidget=0xa059e40, nativeWidget=0x9ffc540, buttonDown=0x1bd7058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#81 QApplicationPrivate::sendMouseEvent (receiver=0xa059e40, event=0xbf9fc6b0, alienWidget=0xa059e40, nativeWidget=0x9ffc540, buttonDown=0x1bd7058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2965
#82 0x01325088 in QETWidget::translateMouseEvent (this=0x9ffc540, event=0xbf9fcbcc) at kernel/qapplication_x11.cpp:4368
#83 0x01324511 in QApplication::x11ProcessEvent (this=0xbf9fd094, event=0xbf9fcbcc) at kernel/qapplication_x11.cpp:3379
#84 0x0135360a in x11EventSourceDispatch (s=0x9f6aa40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#85 0x063cb5e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#86 0x063cf2d8 in ?? () from /lib/libglib-2.0.so.0
#87 0x063cf4b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#88 0x04db65d5 in QEventDispatcherGlib::processEvents (this=0x9f52b60, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#89 0x01353135 in QGuiEventDispatcherGlib::processEvents (this=0x9f52b60, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#90 0x04d89059 in QEventLoop::processEvents (this=0xbf9fcec4, flags=) at kernel/qeventloop.cpp:149
#91 0x04d894aa in QEventLoop::exec (this=0xbf9fcec4, flags=...) at kernel/qeventloop.cpp:201
#92 0x04d8d69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#93 0x01293577 in QApplication::exec () at kernel/qapplication.cpp:3579
#94 0x001259c9 in kdemain (argc=6, argv=0xbf9fd404) at ../../../apps/keditbookmarks/main.cpp:204
#95 0x0804860b in main (argc=6, argv=0xbf9fd404) at keditbookmarks_dummy.cpp:3

This bug may be a duplicate of or related to bug 257557.

Possible duplicates by query: bug 260576, bug 257557, bug 253100.

Reported using DrKonqi
Comment 1 Jon Wooten 2011-02-19 05:25:42 UTC
Created attachment 57367 [details]
New crash information added by DrKonqi

Experimented a little more with this.  I could drag/drop up to 5 bookmarks at a time without EditBookmarks crashing.  Move 6 or more and the app crashes.
Comment 2 Dario Andres 2011-02-19 23:48:02 UTC
[Comment from a bug triager]
This issue is being tracked at bug 226187. Merging. Thanks for the information.

*** This bug has been marked as a duplicate of bug 226187 ***