Bug 260576 - kde crashed after connecting Philips "goGear" SAxx
Summary: kde crashed after connecting Philips "goGear" SAxx
Status: RESOLVED DUPLICATE of bug 254043
Alias: None
Product: kfile
Classification: Unclassified
Component: kfileplacesview (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-17 20:07 UTC by Chantal la Roche
Modified: 2012-01-03 21:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chantal la Roche 2010-12-17 20:07:50 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 3"
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-0.5-desktop i686
Distribution: "openSUSE 11.3 (i586)"

-- Information about the crash:
I had connected Philips "GoGear SAxx" and KDE  crashed

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4e3c710 (LWP 8839))]

Thread 2 (Thread 0xb1666b70 (LWP 8851)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb5622452 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5c572a4 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb2a1b1d7 in metronom_sync_loop () from /usr/lib/libxine.so.1
#4  0xb561db25 in start_thread () from /lib/libpthread.so.0
#5  0xb5c4946e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb4e3c710 (LWP 8839)):
[KCrash Handler]
#6  0xb5ab2ec0 in QDomNode::QDomNode(QDomNode const&) () from /usr/lib/libQtXml.so.4
#7  0xb5ab5123 in QDomElement::QDomElement(QDomElement const&) () from /usr/lib/libQtXml.so.4
#8  0xb7854c8d in KBookmark (this=0x87ea430) at /usr/src/debug/kdelibs-4.4.4/kio/bookmarks/kbookmark.h:34
#9  KFilePlacesItem::bookmark (this=0x87ea430) at /usr/src/debug/kdelibs-4.4.4/kfile/kfileplacesitem.cpp:84
#10 0xb7854ce8 in KFilePlacesItem::isDevice (this=0x87ea430) at /usr/src/debug/kdelibs-4.4.4/kfile/kfileplacesitem.cpp:79
#11 0xb7856ac1 in KFilePlacesModel::deviceForIndex (this=0x83b3478, index=...) at /usr/src/debug/kdelibs-4.4.4/kfile/kfileplacesmodel.cpp:205
#12 0xb7857c7a in KFilePlacesModel::requestTeardown (this=0x83b3478, index=...) at /usr/src/debug/kdelibs-4.4.4/kfile/kfileplacesmodel.cpp:746
#13 0xb7878fb4 in KFilePlacesView::contextMenuEvent (this=0x864f880, event=0xbf96b9ec) at /usr/src/debug/kdelibs-4.4.4/kfile/kfileplacesview.cpp:669
#14 0xb5f81cd4 in QWidget::event (this=0x864f880, event=0xbf96b9ec) at kernel/qwidget.cpp:8211
#15 0xb637a765 in QFrame::event (this=0x864f880, e=0xbf96b9ec) at widgets/qframe.cpp:557
#16 0xb6408e01 in QAbstractScrollArea::viewportEvent (this=0x864f880, e=0xbf96b9ec) at widgets/qabstractscrollarea.cpp:1036
#17 0xb64ab284 in QAbstractItemView::viewportEvent (this=0x864f880, event=0xbf96b9ec) at itemviews/qabstractitemview.cpp:1615
#18 0xb640b776 in viewportEvent (this=0x8464d28, o=0x819e360, e=0xbf96b9ec) at widgets/qabstractscrollarea_p.h:100
#19 QAbstractScrollAreaFilter::eventFilter (this=0x8464d28, o=0x819e360, e=0xbf96b9ec) at widgets/qabstractscrollarea_p.h:116
#20 0xb69d3fa6 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#21 0xb5f27c34 in QApplicationPrivate::notify_helper (this=0x80fb638, receiver=0x819e360, e=0xbf96b9ec) at kernel/qapplication.cpp:4298
#22 0xb5f2ffa8 in QApplication::notify (this=0x819e360, receiver=0x819e360, e=0xbf96b9ec) at kernel/qapplication.cpp:3946
#23 0xb6eeb9d1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#24 0xb69d3e0e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#25 0xb5fb0609 in sendSpontaneousEvent (this=0x8169b78, event=0xbf96bedc) at ../../src/corelib/kernel/qcoreapplication.h:218
#26 QETWidget::translateMouseEvent (this=0x8169b78, event=0xbf96bedc) at kernel/qapplication_x11.cpp:4385
#27 0xb5faf73e in QApplication::x11ProcessEvent (this=0xbf96c234, event=0xbf96bedc) at kernel/qapplication_x11.cpp:3391
#28 0xb5fd8570 in x11EventSourceDispatch (s=0x80f4f10, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#29 0xb544bb49 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0xb544c350 in ?? () from /usr/lib/libglib-2.0.so.0
#31 0xb544c60e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0xb69ffd4b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0xb5fd819a in QGuiEventDispatcherGlib::processEvents (this=0x80d4600, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0xb69d311d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#35 0xb69d3319 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0xb69d7c70 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#37 0xb5f25164 in QApplication::exec () at kernel/qapplication.cpp:3581
#38 0x080785b5 in main (argc=) at /usr/src/debug/kdebase-4.4.4/apps/dolphin/src/main.cpp:101

Reported using DrKonqi
Comment 1 Christoph Feck 2012-01-03 21:16:48 UTC

*** This bug has been marked as a duplicate of bug 254043 ***