Bug 253100 - crasche after modification of bookmarks.
Summary: crasche after modification of bookmarks.
Status: RESOLVED DUPLICATE of bug 226187
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-03 10:16 UTC by Usul
Modified: 2010-10-19 03:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Usul 2010-10-03 10:16:54 UTC
Application: keditbookmarks (4.5.1 (KDE 4.5.1))
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic i686
Distribution: Ubuntu maverick (development branch)

-- Information about the crash:
- Custom settings of the application:

The window has crasché when I wanted to erase bookmarks.

-- Backtrace:
Application: Éditeur de signet (keditbookmarks), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76e2a50 (LWP 3335))]

Thread 2 (Thread 0xb4564b70 (LWP 3336)):
#0  0x0454ae36 in clock_gettime () from /lib/librt.so.1
#1  0x082d150b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x083a86e5 in QTimerInfoList::updateCurrentTime (this=0x8cb853c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x083a872a in QTimerInfoList::timerWait (this=0x8cb853c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x083a67a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb45640bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x083a683d in timerSourcePrepare (source=0x0, timeout=0x454eff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x02588e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x02589279 in ?? () from /lib/libglib-2.0.so.0
#9  0x02589848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x083a659f in QEventDispatcherGlib::processEvents (this=0x8dd2ca0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x08376609 in QEventLoop::processEvents (this=0xb4564290, flags=) at kernel/qeventloop.cpp:149
#12 0x08376a8a in QEventLoop::exec (this=0xb4564290, flags=...) at kernel/qeventloop.cpp:201
#13 0x08272b7e in QThread::exec (this=0x8d9fee0) at thread/qthread.cpp:490
#14 0x0835535b in QInotifyFileSystemWatcherEngine::run (this=0x8d9fee0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x08275df9 in QThreadPrivate::start (arg=0x8d9fee0) at thread/qthread_unix.cpp:266
#16 0x005fecc9 in start_thread () from /lib/libpthread.so.0
#17 0x001e06ae in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb76e2a50 (LWP 3335)):
[KCrash Handler]
#7  0x008de449 in QDomNode::QDomNode (this=0xbfc7853c, n=...) at dom/qdom.cpp:2038
#8  0x008df994 in QDomElement::QDomElement (this=0xbfc7853c, x=...) at dom/qdom.cpp:4738
#9  0x0027e29c in KBookmark (this=0x0) at //usr/include/kbookmark.h:35
#10 TreeItem::bookmark (this=0x0) at ../../../../apps/keditbookmarks/kbookmarkmodel/treeitem.cpp:87
#11 0x0027b8c0 in KBookmarkModel::bookmarkForIndex (this=0x8af77d0, index=...) at ../../../../apps/keditbookmarks/kbookmarkmodel/model.cpp:391
#12 0x0027dc19 in KBookmarkModel::parent (this=0x8af77d0, index=...) at ../../../../apps/keditbookmarks/kbookmarkmodel/model.cpp:258
#13 0x00f1988f in parent (this=0x8e1b958, index=) at /usr/include/qt4/QtCore/qabstractitemmodel.h:389
#14 KViewSearchLine::setVisible (this=0x8e1b958, index=) at ../../../apps/keditbookmarks/kebsearchline.cpp:589
#15 0x00f1a09a in KViewSearchLine::slotRowsInserted (this=0x8e1b958, parent=..., first=5, last=5) at ../../../apps/keditbookmarks/kebsearchline.cpp:564
#16 0x00f1bd4f in KViewSearchLine::qt_metacall (this=0x8e1b958, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfc78790) at ./kebsearchline.moc:111
#17 0x0837d8ca in QMetaObject::metacall (object=0x8e1b958, cl=145717200, idx=86, argv=0xbfc78790) at kernel/qmetaobject.cpp:237
#18 0x083906ad in QMetaObject::activate (sender=0x8af77d0, m=0x84aa198, local_signal_index=5, argv=0x8) at kernel/qobject.cpp:3280
#19 0x083e13bf in QAbstractItemModel::rowsInserted (this=0x8af77d0, _t1=..., _t2=5, _t3=5) at .moc/release-shared/moc_qabstractitemmodel.cpp:181
#20 0x08370bf3 in QAbstractItemModel::endInsertRows (this=0x8af77d0) at kernel/qabstractitemmodel.cpp:2413
#21 0x0027b868 in KBookmarkModel::endInsert (this=0x8af77d0) at ../../../../apps/keditbookmarks/kbookmarkmodel/model.cpp:408
#22 0x00278467 in CreateCommand::redo (this=0x91f2ce8) at ../../../../apps/keditbookmarks/kbookmarkmodel/commands.cpp:142
#23 0x00277bbb in MoveCommand::redo (this=0x8bbf3e0) at ../../../../apps/keditbookmarks/kbookmarkmodel/commands.cpp:369
#24 0x01799b93 in QUndoCommand::redo (this=0x9090688) at util/qundostack.cpp:208
#25 0x0179b605 in QUndoStack::push (this=0x8af4044, cmd=0x9090688) at util/qundostack.cpp:541
#26 0x00276736 in CommandHistory::addCommand (this=0x8af3fa0, cmd=0x9090688) at ../../../../apps/keditbookmarks/kbookmarkmodel/commandhistory.cpp:103
#27 0x0027cfd8 in KBookmarkModel::dropMimeData (this=0x8af77d0, data=0x8cbefc8, action=Qt::MoveAction, row=-1, column=-1, parent=...) at ../../../../apps/keditbookmarks/kbookmarkmodel/model.cpp:375
#28 0x00f1c370 in BookmarkFolderViewFilterModel::dropMimeData (this=0x8cc99a8, data=0x8cbefc8, action=Qt::MoveAction, row=-1, column=-1, parent=...) at ../../../apps/keditbookmarks/bookmarklistview.cpp:187
#29 0x0161fcc3 in QAbstractItemView::dropEvent (this=0x8cc2750, event=0xbfc79480) at itemviews/qabstractitemview.cpp:1981
#30 0x010b1dd0 in QWidget::event (this=0x8cc2750, event=0xbfc79480) at kernel/qwidget.cpp:8377
#31 0x014d3763 in QFrame::event (this=0x8cc2750, e=0xbfc79480) at widgets/qframe.cpp:557
#32 0x01570a82 in QAbstractScrollArea::viewportEvent (this=0x8af77d0, e=0xbfc7853c) at widgets/qabstractscrollarea.cpp:1043
#33 0x0162d0f7 in QAbstractItemView::viewportEvent (this=0x8cc2750, event=0xbfc79480) at itemviews/qabstractitemview.cpp:1619
#34 0x0166f883 in QTreeView::viewportEvent (this=0x8cc2750, event=0xbfc79480) at itemviews/qtreeview.cpp:1256
#35 0x015734d5 in viewportEvent (this=0x8cc4638, o=0x8cc0ee0, e=0xbfc79480) at widgets/qabstractscrollarea_p.h:100
#36 QAbstractScrollAreaFilter::eventFilter (this=0x8cc4638, o=0x8cc0ee0, e=0xbfc79480) at widgets/qabstractscrollarea_p.h:116
#37 0x0837729a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8a43598, receiver=0x8cc0ee0, event=0xbfc79480) at kernel/qcoreapplication.cpp:847
#38 0x01053fb9 in QApplicationPrivate::notify_helper (this=0x8a43598, receiver=0x8cc0ee0, e=0xbfc79480) at kernel/qapplication.cpp:4392
#39 0x0105a51f in QApplication::notify (this=0xbfc7b86c, receiver=0x8cc0ee0, e=0xbfc79480) at kernel/qapplication.cpp:4202
#40 0x00ca568a in KApplication::notify (this=0xbfc7b86c, receiver=0x8cc0ee0, event=0xbfc79480) at ../../kdeui/kernel/kapplication.cpp:310
#41 0x08377b3b in QCoreApplication::notifyInternal (this=0xbfc7b86c, receiver=0x8cc0ee0, event=0xbfc79480) at kernel/qcoreapplication.cpp:732
#42 0x010f5daa in sendEvent (this=0x8a47040, xe=0xbfc7958c, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#43 QX11Data::xdndHandleDrop (this=0x8a47040, xe=0xbfc7958c, passive=false) at kernel/qdnd_x11.cpp:1183
#44 0x010faceb in QDragManager::drop (this=0x8c171c8) at kernel/qdnd_x11.cpp:1725
#45 0x010faeea in QDragManager::eventFilter (this=0x8c171c8, o=0x8b77710, e=0xbfc79af0) at kernel/qdnd_x11.cpp:1312
#46 0x0837735c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x8a43598, receiver=0x8b77710, event=0xbfc79af0) at kernel/qcoreapplication.cpp:828
#47 0x01053f63 in QApplicationPrivate::notify_helper (this=0x8a43598, receiver=0x8b77710, e=0xbfc79af0) at kernel/qapplication.cpp:4371
#48 0x0105ac2e in QApplication::notify (this=0xbfc7b86c, receiver=0x8b77710, e=0xbfc79af0) at kernel/qapplication.cpp:3959
#49 0x00ca568a in KApplication::notify (this=0xbfc7b86c, receiver=0x8b77710, event=0xbfc79af0) at ../../kdeui/kernel/kapplication.cpp:310
#50 0x08377b3b in QCoreApplication::notifyInternal (this=0xbfc7b86c, receiver=0x8b77710, event=0xbfc79af0) at kernel/qcoreapplication.cpp:732
#51 0x01059094 in sendEvent (receiver=0x8b77710, event=0xbfc79af0, alienWidget=0x0, nativeWidget=0x8b77710, buttonDown=0x19ee3c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#52 QApplicationPrivate::sendMouseEvent (receiver=0x8b77710, event=0xbfc79af0, alienWidget=0x0, nativeWidget=0x8b77710, buttonDown=0x19ee3c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#53 0x010e7d10 in QETWidget::translateMouseEvent (this=0x8b77710, event=0xbfc7a00c) at kernel/qapplication_x11.cpp:4403
#54 0x010e7151 in QApplication::x11ProcessEvent (this=0xbfc7b86c, event=0xbfc7a00c) at kernel/qapplication_x11.cpp:3414
#55 0x0111636a in x11EventSourceDispatch (s=0x8a46568, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#56 0x02585855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#57 0x02589668 in ?? () from /lib/libglib-2.0.so.0
#58 0x02589848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#59 0x083a6565 in QEventDispatcherGlib::processEvents (this=0x8a2e2f8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#60 0x01115be5 in QGuiEventDispatcherGlib::processEvents (this=0x8a2e2f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#61 0x08376609 in QEventLoop::processEvents (this=0x9013990, flags=) at kernel/qeventloop.cpp:149
#62 0x08376a8a in QEventLoop::exec (this=0x9013990, flags=...) at kernel/qeventloop.cpp:201
#63 0x010fb5f7 in QDragManager::drag (this=0x8c171c8, o=0x8fd2d78) at kernel/qdnd_x11.cpp:1981
#64 0x0106bd4e in QDrag::exec (this=0x8fd2d78, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#65 0x0162a8ac in QAbstractItemView::startDrag (this=0x8cb65f0, supportedActions=...) at itemviews/qabstractitemview.cpp:3437
#66 0x0162833a in QAbstractItemView::mouseMoveEvent (this=0x8cb65f0, event=0xbfc7ae70) at itemviews/qabstractitemview.cpp:1700
#67 0x0166ef74 in QTreeView::mouseMoveEvent (this=0x8cb65f0, event=0xbfc7ae70) at itemviews/qtreeview.cpp:1902
#68 0x010b1caa in QWidget::event (this=0x8cb65f0, event=0xbfc7ae70) at kernel/qwidget.cpp:8172
#69 0x014d3763 in QFrame::event (this=0x8cb65f0, e=0xbfc7ae70) at widgets/qframe.cpp:557
#70 0x01570a82 in QAbstractScrollArea::viewportEvent (this=0x8af77d0, e=0xbfc7853c) at widgets/qabstractscrollarea.cpp:1043
#71 0x0162d0f7 in QAbstractItemView::viewportEvent (this=0x8cb65f0, event=0xbfc7ae70) at itemviews/qabstractitemview.cpp:1619
#72 0x0166f883 in QTreeView::viewportEvent (this=0x8cb65f0, event=0xbfc7ae70) at itemviews/qtreeview.cpp:1256
#73 0x015734d5 in viewportEvent (this=0x8af2440, o=0x8cb4548, e=0xbfc7ae70) at widgets/qabstractscrollarea_p.h:100
#74 QAbstractScrollAreaFilter::eventFilter (this=0x8af2440, o=0x8cb4548, e=0xbfc7ae70) at widgets/qabstractscrollarea_p.h:116
#75 0x0837729a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8a43598, receiver=0x8cb4548, event=0xbfc7ae70) at kernel/qcoreapplication.cpp:847
#76 0x01053fb9 in QApplicationPrivate::notify_helper (this=0x8a43598, receiver=0x8cb4548, e=0xbfc7ae70) at kernel/qapplication.cpp:4392
#77 0x0105ac2e in QApplication::notify (this=0xbfc7b86c, receiver=0x8cb4548, e=0xbfc7ae70) at kernel/qapplication.cpp:3959
#78 0x00ca568a in KApplication::notify (this=0xbfc7b86c, receiver=0x8cb4548, event=0xbfc7ae70) at ../../kdeui/kernel/kapplication.cpp:310
#79 0x08377b3b in QCoreApplication::notifyInternal (this=0xbfc7b86c, receiver=0x8cb4548, event=0xbfc7ae70) at kernel/qcoreapplication.cpp:732
#80 0x01059094 in sendEvent (receiver=0x8cb4548, event=0xbfc7ae70, alienWidget=0x8cb4548, nativeWidget=0x8d9f758, buttonDown=0x19ee3c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#81 QApplicationPrivate::sendMouseEvent (receiver=0x8cb4548, event=0xbfc7ae70, alienWidget=0x8cb4548, nativeWidget=0x8d9f758, buttonDown=0x19ee3c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#82 0x010e7d10 in QETWidget::translateMouseEvent (this=0x8d9f758, event=0xbfc7b38c) at kernel/qapplication_x11.cpp:4403
#83 0x010e7151 in QApplication::x11ProcessEvent (this=0xbfc7b86c, event=0xbfc7b38c) at kernel/qapplication_x11.cpp:3414
#84 0x0111636a in x11EventSourceDispatch (s=0x8a46568, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#85 0x02585855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#86 0x02589668 in ?? () from /lib/libglib-2.0.so.0
#87 0x02589848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#88 0x083a6565 in QEventDispatcherGlib::processEvents (this=0x8a2e2f8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#89 0x01115be5 in QGuiEventDispatcherGlib::processEvents (this=0x8a2e2f8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#90 0x08376609 in QEventLoop::processEvents (this=0xbfc7b684, flags=) at kernel/qeventloop.cpp:149
#91 0x08376a8a in QEventLoop::exec (this=0xbfc7b684, flags=...) at kernel/qeventloop.cpp:201
#92 0x0837b00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#93 0x01052e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#94 0x00f00051 in kdemain (argc=4, argv=0xbfc7bc04) at ../../../apps/keditbookmarks/main.cpp:212
#95 0x080485ab in main (argc=4, argv=0xbfc7bc04) at keditbookmarks_dummy.cpp:3

Possible duplicates by query: bug 222190.

Reported using DrKonqi
Comment 1 Christoph Feck 2010-10-19 03:36:03 UTC

*** This bug has been marked as a duplicate of bug 226187 ***