Bug 257557 - Application: Edytor zakładek (keditbookmarks), signal: Segmentation fault
Summary: Application: Edytor zakładek (keditbookmarks), signal: Segmentation fault
Status: RESOLVED DUPLICATE of bug 226187
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-21 22:50 UTC by Marek Paśnikowski
Modified: 2012-06-23 15:26 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Paśnikowski 2010-11-21 22:50:59 UTC
Application: keditbookmarks (4.5.3 (KDE 4.5.3))
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.0
Operating System: Linux 2.6.36-CHAKRA i686
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

I wanted to organize some of my bookmarks by dragging them. The crash happenned right after releasing the mouse button.

The system is Arch-based Chakra Linux.

-- Backtrace:
Application: Edytor zakładek (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#7  0xb7339b39 in QDomNode (this=0xbfb7823c, n=@0x8) at dom/qdom.cpp:2038
#8  0xb733c064 in QDomElement (this=0xbfb7823c, x=@0x8) at dom/qdom.cpp:4738
#9  0xb762543c in ?? () from /usr/lib/libkbookmarkmodel_private.so.4
#10 0xb7623300 in KBookmarkModel::bookmarkForIndex(QModelIndex const&) const () from /usr/lib/libkbookmarkmodel_private.so.4
#11 0xb7623389 in KBookmarkModel::parent(QModelIndex const&) const () from /usr/lib/libkbookmarkmodel_private.so.4
#12 0xb6bf5c3b in QModelIndex::parent (this=0x91c0638, source_parent=...) at ../../include/QtCore/../../src/corelib/kernel/qabstractitemmodel.h:389
#13 QSortFilterProxyModelPrivate::can_create_mapping (this=0x91c0638, source_parent=...) at itemviews/qsortfilterproxymodel.cpp:399
#14 0xb6bf91fe in QSortFilterProxyModelPrivate::_q_sourceRowsAboutToBeInserted (this=0x91c0638, source_parent=..., start=2, end=2) at itemviews/qsortfilterproxymodel.cpp:1271
#15 0xb6bfd65f in QSortFilterProxyModel::qt_metacall (this=0x91c0070, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbfb78430) at .moc/debug-shared/moc_qsortfilterproxymodel.cpp:134
#16 0xb77a14b2 in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#17 0xb60a555c in QMetaObject::metacall (object=0x91c0070, cl=QMetaObject::InvokeMetaMethod, idx=36, argv=0xbfb78430) at kernel/qmetaobject.cpp:237
#18 0xb60b63d7 in QMetaObject::activate (sender=0x914a038, m=0xb61e5498, local_signal_index=4, argv=0xbfb78430) at kernel/qobject.cpp:3280
#19 0xb61079df in QAbstractItemModel::rowsAboutToBeInserted (this=0x914a038, _t1=..., _t2=2, _t3=2) at .moc/debug-shared/moc_qabstractitemmodel.cpp:174
#20 0xb6094d04 in QAbstractItemModel::beginInsertRows (this=0x914a038, parent=..., first=2, last=2) at kernel/qabstractitemmodel.cpp:2396
#21 0xb76239a6 in KBookmarkModel::beginInsert(KBookmarkGroup const&, int, int) () from /usr/lib/libkbookmarkmodel_private.so.4
#22 0xb761ec48 in CreateCommand::redo() () from /usr/lib/libkbookmarkmodel_private.so.4
#23 0xb76201cb in ?? () from /usr/lib/libkbookmarkmodel_private.so.4
#24 0xb6cdfb13 in QUndoCommand::redo (this=0x91cfd50) at util/qundostack.cpp:208
#25 0xb6ce1615 in QUndoStack::push (this=0x9140b5c, cmd=0x91cfd50) at util/qundostack.cpp:541
#26 0xb761e486 in CommandHistory::addCommand(QUndoCommand*) () from /usr/lib/libkbookmarkmodel_private.so.4
#27 0xb7624833 in KBookmarkModel::dropMimeData(QMimeData const*, Qt::DropAction, int, int, QModelIndex const&) () from /usr/lib/libkbookmarkmodel_private.so.4
#28 0xb77a1410 in ?? () from /usr/lib/libkdeinit4_keditbookmarks.so
#29 0xb6b61aa3 in QAbstractItemView::dropEvent (this=0x91b9760, event=0xbfb79174) at itemviews/qabstractitemview.cpp:1981
#30 0xb65e413f in QWidget::event (this=0x91b9760, event=0xbfb79174) at kernel/qwidget.cpp:8377
#31 0xb6a118e3 in QFrame::event (this=0x91b9760, e=0xbfb79174) at widgets/qframe.cpp:557
#32 0xb6aac442 in QAbstractScrollArea::viewportEvent (this=0x91b9760, e=0xbfb79174) at widgets/qabstractscrollarea.cpp:1043
#33 0xb6b5b49f in QAbstractItemView::viewportEvent (this=0x91b9760, event=0xbfb79174) at itemviews/qabstractitemview.cpp:1619
#34 0xb6baa483 in QTreeView::viewportEvent (this=0x91b9760, event=0xbfb79174) at itemviews/qtreeview.cpp:1256
#35 0xb6aaef35 in QAbstractScrollAreaPrivate::viewportEvent (this=0x90d21a0, o=0x91b9bc8, e=0xbfb79174) at widgets/qabstractscrollarea_p.h:100
#36 QAbstractScrollAreaFilter::eventFilter (this=0x90d21a0, o=0x91b9bc8, e=0xbfb79174) at widgets/qabstractscrollarea_p.h:116
#37 0xb609e6aa in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9037648, receiver=0x91b9bc8, event=0xbfb79174) at kernel/qcoreapplication.cpp:847
#38 0xb6581aea in QApplicationPrivate::notify_helper (this=0x9037648, receiver=0x91b9bc8, e=0xbfb79174) at kernel/qapplication.cpp:4393
#39 0xb6587e3c in QApplication::notify (this=0xbfb7b55c, receiver=0x91b9bc8, e=0xbfb79174) at kernel/qapplication.cpp:4203
#40 0xb7169d8a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#41 0xb609e50b in QCoreApplication::notifyInternal (this=0xbfb7b55c, receiver=0x91b9bc8, event=0xbfb79174) at kernel/qcoreapplication.cpp:732
#42 0xb6621b44 in QCoreApplication::sendEvent (this=0x903b070, xe=0xbfb79278, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#43 QX11Data::xdndHandleDrop (this=0x903b070, xe=0xbfb79278, passive=false) at kernel/qdnd_x11.cpp:1183
#44 0xb6622d3d in QDragManager::drop (this=0x945a3a8) at kernel/qdnd_x11.cpp:1725
#45 0xb6625d7a in QDragManager::eventFilter (this=0x945a3a8, o=0x94628d8, e=0xbfb798e8) at kernel/qdnd_x11.cpp:1312
#46 0xb609e5dc in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x9037648, receiver=0x94628d8, event=0xbfb798e8) at kernel/qcoreapplication.cpp:828
#47 0xb6581a73 in QApplicationPrivate::notify_helper (this=0x9037648, receiver=0x94628d8, e=0xbfb798e8) at kernel/qapplication.cpp:4372
#48 0xb6587c82 in QApplication::notify (this=0xbfb7b55c, receiver=0x94628d8, e=0xbfb798e8) at kernel/qapplication.cpp:3960
#49 0xb7169d8a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#50 0xb609e50b in QCoreApplication::notifyInternal (this=0xbfb7b55c, receiver=0x94628d8, event=0xbfb798e8) at kernel/qcoreapplication.cpp:732
#51 0xb6582fc0 in QCoreApplication::sendSpontaneousEvent (receiver=0x94628d8, event=0xbfb798e8, alienWidget=0x0, nativeWidget=0x94628d8, buttonDown=0xb6f8c9a0, lastMouseReceiver=..., 
    spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#52 QApplicationPrivate::sendMouseEvent (receiver=0x94628d8, event=0xbfb798e8, alienWidget=0x0, nativeWidget=0x94628d8, buttonDown=0xb6f8c9a0, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:3057
#53 0xb6616ad4 in QETWidget::translateMouseEvent (this=0x94628d8, event=0xbfb79d40) at kernel/qapplication_x11.cpp:4403
#54 0xb66156c8 in QApplication::x11ProcessEvent (this=0xbfb7b55c, event=0xbfb79d40) at kernel/qapplication_x11.cpp:3536
#55 0xb66409ea in x11EventSourceDispatch (s=0x903a6a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#56 0xb5841b72 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#57 0xb5842350 in ?? () from /usr/lib/libglib-2.0.so.0
#58 0xb5842604 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#59 0xb60cf3ac in QEventDispatcherGlib::processEvents (this=0x9008b40, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#60 0xb66405c5 in QGuiEventDispatcherGlib::processEvents (this=0x9008b40, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#61 0xb609ceb9 in QEventLoop::processEvents (this=0x923fa68, flags=...) at kernel/qeventloop.cpp:149
#62 0xb609d15a in QEventLoop::exec (this=0x923fa68, flags=...) at kernel/qeventloop.cpp:201
#63 0xb66259b7 in QDragManager::drag (this=0x945a3a8, o=0x91c6dc0) at kernel/qdnd_x11.cpp:1981
#64 0xb659681e in QDrag::exec (this=0x91c6dc0, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#65 0xb6b65abc in QAbstractItemView::startDrag (this=0x91b1fa8, supportedActions=...) at itemviews/qabstractitemview.cpp:3437
#66 0xb6b6407a in QAbstractItemView::mouseMoveEvent (this=0x91b1fa8, event=0xbfb7ac68) at itemviews/qabstractitemview.cpp:1700
#67 0xb6ba8614 in QTreeView::mouseMoveEvent (this=0x91b1fa8, event=0xbfb7ac68) at itemviews/qtreeview.cpp:1902
#68 0xb65e3b55 in QWidget::event (this=0x91b1fa8, event=0xbfb7ac68) at kernel/qwidget.cpp:8172
#69 0xb6a118e3 in QFrame::event (this=0x91b1fa8, e=0xbfb7ac68) at widgets/qframe.cpp:557
#70 0xb6aac442 in QAbstractScrollArea::viewportEvent (this=0x91b1fa8, e=0xbfb7ac68) at widgets/qabstractscrollarea.cpp:1043
#71 0xb6b5b49f in QAbstractItemView::viewportEvent (this=0x91b1fa8, event=0xbfb7ac68) at itemviews/qabstractitemview.cpp:1619
#72 0xb6baa483 in QTreeView::viewportEvent (this=0x91b1fa8, event=0xbfb7ac68) at itemviews/qtreeview.cpp:1256
#73 0xb6aaef35 in QAbstractScrollAreaPrivate::viewportEvent (this=0x91afe20, o=0x91b0ce8, e=0xbfb7ac68) at widgets/qabstractscrollarea_p.h:100
#74 QAbstractScrollAreaFilter::eventFilter (this=0x91afe20, o=0x91b0ce8, e=0xbfb7ac68) at widgets/qabstractscrollarea_p.h:116
#75 0xb609e6aa in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9037648, receiver=0x91b0ce8, event=0xbfb7ac68) at kernel/qcoreapplication.cpp:847
#76 0xb6581aea in QApplicationPrivate::notify_helper (this=0x9037648, receiver=0x91b0ce8, e=0xbfb7ac68) at kernel/qapplication.cpp:4393
#77 0xb6587c82 in QApplication::notify (this=0xbfb7b55c, receiver=0x91b0ce8, e=0xbfb7ac68) at kernel/qapplication.cpp:3960
#78 0xb7169d8a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#79 0xb609e50b in QCoreApplication::notifyInternal (this=0xbfb7b55c, receiver=0x91b0ce8, event=0xbfb7ac68) at kernel/qcoreapplication.cpp:732
#80 0xb6582fc0 in QCoreApplication::sendSpontaneousEvent (receiver=0x91b0ce8, event=0xbfb7ac68, alienWidget=0x91b0ce8, nativeWidget=0x90370e0, buttonDown=0xb6f8c9a0, lastMouseReceiver=..., 
    spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#81 QApplicationPrivate::sendMouseEvent (receiver=0x91b0ce8, event=0xbfb7ac68, alienWidget=0x91b0ce8, nativeWidget=0x90370e0, buttonDown=0xb6f8c9a0, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:3057
#82 0xb6616ad4 in QETWidget::translateMouseEvent (this=0x90370e0, event=0xbfb7b0c0) at kernel/qapplication_x11.cpp:4403
#83 0xb66156c8 in QApplication::x11ProcessEvent (this=0xbfb7b55c, event=0xbfb7b0c0) at kernel/qapplication_x11.cpp:3536
#84 0xb66409ea in x11EventSourceDispatch (s=0x903a6a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#85 0xb5841b72 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#86 0xb5842350 in ?? () from /usr/lib/libglib-2.0.so.0
#87 0xb5842604 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#88 0xb60cf3ac in QEventDispatcherGlib::processEvents (this=0x9008b40, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#89 0xb66405c5 in QGuiEventDispatcherGlib::processEvents (this=0x9008b40, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#90 0xb609ceb9 in QEventLoop::processEvents (this=0xbfb7b394, flags=...) at kernel/qeventloop.cpp:149
#91 0xb609d15a in QEventLoop::exec (this=0xbfb7b394, flags=...) at kernel/qeventloop.cpp:201
#92 0xb60a2caf in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#93 0xb657f947 in QApplication::exec () at kernel/qapplication.cpp:3673
#94 0xb7787479 in kdemain () from /usr/lib/libkdeinit4_keditbookmarks.so
#95 0x0804859b in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2011-02-19 23:47:54 UTC
[Comment from a bug triager]
This is probably related to bug 226187.
Regards
Comment 2 Jekyll Wu 2012-06-23 15:26:01 UTC

*** This bug has been marked as a duplicate of bug 226187 ***