Bug 265163 - switching between Windows when crash occured
Summary: switching between Windows when crash occured
Status: RESOLVED DUPLICATE of bug 253079
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-02 07:48 UTC by m.wege
Modified: 2011-02-02 16:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.wege 2011-02-02 07:48:39 UTC
Application: kwin (4.6.00 (4.6.0))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: switching between Windows when crash occured. switching between Windows when crash occured

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb2967720 (LWP 9064))]

Thread 3 (Thread 0xacf3db70 (LWP 9069)):
#0  0xb38f9e36 in clock_gettime () from /lib/librt.so.1
#1  0xb646750b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0xb653e6e5 in QTimerInfoList::updateCurrentTime (this=0xaf901290) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb653e72a in QTimerInfoList::timerWait (this=0xaf901290, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb653fcab in QEventDispatcherUNIX::processEvents (this=0xaf900be0, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0xb650c609 in QEventLoop::processEvents (this=0xacf3d280, flags=) at kernel/qeventloop.cpp:149
#7  0xb650ca8a in QEventLoop::exec (this=0xacf3d280, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6408b7e in QThread::exec (this=0x96e0fc0) at thread/qthread.cpp:490
#9  0xb64eb35b in QInotifyFileSystemWatcherEngine::run (this=0x96e0fc0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb640bdf9 in QThreadPrivate::start (arg=0x96e0fc0) at thread/qthread_unix.cpp:266
#11 0xb398ccc9 in start_thread () from /lib/libpthread.so.0
#12 0xb760369e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xac73cb70 (LWP 9070)):
#0  0xb77ce424 in __kernel_vsyscall ()
#1  0xb39914dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7610d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb6d37877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb6e361a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb6d378c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb6e361a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb398ccc9 in start_thread () from /lib/libpthread.so.0
#6  0xb760369e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb2967720 (LWP 9064)):
[KCrash Handler]
#7  operator== (this=0x961c5f0, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#8  KWin::EffectFrameImpl::setSelection (this=0x961c5f0, selection=...) at ../../kwin/effects.cpp:1900
#9  0xae409ac5 in KWin::BoxSwitchEffect::paintWindowsBox (this=0x95eca28, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#10 0xae40aa76 in KWin::BoxSwitchEffectProxy::paintWindowsBox (this=0x95ecb18, region=...) at ../../../kwin/effects/boxswitch/boxswitch_proxy.cpp:43
#11 0xae468984 in KWin::CoverSwitchEffect::paintScreen (this=0x9506800, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
#12 0xb77933c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x93f73b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#13 0xb6b38846 in KWin::Effect::paintScreen (this=0x946c030, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#14 0xb77933c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x93f73b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#15 0xb6b38846 in KWin::Effect::paintScreen (this=0x95bb200, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0xb77933c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x93f73b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#17 0xae45d709 in KWin::ZoomEffect::paintScreen (this=0x94f77e0, mask=32, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#18 0xb77933c0 in KWin::EffectsHandlerImpl::paintScreen (this=0x93f73b8, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#19 0xb7770e04 in KWin::Scene::paintScreen (this=0x91099f0, mask=0xbfa44c34, region=0xbfa44ce0) at ../../kwin/scene.cpp:137
#20 0xb77877aa in KWin::SceneOpenGL::paint (this=0x91099f0, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#21 0xb776bb57 in KWin::Workspace::performCompositing (this=0x93ff5a8) at ../../kwin/composite.cpp:448
#22 0xb6520504 in QObject::event (this=0x93ff5a8, e=0x961c5f8) at kernel/qobject.cpp:1183
#23 0xb5a0cfdc in QApplicationPrivate::notify_helper (this=0x9034c50, receiver=0x93ff5a8, e=0xbfa45220) at kernel/qapplication.cpp:4396
#24 0xb5a1304e in QApplication::notify (this=0xbfa45544, receiver=0x93ff5a8, e=0xbfa45220) at kernel/qapplication.cpp:3798
#25 0xb7343f7a in KApplication::notify (this=0xbfa45544, receiver=0x93ff5a8, event=0xbfa45220) at ../../kdeui/kernel/kapplication.cpp:311
#26 0xb76f4d0f in KWin::Application::notify (this=0xbfa45544, o=0x93ff5a8, e=0xbfa45220) at ../../kwin/main.cpp:376
#27 0xb650db3b in QCoreApplication::notifyInternal (this=0xbfa45544, receiver=0x93ff5a8, event=0xbfa45220) at kernel/qcoreapplication.cpp:732
#28 0xb653fad6 in sendEvent (this=0x90353d8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#29 QTimerInfoList::activateTimers (this=0x90353d8) at kernel/qeventdispatcher_unix.cpp:602
#30 0xb653fc37 in QEventDispatcherUNIX::processEvents (this=0x9016bb8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#31 0xb5ad00d2 in QEventDispatcherX11::processEvents (this=0x9016bb8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#32 0xb650c609 in QEventLoop::processEvents (this=0xbfa45474, flags=) at kernel/qeventloop.cpp:149
#33 0xb650ca8a in QEventLoop::exec (this=0xbfa45474, flags=...) at kernel/qeventloop.cpp:201
#34 0xb651100f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#35 0xb5a0be07 in QApplication::exec () at kernel/qapplication.cpp:3672
#36 0xb76f7d00 in kdemain (argc=3, argv=0xbfa457c4) at ../../kwin/main.cpp:542
#37 0x080485ab in main (argc=3, argv=0xbfa457c4) at kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 253079.

Possible duplicates by query: bug 265068, bug 263064, bug 253079.

Reported using DrKonqi
Comment 1 m.wege 2011-02-02 08:00:19 UTC
Addtional information: After the crash the window frame of LibreOffice was gone. Only of LibreOffice, all other apps including Firefox where fine. LibreOffice was still functional and could be closed normally.
Comment 2 Thomas Lübking 2011-02-02 16:03:37 UTC
dupe.

--
no idea about libre office, though.
if it's unrelated "kwin --replace" should trigger the same. then please dump xprop of that client:
"xprop > libOff_noDeco.txt", click the window and attach the file here. pressing alt+f3 while the window is active should bring you a popup and in the "advanced" submenu, you can toggle the titlebar.

*** This bug has been marked as a duplicate of bug 253079 ***