Bug 253079 - [Boxswitch] Crash in KWin::EffectFrameImpl::setSelection
Summary: [Boxswitch] Crash in KWin::EffectFrameImpl::setSelection
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 263064 265068 265163 271064 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-03 01:52 UTC by Sébastien GUERIN
Modified: 2011-05-07 11:52 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Windows switcher configuration (65.21 KB, image/png)
2010-10-21 22:39 UTC, guerini
Details
Windows switcher configuration (46.49 KB, image/png)
2010-10-21 23:13 UTC, guerini
Details
New crash information added by DrKonqi (6.82 KB, text/plain)
2010-12-16 01:56 UTC, John Layt
Details
New crash information added by DrKonqi (7.11 KB, text/plain)
2010-12-23 00:35 UTC, Bernhard Jungk
Details
New crash information added by DrKonqi (5.97 KB, text/plain)
2011-01-08 22:18 UTC, Rohan Garg
Details
New crash information added by DrKonqi (5.89 KB, text/plain)
2011-01-29 23:13 UTC, John Layt
Details
New crash information added by DrKonqi (5.78 KB, text/plain)
2011-01-31 12:42 UTC, Eric
Details
New crash information added by DrKonqi (6.24 KB, text/plain)
2011-01-31 17:57 UTC, Valdas
Details
New crash information added by DrKonqi (5.97 KB, text/plain)
2011-02-04 19:04 UTC, m.wege
Details
New crash information added by DrKonqi (6.29 KB, text/plain)
2011-02-10 15:56 UTC, Stefán Freyr Stefánsson
Details
New crash information added by DrKonqi (6.86 KB, text/plain)
2011-02-16 21:45 UTC, Ivan D Vasin
Details
New crash information added by DrKonqi (4.87 KB, text/plain)
2011-03-15 20:42 UTC, richlv
Details
New crash information added by DrKonqi (5.29 KB, text/plain)
2011-03-18 16:58 UTC, Thomas Bond
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sébastien GUERIN 2010-10-03 01:52:13 UTC
Application: kwin (4.5.68 (4.6 >= 20100912))
KDE Platform Version: 4.5.68 (4.6 >= 20100912)
Qt Version: 4.7.0
Operating System: Linux 2.6.36-tmb-laptop-0.rc6.1mdv x86_64
Distribution: "Mandriva Linux 2011.0"

-- Information about the crash:
- What I was doing when the application crashed:
I was switching between applications (KWrite, Firefox, Dolphin, Gwenview) using ALT+TAB

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x00007fd5bce82384 in operator== (r1=..., r2=...) at /usr/lib/qt4/include/QtCore/qrect.h:498
#7  0x00007fd5bceff84b in KWin::EffectFrameImpl::setSelection (this=0x269d950, selection=...) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects.cpp:1860
#8  0x00007fd5a142136e in KWin::BoxSwitchEffect::paintWindowsBox (this=0x26a8df0, region=...) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects/boxswitch/boxswitch.cpp:174
#9  0x00007fd5a146b928 in KWin::CoverSwitchEffect::paintScreen (this=0x2682c90, mask=<value optimized out>, region=..., data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects/coverswitch/coverswitch.cpp:344
#10 0x00007fd5bcf013c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x2593fb0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects.cpp:169
#11 0x00007fd5bb426d1f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/lib/kwineffects.cpp:227
#12 0x00007fd5bcf013c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x2593fb0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects.cpp:169
#13 0x00007fd5bb426d1f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/lib/kwineffects.cpp:227
#14 0x00007fd5bcf013c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x2593fb0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects.cpp:169
#15 0x00007fd5bb426d1f in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/lib/kwineffects.cpp:227
#16 0x00007fd5bcf013c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x2593fb0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects.cpp:169
#17 0x00007fd5a148c3f5 in KWin::TrackMouseEffect::paintScreen (this=0x261de00, mask=32, region=..., data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects/trackmouse/trackmouse.cpp:112
#18 0x00007fd5bcf013c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x2593fb0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects.cpp:169
#19 0x00007fd5a146296b in KWin::ZoomEffect::paintScreen (this=0x2691b60, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects/zoom/zoom.cpp:341
#20 0x00007fd5bcf013c1 in KWin::EffectsHandlerImpl::paintScreen (this=0x2593fb0, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/effects.cpp:169
#21 0x00007fd5bcee7956 in KWin::Scene::paintScreen (this=0x2552d30, mask=0x7fff3bf3c87c, region=0x7fff3bf3c9a0) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/scene.cpp:137
#22 0x00007fd5bcef8f31 in KWin::SceneOpenGL::paint (this=0x2552d30, damage=..., toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/scene_opengl.cpp:748
#23 0x00007fd5bcee2a75 in KWin::Workspace::performCompositing (this=0x23cbb20) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/composite.cpp:454
#24 0x00007fd5bce69845 in KWin::Workspace::qt_metacall (this=0x23cbb20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff3bf3cb70)
    at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/build/kwin/workspace.moc:583
#25 0x00007fd5b9321fbf in QMetaObject::activate (sender=0x23cbfe8, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#26 0x00007fd5b93217e9 in QObject::event (this=0x23cbfe8, e=<value optimized out>) at kernel/qobject.cpp:1175
#27 0x00007fd5b84c0664 in QApplicationPrivate::notify_helper (this=0x2401010, receiver=0x23cbfe8, e=0x7fff3bf3d2e0) at kernel/qapplication.cpp:4396
#28 0x00007fd5b84c50da in QApplication::notify (this=<value optimized out>, receiver=0x23cbfe8, e=0x7fff3bf3d2e0) at kernel/qapplication.cpp:4277
#29 0x00007fd5bc648766 in KApplication::notify (this=0x7fff3bf3d6d0, receiver=0x23cbfe8, event=0x7fff3bf3d2e0) at /usr/src/debug/kdelibs-4.5.68svn1174542/kdeui/kernel/kapplication.cpp:310
#30 0x00007fd5b930d73c in QCoreApplication::notifyInternal (this=0x7fff3bf3d6d0, receiver=0x23cbfe8, event=0x7fff3bf3d2e0) at kernel/qcoreapplication.cpp:732
#31 0x00007fd5b933b382 in sendEvent (this=0x2401a20) at kernel/qcoreapplication.h:215
#32 QTimerInfoList::activateTimers (this=0x2401a20) at kernel/qeventdispatcher_unix.cpp:602
#33 0x00007fd5b933b4c0 in QEventDispatcherUNIX::processEvents (this=0x23dcb10, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#34 0x00007fd5b85656ac in QEventDispatcherX11::processEvents (this=0x23dcb10, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#35 0x00007fd5b930cad2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007fd5b930cd1c in QEventLoop::exec (this=0x7fff3bf3d620, flags=...) at kernel/qeventloop.cpp:201
#37 0x00007fd5b931119b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x00007fd5bce899f9 in kdemain (argc=<value optimized out>, argv=0x7fff3bf3dc58) at /usr/src/debug/kdebase-workspace-4.5.68svn1174542/kwin/main.cpp:531
#39 0x00007fd5bcadfc3d in __libc_start_main () from /lib64/libc.so.6
#40 0x0000000000400669 in _start () at ../sysdeps/x86_64/elf/start.S:113

Reported using DrKonqi
Comment 1 Martin Flöser 2010-10-21 21:20:10 UTC
are you using boxswitch with animated windows?
Comment 2 guerini 2010-10-21 22:39:52 UTC
Created attachment 52728 [details]
Windows switcher configuration
Comment 3 guerini 2010-10-21 22:40:47 UTC
Do you speak about this ? (see screen shot above please)
Comment 4 Martin Flöser 2010-10-21 22:45:17 UTC
> --- Comment #3 from guerini <sebastien guerin news gmail com>  2010-10-21
> 22:40:47 --- Do you speak about this ? (see screen shot above please)
Sorry I don't speak French, but the dialog is not the one I mean.
Comment 5 Thomas Lübking 2010-10-21 23:01:32 UTC
@guerini:
it crashes in "Défilement dans une boîte", not in "Défilement circulaire"
Comment 6 guerini 2010-10-21 23:13:22 UTC
Created attachment 52729 [details]
Windows switcher configuration
Comment 7 guerini 2010-10-21 23:14:28 UTC
Sorry, this is the screen shot for "Défilement dans une boîte".
Comment 8 guerini 2010-10-21 23:17:35 UTC
For information, I haven't met this bug since I have upgraded to KDE "Plate-forme version 4.5.71 (4.6 >= 20101005)".
Comment 9 Thomas Lübking 2010-10-21 23:18:45 UTC
@martin: "no" ;-)
Comment 10 John Layt 2010-12-16 01:56:29 UTC
Created attachment 54816 [details]
New crash information added by DrKonqi

kwin (4.5.86 (4.6 >= 20101210) "release 8") on KDE Platform 4.5.86 (4.6 >= 20101210) "release 8" using Qt 4.7.1

- What I was doing when the application crashed:

Switching application using cover switch.

-- Backtrace (Reduced):
#6  0x00007fb5de6b4d6f in operator== (this=0x9e7cb0, selection=...) at /usr/include/QtCore/qrect.h:498
#7  KWin::EffectFrameImpl::setSelection (this=0x9e7cb0, selection=...) at /usr/src/debug/kdebase-workspace-4.5.86svn1205247/kwin/effects.cpp:1900
#8  0x00007fb5c4617cbd in KWin::BoxSwitchEffect::paintWindowsBox (this=0x92d1e0, region=...) at /usr/src/debug/kdebase-workspace-4.5.86svn1205247/kwin/effects/boxswitch/boxswitch.cpp:174
#9  0x00007fb5c46699bc in KWin::CoverSwitchEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=..., data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.5.86svn1205247/kwin/effects/coverswitch/coverswitch.cpp:344
#10 0x00007fb5de6b642c in KWin::EffectsHandlerImpl::paintScreen (this=0x8222f0, mask=32, region=<value optimized out>, data=...)
    at /usr/src/debug/kdebase-workspace-4.5.86svn1205247/kwin/effects.cpp:169
Comment 11 Bernhard Jungk 2010-12-23 00:35:49 UTC
Created attachment 55176 [details]
New crash information added by DrKonqi

kwin (4.5.85 (4.6 Beta2)) on KDE Platform 4.5.85 (4.6 Beta2) using Qt 4.7.1

- What I was doing when the application crashed:

I'm not completely sure, what exactly caused the crash. First I opened kate, maximized kate (on one screen off a dual head setup) and afterwards switched to another application. This is the first time that I'm encountering the bug.

Another strange thing: After KWin restarted, the compositing is really slow, so slow, that KWin automatically deactivates compositing. Manually enabling desktop effects again does not help either.

-- Backtrace (Reduced):
#6  0x00007f65115d382f in operator== (this=0x2464b10, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#7  KWin::EffectFrameImpl::setSelection (this=0x2464b10, selection=...) at ../../kwin/effects.cpp:1882
#8  0x00007f64f64fe947 in KWin::BoxSwitchEffect::paintWindowsBox (this=0x2613270, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#9  0x00007f64f654eac4 in KWin::CoverSwitchEffect::paintScreen (this=0x2378770, mask=<value optimized out>, region=..., data=<value optimized out>) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
#10 0x00007f65115d4f33 in KWin::EffectsHandlerImpl::paintScreen (this=0x2634600, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
Comment 12 Rohan Garg 2011-01-08 22:18:17 UTC
Created attachment 55751 [details]
New crash information added by DrKonqi

kwin (4.5.95 (4.6 RC2)) on KDE Platform 4.5.95 (4.6 RC2) using Qt 4.7.0

- What I was doing when the application crashed:
Like the original report, i was just pressing alt+tab
- Unusual behavior I noticed:
KWin crashed
- Custom settings of the application:
Alt+Tab gives the Cover Switch

-- Backtrace (Reduced):
#6  operator== (this=0x22f0730, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#7  KWin::EffectFrameImpl::setSelection (this=0x22f0730, selection=...) at ../../kwin/effects.cpp:1900
#8  0x00007f01d9bea8fd in KWin::BoxSwitchEffect::paintWindowsBox (this=0x22e2d50, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#9  0x00007f01d9c4377c in KWin::CoverSwitchEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=<value optimized out>) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
#10 0x00007f01f49d348e in KWin::EffectsHandlerImpl::paintScreen (this=0x21ca3f0, mask=32, region=) at ../../kwin/effects.cpp:169
Comment 13 Martin Flöser 2011-01-13 20:49:06 UTC
*** Bug 263064 has been marked as a duplicate of this bug. ***
Comment 14 Martin Flöser 2011-01-16 11:58:44 UTC
I am not able to reproduce this bug. Is there anything special to trigger it? Any behaviour pattern? E.g. a window gets closed and a special number of windows is still open?
Comment 15 Fabian B. 2011-01-26 00:41:03 UTC
open 15or more windows, use coverswitch as effect. now press alt+tab and then hold the tabulator down and leave alt. 
Kubuntu 10.10
Qt: 4.7.0
KDE: 4.5.95 (4.6 RC2)
Comment 16 John Layt 2011-01-26 00:57:27 UTC
I can confirm that Fabian's sequence also causes the crash here on 4.6 RC1 on openSuse with NVidia drivers, however that was not what I did when I was getting my regular crashes, mine was just two presses of alt-tab.  I've been unable to recreate the crash in regular use for a few weeks, but I've been on holiday and not using external monitors or as many open windows as usual so I'll need to test with that set-up.
Comment 17 Thomas Lübking 2011-01-26 01:15:32 UTC
No crash here (yes, with active sidearm tabbox ;-)
However i've only tested on 4.5.5 & and unclean trunk.
Notably it contains this patch: http://svn.reviewboard.kde.org/r/6355/

Maybe you could test whether it fixes your crash?
Comment 18 John Layt 2011-01-29 23:13:23 UTC
Created attachment 56637 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0)) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.1

- What I was doing when the application crashed:

It's back again :-(  Just hit alt-tab twice and down it went.  Had 19 windows open, but nothing recently opened or closed since previous alt-tab.

-- Backtrace (Reduced):
#6  0x00007f0f2827ac7f in operator== (this=0xb1f470, selection=...) at /usr/include/QtCore/qrect.h:498
#7  KWin::EffectFrameImpl::setSelection (this=0xb1f470, selection=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:1900
#8  0x00007f0f0e045cbd in KWin::BoxSwitchEffect::paintWindowsBox (this=0x9ca4a0, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:174
#9  0x00007f0f0e09799c in KWin::CoverSwitchEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=..., data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/coverswitch/coverswitch.cpp:344
#10 0x00007f0f2827c33c in KWin::EffectsHandlerImpl::paintScreen (this=0x91c2f0, mask=32, region=<value optimized out>, data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:169
Comment 19 Eric 2011-01-31 12:42:30 UTC
Created attachment 56689 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0)) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed:

I was pressing ALT+TAB to switch application

-- Backtrace (Reduced):
#7  operator== (this=0x9ae20b8, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#8  KWin::EffectFrameImpl::setSelection (this=0x9ae20b8, selection=...) at ../../kwin/effects.cpp:1900
#9  0xadb43ac5 in KWin::BoxSwitchEffect::paintWindowsBox (this=0x9afb318, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#10 0xadb44a76 in KWin::BoxSwitchEffectProxy::paintWindowsBox (this=0x9afb408, region=...) at ../../../kwin/effects/boxswitch/boxswitch_proxy.cpp:43
#11 0xadba2984 in KWin::CoverSwitchEffect::paintScreen (this=0x9b10db8, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
Comment 20 Valdas 2011-01-31 17:57:35 UTC
Created attachment 56698 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0)) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed:

I think this related to KDevelop: when I work with it then system becomes wery wery laggy (response to desktop switch, tab switch, ... delays 1 and more seconds), and then if I start rappidly switching between applications (Alt+Tab)  enaugth ~5 rapid switches in a row then desktop switcher (You know... where all opened windows is shown) freezes and then KWin restarts with crash report.

-- Backtrace (Reduced):
#7  operator== (this=0x9175800, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#8  KWin::EffectFrameImpl::setSelection (this=0x9175800, selection=...) at ../../kwin/effects.cpp:1900
#9  0x037d4ac5 in KWin::BoxSwitchEffect::paintWindowsBox (this=0x9175700, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#10 0x037d5a76 in KWin::BoxSwitchEffectProxy::paintWindowsBox (this=0x91757f0, region=...) at ../../../kwin/effects/boxswitch/boxswitch_proxy.cpp:43
#11 0x03833984 in KWin::CoverSwitchEffect::paintScreen (this=0x9182c08, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
Comment 21 Valdas 2011-01-31 18:53:10 UTC
(In reply to comment #20)

 Also I must mention that during "laggy kde" memory usage on Xorg reports 500M (!), then I tried close all applications - Xorg memory usage reduces to 100 M, but KDE remains laggy.
 Then I logged out and restarted X server, logged in started all needed apps (same apps as before KWin crash) and til now (elapsed ~10 min) Xorg memory usage remains 37 M, KDE works fast. Xorg memory leaks?
Comment 22 John Layt 2011-01-31 23:36:04 UTC
Sigh.  I've had at least 6 crashes today, 2 in the last hour with a full reboot in-between to clean things out and reducing the number of open windows, and this after 4-5 weeks of no crashes while running the RC's.  Things also feel sluggish again generally with random Xorg cpu spikes.  The only difference I can think of is I'm now back to using my external monitor instead of just the laptop screen, and I've upgraded to the latest NVidia drivers.  Perhaps I'll try roll back to the previous drivers tomorrow to see if that helps.
Comment 23 Martin Flöser 2011-02-01 07:13:43 UTC
A temporary solution would be to disable boxswitch. Unfortunately I am still unable to reproduce and in fact rather clueless.
Comment 24 Thomas Lübking 2011-02-01 16:08:23 UTC
*** Bug 265068 has been marked as a duplicate of this bug. ***
Comment 25 Thomas Lübking 2011-02-02 16:03:37 UTC
*** Bug 265163 has been marked as a duplicate of this bug. ***
Comment 26 m.wege 2011-02-04 19:04:31 UTC
Created attachment 56862 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0)) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed: Was using the task switcher when Kwin crashed.

-- Backtrace (Reduced):
#7  operator== (this=0x9135b68, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#8  KWin::EffectFrameImpl::setSelection (this=0x9135b68, selection=...) at ../../kwin/effects.cpp:1900
#9  0xae405ac5 in KWin::BoxSwitchEffect::paintWindowsBox (this=0x9133d80, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#10 0xae406a76 in KWin::BoxSwitchEffectProxy::paintWindowsBox (this=0x9133e70, region=...) at ../../../kwin/effects/boxswitch/boxswitch_proxy.cpp:43
#11 0xae464984 in KWin::CoverSwitchEffect::paintScreen (this=0x9129bc0, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
Comment 27 Thomas Lübking 2011-02-06 00:59:03 UTC
Git commit eabb12f6457a3aa704dc0e0954ef65eb9808161e by Thomas L��bking.
Committed on 06/02/11 at 00:53.
Pushed by luebking into branch 'master'.

strip qhash::operator[] from boxswitch

possibly prevents leaking ItemInfos
secure some accesses (selected_window), not sure whether this caused the unreproducable crash when used as proxy in coverswitch
manual fwd port of 84384efb52367e720ad82ace04ac8da668afc5ec

CCBUG: 253079

M  +82   -68   kwin/effects/boxswitch/boxswitch.cpp     

http://commits.kde.org/kde-workspace/eabb12f6457a3aa704dc0e0954ef65eb9808161e
Comment 28 Stefán Freyr Stefánsson 2011-02-10 15:56:09 UTC
Created attachment 57098 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0)) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed:

Switching between windows using Alt + TAB.

-- Backtrace (Reduced):
#7  operator== (this=0x9ec43f0, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#8  KWin::EffectFrameImpl::setSelection (this=0x9ec43f0, selection=...) at ../../kwin/effects.cpp:1900
#9  0xadf44ac5 in KWin::BoxSwitchEffect::paintWindowsBox (this=0xa056578, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#10 0xadf45a76 in KWin::BoxSwitchEffectProxy::paintWindowsBox (this=0xa056668, region=...) at ../../../kwin/effects/boxswitch/boxswitch_proxy.cpp:43
#11 0xadfa3984 in KWin::CoverSwitchEffect::paintScreen (this=0xa1b1618, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
Comment 29 Ivan D Vasin 2011-02-16 21:45:49 UTC
Created attachment 57311 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0)) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.0

- What I was doing when the application crashed:

switching windows with alt-tab using cover switch.

- Unusual behavior I noticed:

i didn't notice anything before the crash, but after the crash:
  * KDE is laggy, but not totally unusable.
  * Xorg (version 7.5) eats up a whole core worth of CPU usage and about 250 MB of memory.
  * firefox-4.0-bin (version 4.0b12pre (2011-02-16)) eats up a whole core worth of CPU usage.  exiting it doesn't resolve the other issues.

-- Backtrace (Reduced):
#6  operator== (this=0x23451c0, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#7  KWin::EffectFrameImpl::setSelection (this=0x23451c0, selection=...) at ../../kwin/effects.cpp:1900
#8  0x00007f0d663318fd in KWin::BoxSwitchEffect::paintWindowsBox (this=0x232a290, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#9  0x00007f0d6638a77c in KWin::CoverSwitchEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=<value optimized out>) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
#10 0x00007f0d808c81fe in KWin::EffectsHandlerImpl::paintScreen (this=0x216dc40, mask=32, region=) at ../../kwin/effects.cpp:169
Comment 30 richlv 2011-03-15 20:42:23 UTC
Created attachment 58052 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0) "release 6") on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed:

reliably reproducible. have bunch of windows open, enable coverswitch effect, hold down alt+tab for a while, press esc - kwin crashes.

-- Backtrace (Reduced):
#7  operator== (this=0x881c970, selection=...) at /usr/include/QtCore/qrect.h:498
#8  KWin::EffectFrameImpl::setSelection (this=0x881c970, selection=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:1900
#9  0xae329c6b in KWin::BoxSwitchEffect::paintWindowsBox (this=0x87bd028, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:174
#10 0xae32e525 in KWin::BoxSwitchEffectProxy::paintWindowsBox (this=0x87bd118, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch_proxy.cpp:43
#11 0xae381bfd in KWin::CoverSwitchEffect::paintScreen (this=0x87bdd10, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/coverswitch/coverswitch.cpp:344
Comment 31 Thomas Lübking 2011-03-15 21:46:31 UTC
can you try 4.6.1? The patch from comment #27 should be in there (but we don't know for sure whether that's it)
Comment 32 Thomas Bond 2011-03-18 16:58:20 UTC
Created attachment 58147 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0) "release 6") on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed: switching between windows using the cover feature

-- Backtrace (Reduced):
#7  operator== (this=0x84a3588, selection=...) at /usr/include/QtCore/qrect.h:498
#8  KWin::EffectFrameImpl::setSelection (this=0x84a3588, selection=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects.cpp:1900
#9  0xad94ac6b in KWin::BoxSwitchEffect::paintWindowsBox (this=0x821ecf8, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch.cpp:174
#10 0xad94f525 in KWin::BoxSwitchEffectProxy::paintWindowsBox (this=0x821ede8, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/boxswitch/boxswitch_proxy.cpp:43
#11 0xad9a2bfd in KWin::CoverSwitchEffect::paintScreen (this=0x84df278, mask=32, region=..., data=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/effects/coverswitch/coverswitch.cpp:344
Comment 33 Thomas Lübking 2011-04-16 01:00:55 UTC
*** Bug 271064 has been marked as a duplicate of this bug. ***
Comment 34 Martin Flöser 2011-05-07 11:52:24 UTC
I am not able to reproduce and all crash reports are for 4.6.0 or less. In case anyone is still able to reproduce with > 4.6.0, please reopen.