Bug 263064 - Cover Switch crash
Summary: Cover Switch crash
Status: RESOLVED DUPLICATE of bug 253079
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-13 20:23 UTC by Mr. Hankey
Modified: 2011-01-13 20:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mr. Hankey 2011-01-13 20:23:24 UTC
Application: kwin (4.5.95 (4.6 RC2))
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I had about 15 windows opened and pressed ALT+TAB to switch windows.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7719940 (LWP 2157))]

Thread 3 (Thread 0xb3846b70 (LWP 2164)):
#0  0x01a23e36 in clock_gettime () from /lib/librt.so.1
#1  0x0756450b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x0763b6e5 in QTimerInfoList::updateCurrentTime (this=0x93d09b0) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0763bd55 in QEventDispatcherUNIXPrivate::doSelect (this=0x93d0310, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:182
#5  0x0763cc25 in QEventDispatcherUNIX::processEvents (this=0x93cadc0, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x07609609 in QEventLoop::processEvents (this=0xb38461d0, flags=) at kernel/qeventloop.cpp:149
#7  0x07609a8a in QEventLoop::exec (this=0xb38461d0, flags=...) at kernel/qeventloop.cpp:201
#8  0x07505b7e in QThread::exec (this=0x93d4740) at thread/qthread.cpp:490
#9  0x075e835b in QInotifyFileSystemWatcherEngine::run (this=0x93d4740) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x07508df9 in QThreadPrivate::start (arg=0x93d4740) at thread/qthread_unix.cpp:266
#11 0x00619ba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 2 (Thread 0xb2f55b70 (LWP 2165)):
#0  0x008ad416 in __kernel_vsyscall ()
#1  0x05d284dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x002a2d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x010e7877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x11e61a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x010e78c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x11e61a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x00619ba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 1 (Thread 0xb7719940 (LWP 2157)):
[KCrash Handler]
#7  operator== (this=0x9331ba0, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#8  KWin::EffectFrameImpl::setSelection (this=0x9331ba0, selection=...) at ../../kwin/effects.cpp:1900
#9  0x04c38ac5 in KWin::BoxSwitchEffect::paintWindowsBox (this=0x9328528, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#10 0x04c39a76 in KWin::BoxSwitchEffectProxy::paintWindowsBox (this=0x9328618, region=...) at ../../../kwin/effects/boxswitch/boxswitch_proxy.cpp:43
#11 0x04c97984 in KWin::CoverSwitchEffect::paintScreen (this=0x93a8f30, mask=32, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
#12 0x007a6800 in KWin::EffectsHandlerImpl::paintScreen (this=0x92b4f68, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#13 0x001697d6 in KWin::Effect::paintScreen (this=0x92bd2a0, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#14 0x007a6800 in KWin::EffectsHandlerImpl::paintScreen (this=0x92b4f68, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#15 0x001697d6 in KWin::Effect::paintScreen (this=0x9322f48, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#16 0x007a6800 in KWin::EffectsHandlerImpl::paintScreen (this=0x92b4f68, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#17 0x001697d6 in KWin::Effect::paintScreen (this=0x9337f30, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#18 0x007a6800 in KWin::EffectsHandlerImpl::paintScreen (this=0x92b4f68, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#19 0x007844e4 in KWin::Scene::paintScreen (this=0x9296d30, mask=0xbf9d9864, region=0xbf9d9918) at ../../kwin/scene.cpp:137
#20 0x0079ae3a in KWin::SceneOpenGL::paint (this=0x9296d30, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:771
#21 0x0077efa8 in KWin::Workspace::performCompositing (this=0x9249c60) at ../../kwin/composite.cpp:442
#22 0x0761d504 in QObject::event (this=0x9249c60, e=0x9331ba8) at kernel/qobject.cpp:1183
#23 0x01f77fdc in QApplicationPrivate::notify_helper (this=0x9126508, receiver=0x9249c60, e=0xbf9d9e50) at kernel/qapplication.cpp:4396
#24 0x01f7e04e in QApplication::notify (this=0xbf9da174, receiver=0x9249c60, e=0xbf9d9e50) at kernel/qapplication.cpp:3798
#25 0x00ab7f8a in KApplication::notify (this=0xbf9da174, receiver=0x9249c60, event=0xbf9d9e50) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x007085bf in KWin::Application::notify (this=0xbf9da174, o=0x9249c60, e=0xbf9d9e50) at ../../kwin/main.cpp:376
#27 0x0760ab3b in QCoreApplication::notifyInternal (this=0xbf9da174, receiver=0x9249c60, event=0xbf9d9e50) at kernel/qcoreapplication.cpp:732
#28 0x0763cad6 in sendEvent (this=0x9126ce8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#29 QTimerInfoList::activateTimers (this=0x9126ce8) at kernel/qeventdispatcher_unix.cpp:602
#30 0x0763cc37 in QEventDispatcherUNIX::processEvents (this=0x9126208, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#31 0x0203b0d2 in QEventDispatcherX11::processEvents (this=0x9126208, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#32 0x07609609 in QEventLoop::processEvents (this=0xbf9da0a4, flags=) at kernel/qeventloop.cpp:149
#33 0x07609a8a in QEventLoop::exec (this=0xbf9da0a4, flags=...) at kernel/qeventloop.cpp:201
#34 0x0760e00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#35 0x01f76e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#36 0x0070b5b0 in kdemain (argc=3, argv=0xbf9da3f4) at ../../kwin/main.cpp:542
#37 0x080485ab in main (argc=3, argv=0xbf9da3f4) at kwin_dummy.cpp:3

Possible duplicates by query: bug 253079.

Reported using DrKonqi
Comment 1 Martin Flöser 2011-01-13 20:49:06 UTC

*** This bug has been marked as a duplicate of bug 253079 ***