Bug 265068 - use alt-tabs (window switch) and kwin segfault
Summary: use alt-tabs (window switch) and kwin segfault
Status: RESOLVED DUPLICATE of bug 253079
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-01 10:35 UTC by develop
Modified: 2011-02-01 16:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description develop 2011-02-01 10:35:37 UTC
Application: kwin (4.6.00 (4.6.0))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.1
Operating System: Linux 2.6.38-1-generic x86_64
Distribution: Ubuntu natty (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
use alt-tabs (window switch)
sometimes kwin crashed.

i use natty for testing and an nvidia driver from repo

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f79391927c0 (LWP 1544))]

Thread 3 (Thread 0x7f791bfeb700 (LWP 1567)):
#0  0x00007f79389e9443 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f7934d4a91c in qt_safe_select (nfds=21, fdread=0x28543e0, fdwrite=0x2854678, fdexcept=0x2854910, orig_timeout=<value optimized out>) at kernel/qcore_unix.cpp:82
#2  0x00007f7934d4f990 in QEventDispatcherUNIXPrivate::doSelect (this=0x2854220, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:219
#3  0x00007f7934d505fa in QEventDispatcherUNIX::processEvents (this=0x28a42a0, flags=...) at kernel/qeventdispatcher_unix.cpp:918
#4  0x00007f7934d21ed2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7934d2210c in QEventLoop::exec (this=0x7f791bfead90, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f7934c39214 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f7934d043df in QInotifyFileSystemWatcherEngine::run (this=0x275d040) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7934c3b9ce in QThreadPrivate::start (arg=0x275d040) at thread/qthread_unix.cpp:285
#9  0x00007f792f1e1d8c in start_thread (arg=0x7f791bfeb700) at pthread_create.c:304
#10 0x00007f79389f139d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f791b7ea700 (LWP 1568)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7937858412 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f7937b71180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f7937858449 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f7937b7f254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f792f1e1d8c in start_thread (arg=0x7f791b7ea700) at pthread_create.c:304
#4  0x00007f79389f139d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f79391927c0 (LWP 1544)):
[KCrash Handler]
#6  0x00007f7938d6d64f in operator== (this=0x29e9870, selection=...) at /usr/include/qt4/QtCore/qrect.h:498
#7  KWin::EffectFrameImpl::setSelection (this=0x29e9870, selection=...) at ../../kwin/effects.cpp:1900
#8  0x00007f791e006937 in KWin::BoxSwitchEffect::paintWindowsBox (this=0x226cda0, region=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:174
#9  0x00007f791e056a34 in KWin::CoverSwitchEffect::paintScreen (this=0x2133660, mask=<value optimized out>, region=..., data=<value optimized out>) at ../../../kwin/effects/coverswitch/coverswitch.cpp:344
#10 0x00007f7938d6ec23 in KWin::EffectsHandlerImpl::paintScreen (this=0x465b120, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#11 0x00007f7936e40a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#12 0x00007f7938d6ec23 in KWin::EffectsHandlerImpl::paintScreen (this=0x465b120, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#13 0x00007f7936e40a18 in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#14 0x00007f7938d6ec23 in KWin::EffectsHandlerImpl::paintScreen (this=0x465b120, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#15 0x00007f791e04c9cb in KWin::ZoomEffect::paintScreen (this=0x3e64170, mask=32, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#16 0x00007f7938d6ec23 in KWin::EffectsHandlerImpl::paintScreen (this=0x465b120, mask=32, region=<value optimized out>, data=...) at ../../kwin/effects.cpp:169
#17 0x00007f7938d52d5f in KWin::Scene::paintScreen (this=0x2559a10, mask=0x7fff0d0942cc, region=0x7fff0d0943b0) at ../../kwin/scene.cpp:137
#18 0x00007f7938d66be3 in KWin::SceneOpenGL::paint (this=0x2559a10, damage=..., toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:772
#19 0x00007f7938d4df87 in KWin::Workspace::performCompositing (this=0x22ee0f0) at ../../kwin/composite.cpp:442
#20 0x00007f7934d36779 in QObject::event (this=0x22ee0f0, e=<value optimized out>) at kernel/qobject.cpp:1183
#21 0x00007f79340e7024 in QApplicationPrivate::notify_helper (this=0x20d6380, receiver=0x22ee0f0, e=0x7fff0d094b20) at kernel/qapplication.cpp:4445
#22 0x00007f79340eb95a in QApplication::notify (this=<value optimized out>, receiver=0x22ee0f0, e=0x7fff0d094b20) at kernel/qapplication.cpp:4324
#23 0x00007f79384f26d6 in KApplication::notify (this=0x7fff0d094f20, receiver=0x22ee0f0, event=0x7fff0d094b20) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f7934d22aec in QCoreApplication::notifyInternal (this=0x7fff0d094f20, receiver=0x22ee0f0, event=0x7fff0d094b20) at kernel/qcoreapplication.cpp:732
#25 0x00007f7934d504c2 in sendEvent (this=0x20d6d90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x20d6d90) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f7934d5060b in QEventDispatcherUNIX::processEvents (this=0x20b1db0, flags=...) at kernel/qeventdispatcher_unix.cpp:922
#28 0x00007f793418ddac in QEventDispatcherX11::processEvents (this=0x20b1db0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#29 0x00007f7934d21ed2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f7934d2210c in QEventLoop::exec (this=0x7fff0d094e60, flags=...) at kernel/qeventloop.cpp:201
#31 0x00007f7934d2651b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#32 0x00007f7938cebfbc in kdemain (argc=<value optimized out>, argv=0x7fff0d0955b8) at ../../kwin/main.cpp:542
#33 0x00007f793892fd1e in __libc_start_main (main=0x400740 <main(int, char**)>, argc=3, ubp_av=0x7fff0d0955b8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff0d0955a8) at libc-start.c:226
#34 0x0000000000400669 in _start ()

Possible duplicates by query: bug 263064, bug 253079.

Reported using DrKonqi
Comment 1 Thomas Lübking 2011-02-01 16:08:23 UTC

*** This bug has been marked as a duplicate of bug 253079 ***