Bug 263047 - Crash in kded on wake from suspend
Summary: Crash in kded on wake from suspend
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-13 18:03 UTC by Ryan Martin
Modified: 2011-02-04 15:11 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Martin 2011-01-13 18:03:26 UTC
Application: kded4 ($Id: kded.cpp 1156841 2010-07-29 19:59:05Z zander $)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.10-74.fc14.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:

I had suspended my Toshiba Satellite L355D-S7901 using the laptop lid switch. When I woke from suspend, kded had crashed. I'm using the omnibook module to provide ACPI services.

-- Backtrace:
Application: KDE Daemon (kded4), signal: Segmentation fault
[KCrash Handler]
#6  0x000000000135d950 in ?? ()
#7  0x00000032baf61619 in QMetaObject::cast (this=0x32c0438d80, obj=0x12f36a0) at kernel/qmetaobject.cpp:266
#8  0x00007ffaf39e263a in qobject_cast<Knm::InterfaceConnection const*> (first=0x12f36a0, second=0x12cd370) at /usr/include/QtCore/qobject.h:468
#9  activatableLessThan (first=0x12f36a0, second=0x12cd370) at /usr/src/debug/networkmanagement-0.9/libs/service/sortedactivatablelist.cpp:184
#10 0x00007ffaf39e3133 in void QAlgorithmsPrivate::qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)>(QList<Knm::Activatable*>::iterator, QList<Knm::Activatable*>::iterator, Knm::Activatable* const&, bool (*)(Knm::Activatable const*, Knm::Activatable const*)) () from /usr/lib64/libknmservice.so.4
#11 0x00007ffaf39e29e8 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:187
#12 SortedActivatableList::handleUpdate (this=<value optimized out>) at /usr/src/debug/networkmanagement-0.9/libs/service/sortedactivatablelist.cpp:105
#13 0x00007ffaf39d3613 in ActivatableList::activatableChanged (this=<value optimized out>) at /usr/src/debug/networkmanagement-0.9/libs/service/activatablelist.cpp:144
#14 0x00007ffaf39cef98 in ActivatableList::qt_metacall (this=0x1187450, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24f745a0) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/libs/service/moc_activatablelist.cpp:74
#15 0x00000032baf7004f in QMetaObject::activate (sender=0x11c35f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#16 0x00000032c02278f1 in Knm::InterfaceConnection::setActivationState (this=0x11c35f0, state=<value optimized out>) at /usr/src/debug/networkmanagement-0.9/libs/internals/interfaceconnection.cpp:82
#17 0x00007ffaf37aa99d in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x11d5c80, __in_chrg=<value optimized out>) at /usr/src/debug/networkmanagement-0.9/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:58
#18 0x00007ffaf37aa9c9 in NMDBusActiveConnectionProxy::~NMDBusActiveConnectionProxy (this=0x11d5c80, __in_chrg=<value optimized out>) at /usr/src/debug/networkmanagement-0.9/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:60
#19 0x00007ffaf37acbe7 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*>::const_iterator> (begin=<value optimized out>, end=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#20 0x00007ffaf37ab306 in qDeleteAll<QHash<QString, NMDBusActiveConnectionProxy*> > (this=<value optimized out>, status=<value optimized out>) at /usr/include/QtCore/qalgorithms.h:330
#21 NMDBusActiveConnectionMonitor::networkingStatusChanged (this=<value optimized out>, status=<value optimized out>) at /usr/src/debug/networkmanagement-0.9/backends/NetworkManager/nmdbusactiveconnectionmonitor.cpp:246
#22 0x00007ffaf37820e0 in NMDBusActiveConnectionMonitor::qt_metacall (this=0x11aabc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24f74760) at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/backends/NetworkManager/moc_nmdbusactiveconnectionmonitor.cpp:78
#23 0x00000032baf7004f in QMetaObject::activate (sender=0x118f610, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff24f74760) at kernel/qobject.cpp:3272
#24 0x00000032c2819b6e in Solid::Control::NetworkManager::Notifier::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown) at /usr/src/debug/kdebase-workspace-4.5.4/x86_64-redhat-linux-gnu/libs/solid/control/networkmanager.moc:103
#25 0x00000032c2819de3 in Solid::Control::NetworkManager::Notifier::qt_metacall (this=0x118f610, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24f748b0) at /usr/src/debug/kdebase-workspace-4.5.4/x86_64-redhat-linux-gnu/libs/solid/control/networkmanager.moc:85
#26 0x00000032c281a190 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x118f610, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24f748b0) at /usr/src/debug/kdebase-workspace-4.5.4/x86_64-redhat-linux-gnu/libs/solid/control/networkmanager_p.moc:76
#27 0x00000032baf7004f in QMetaObject::activate (sender=0x11938d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff24f748b0) at kernel/qobject.cpp:3272
#28 0x00000032c5008c7e in Solid::Control::Ifaces::NetworkManager::statusChanged (this=<value optimized out>, _t1=Solid::Networking::Unknown) at /usr/src/debug/kdebase-workspace-4.5.4/x86_64-redhat-linux-gnu/libs/solid/control/ifaces/networkmanager.moc:111
#29 0x00007ffaf3354acb in NMNetworkManager::qt_metacall (this=0x11938d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff24f74a00) at /usr/src/debug/kdebase-workspace-4.5.4/x86_64-redhat-linux-gnu/solid/networkmanager-0.7/manager.moc:97
#30 0x00000032baf7004f in QMetaObject::activate (sender=0x1193e30, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fff24f74a00) at kernel/qobject.cpp:3272
#31 0x00007ffaf335deb1 in OrgFreedesktopNetworkManagerInterface::StateChanged (this=<value optimized out>, _t1=1) at /usr/src/debug/kdebase-workspace-4.5.4/x86_64-redhat-linux-gnu/solid/networkmanager-0.7/nm-manager-clientinterface.moc:182
#32 0x00007ffaf335e29e in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x1193e30, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0x7fff24f74e90) at /usr/src/debug/kdebase-workspace-4.5.4/x86_64-redhat-linux-gnu/solid/networkmanager-0.7/nm-manager-clientinterface.moc:108
#33 0x00000032bc020228 in QDBusConnectionPrivate::deliverCall (this=0x118b760, object=0x1193e30, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:919
#34 0x00000032bc02b0ff in QDBusCallDeliveryEvent::placeMetaCall (this=<value optimized out>, object=<value optimized out>) at qdbusintegrator_p.h:103
#35 0x00000032baf6fb4a in QObject::event (this=0x1193e30, e=<value optimized out>) at kernel/qobject.cpp:1211
#36 0x00000032bdfb78c4 in QApplicationPrivate::notify_helper (this=0x1037b20, receiver=0x1193e30, e=0x111ce80) at kernel/qapplication.cpp:4445
#37 0x00000032bdfbc3da in QApplication::notify (this=<value optimized out>, receiver=0x1193e30, e=0x111ce80) at kernel/qapplication.cpp:4324
#38 0x00000032bfa20566 in KApplication::notify (this=0x7fff24f75960, receiver=0x1193e30, event=0x111ce80) at /usr/src/debug/kdelibs-4.5.4/kdeui/kernel/kapplication.cpp:310
#39 0x00000032baf5b7ac in QCoreApplication::notifyInternal (this=0x7fff24f75960, receiver=0x1193e30, event=0x111ce80) at kernel/qcoreapplication.cpp:732
#40 0x00000032baf5ef95 in sendEvent (receiver=0x0, event_type=0, data=0x100d600) at kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x100d600) at kernel/qcoreapplication.cpp:1373
#42 0x00000032baf86723 in sendPostedEvents (s=0x103b6f0) at kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=0x103b6f0) at kernel/qeventdispatcher_glib.cpp:277
#44 0x00000032b1e41e33 in g_main_dispatch (context=0x103a5f0) at gmain.c:2149
#45 g_main_context_dispatch (context=0x103a5f0) at gmain.c:2702
#46 0x00000032b1e42610 in g_main_context_iterate (context=0x103a5f0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#47 0x00000032b1e428ad in g_main_context_iteration (context=0x103a5f0, may_block=1) at gmain.c:2843
#48 0x00000032baf868bf in QEventDispatcherGlib::processEvents (this=0x100ccf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#49 0x00000032be05c59e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#50 0x00000032baf5ab42 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#51 0x00000032baf5ad8c in QEventLoop::exec (this=0x7fff24f758b0, flags=...) at kernel/qeventloop.cpp:201
#52 0x00000032baf5f24b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#53 0x00000032baa081a7 in kdemain (argc=1, argv=0x7fff24f75d28) at /usr/src/debug/kdelibs-4.5.4/kded/kded.cpp:894
#54 0x00000032afe1ee7d in __libc_start_main (main=0x400810 <main(int, char**)>, argc=1, ubp_av=0x7fff24f75d28, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff24f75d18) at libc-start.c:226
#55 0x0000000000400739 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-22 12:58:37 UTC
[Comment from a bug triager]
This is probably related to bug 258168 / bug 256662 / bug 210878.
Regards
Comment 2 Lamarque V. Souza 2011-02-04 15:11:24 UTC

*** This bug has been marked as a duplicate of bug 210878 ***