Bug 260767 - plasma crash after adding magic folder applet
Summary: plasma crash after adding magic folder applet
Status: RESOLVED DUPLICATE of bug 182511
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-20 09:01 UTC by Johannes Schwall
Modified: 2010-12-20 18:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Schwall 2010-12-20 09:01:53 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.1
Operating System: Linux 2.6.35.6-45.fc14.i686 i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
added "magic folder" applet to plasma bar; plasma crashed immediately after that and restartet

-- Backtrace:
Application: Plasma-Arbeitsfläche (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77139b0 (LWP 13373))]

Thread 5 (Thread 0xaefffb70 (LWP 13632)):
#0  0x0087f416 in __kernel_vsyscall ()
#1  0x0064b98b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x0588f567 in wait (this=0x9789ee8, mutex=0x9786ac8, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x9789ee8, mutex=0x9786ac8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0x03ef9fb1 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9789ed0, th=0x94cad10) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x03efccdd in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x978a070, th=0x94cad10) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x03ef9bec in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9789ed0, th=0x94cad10) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x03efcdd2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x978a070, th=0x94cad10) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x03ef9b34 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9789ed0, th=0x94cad10, previous=0x9df7c90) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x03efb7b6 in ThreadWeaver::ThreadRunHelper::run (this=0xaefff284, parent=0x9789ed0, th=0x94cad10) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/Thread.cpp:87
#10 0x03efb87c in ThreadWeaver::Thread::run (this=0x94cad10) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/Thread.cpp:142
#11 0x0588ee6a in QThreadPrivate::start (arg=0x94cad10) at thread/qthread_unix.cpp:285
#12 0x00646f19 in start_thread () from /lib/libpthread.so.0
#13 0x00555a2e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xaf9ffb70 (LWP 13633)):
#0  0x0087f416 in __kernel_vsyscall ()
#1  0x0064b98b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x0588f567 in wait (this=0x9789ee8, mutex=0x9786ac8, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x9789ee8, mutex=0x9786ac8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0x03ef9fb1 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9789ed0, th=0x9b2ab60) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x03efccdd in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x978a070, th=0x9b2ab60) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x03ef9bec in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9789ed0, th=0x9b2ab60) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x03efcdd2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x978a070, th=0x9b2ab60) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x03ef9b34 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9789ed0, th=0x9b2ab60, previous=0x0) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x03efcdf1 in ThreadWeaver::WorkingHardState::applyForWork (this=0x978a070, th=0x9b2ab60) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WorkingHardState.cpp:74
#10 0x03ef9b34 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9789ed0, th=0x9b2ab60, previous=0x9d926a0) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:351
#11 0x03efb7b6 in ThreadWeaver::ThreadRunHelper::run (this=0xaf9ff284, parent=0x9789ed0, th=0x9b2ab60) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/Thread.cpp:87
#12 0x03efb87c in ThreadWeaver::Thread::run (this=0x9b2ab60) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/Thread.cpp:142
#13 0x0588ee6a in QThreadPrivate::start (arg=0x9b2ab60) at thread/qthread_unix.cpp:285
#14 0x00646f19 in start_thread () from /lib/libpthread.so.0
#15 0x00555a2e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xac85eb70 (LWP 13634)):
#0  0x0087f416 in __kernel_vsyscall ()
#1  0x0064b98b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x0588f567 in wait (this=0x9789ee8, mutex=0x9786ac8, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x9789ee8, mutex=0x9786ac8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0x03ef9fb1 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9789ed0, th=0x98535a8) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x03efccdd in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x978a070, th=0x98535a8) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x03ef9bec in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9789ed0, th=0x98535a8) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x03efcdd2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x978a070, th=0x98535a8) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x03ef9b34 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9789ed0, th=0x98535a8, previous=0x9d7b8d0) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x03efb7b6 in ThreadWeaver::ThreadRunHelper::run (this=0xac85e284, parent=0x9789ed0, th=0x98535a8) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/Thread.cpp:87
#10 0x03efb87c in ThreadWeaver::Thread::run (this=0x98535a8) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/Thread.cpp:142
#11 0x0588ee6a in QThreadPrivate::start (arg=0x98535a8) at thread/qthread_unix.cpp:285
#12 0x00646f19 in start_thread () from /lib/libpthread.so.0
#13 0x00555a2e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xac05db70 (LWP 13635)):
#0  0x0087f416 in __kernel_vsyscall ()
#1  0x0064b98b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x0588f567 in wait (this=0x9789ee8, mutex=0x9786ac8, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#3  QWaitCondition::wait (this=0x9789ee8, mutex=0x9786ac8, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#4  0x03ef9fb1 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9789ed0, th=0x94b4270) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x03efccdd in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x978a070, th=0x94b4270) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x03ef9bec in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9789ed0, th=0x94b4270) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x03efcdd2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x978a070, th=0x94b4270) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x03ef9b34 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9789ed0, th=0x94b4270, previous=0x9d72640) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x03efb7b6 in ThreadWeaver::ThreadRunHelper::run (this=0xac05d284, parent=0x9789ed0, th=0x94b4270) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/Thread.cpp:87
#10 0x03efb87c in ThreadWeaver::Thread::run (this=0x94b4270) at /usr/src/debug/kdelibs-4.5.4/threadweaver/Weaver/Thread.cpp:142
#11 0x0588ee6a in QThreadPrivate::start (arg=0x94b4270) at thread/qthread_unix.cpp:285
#12 0x00646f19 in start_thread () from /lib/libpthread.so.0
#13 0x00555a2e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77139b0 (LWP 13373)):
[KCrash Handler]
#7  0x0588a483 in fetchAndAddOrdered (this=0xa257f10) at ../../src/corelib/arch/qatomic_i386.h:163
#8  fetchAndAddAcquire (this=0xa257f10) at ../../src/corelib/arch/qatomic_i386.h:296
#9  QMutex::lock (this=0xa257f10) at thread/qmutex.cpp:159
#10 0x05989601 in QCoreApplication::postEvent (receiver=0xa1bca30, event=0xa168f90, priority=0) at kernel/qcoreapplication.cpp:1141
#11 0x0598991d in QCoreApplication::postEvent (receiver=0xa1bca30, event=0xa168f90) at kernel/qcoreapplication.cpp:1094
#12 0x05998985 in QObject::deleteLater (this=0xa1bca30) at kernel/qobject.cpp:2123
#13 0x062edc11 in QX11Data::xdndHandleFinished (this=0x91ba360, xe=0xbfb2cefc, passive=false) at kernel/qdnd_x11.cpp:1254
#14 0x062dec0e in QApplication::x11ClientMessage (this=0x91ab5f0, w=0x9dbf980, event=0xbfb2cefc, passive_only=false) at kernel/qapplication_x11.cpp:3135
#15 0x062dc982 in QApplication::x11ProcessEvent (this=0x91ab5f0, event=0xbfb2cefc) at kernel/qapplication_x11.cpp:3703
#16 0x06307790 in x11EventSourceDispatch (s=0x91b9ae8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#17 0x008c0192 in g_main_dispatch (context=0x91b8c90) at gmain.c:2149
#18 g_main_context_dispatch (context=0x91b8c90) at gmain.c:2702
#19 0x008c0978 in g_main_context_iterate (context=0x91b8c90, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2780
#20 0x008c0c35 in g_main_context_iteration (context=0x91b8c90, may_block=1) at gmain.c:2843
#21 0x059b402d in QEventDispatcherGlib::processEvents (this=0x9195a48, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#22 0x06307406 in QGuiEventDispatcherGlib::processEvents (this=0x9195a48, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#23 0x059854ca in QEventLoop::processEvents (this=0xbfb2d1d4, flags=...) at kernel/qeventloop.cpp:149
#24 0x0598577a in QEventLoop::exec (this=0xbfb2d1d4, flags=...) at kernel/qeventloop.cpp:201
#25 0x0598a327 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#26 0x06252078 in QApplication::exec () at kernel/qapplication.cpp:3719
#27 0x07804e21 in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#28 0x080487cc in _start ()

This bug may be a duplicate of or related to bug 192000.

Possible duplicates by query: bug 258095, bug 254699, bug 252098, bug 247792, bug 247467.

Reported using DrKonqi
Comment 1 Marco Martin 2010-12-20 18:03:17 UTC

*** This bug has been marked as a duplicate of bug 182511 ***