Bug 247792 - Crash when changing controlbar
Summary: Crash when changing controlbar
Status: RESOLVED DUPLICATE of bug 192000
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-13 23:48 UTC by Knut
Modified: 2010-08-27 12:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Knut 2010-08-13 23:48:23 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.2 (KDE 4.4.2)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-24-generic i686
Distribution: Ubuntu 10.04.1 LTS

-- Information about the crash:
Crash when changing controlbarsettings

kubuntu10.4, KDE 4.4.2

 -- Backtrace:
Application: Plasma-Arbeitsfläche (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78a0aa0 (LWP 1518))]

Thread 7 (Thread 0xaa598b70 (LWP 1522)):
#0  0x02416e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x00d316fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x00d36825 in QTimerInfoList::updateCurrentTime (this=0x89f02ac) at kernel/qeventdispatcher_unix.cpp:340
#3  0x00d3686a in QTimerInfoList::timerWait (this=0x89f02ac, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x00d34818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaa5980cc) at kernel/qeventdispatcher_glib.cpp:136
#5  0x00d348a5 in timerSourcePrepare (source=0x0, timeout=0x241aff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x04b83aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x04b83ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x04b844b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x00d3460f in QEventDispatcherGlib::processEvents (this=0x89efc40, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x00d07059 in QEventLoop::processEvents (this=0xaa598290, flags=) at kernel/qeventloop.cpp:149
#11 0x00d074aa in QEventLoop::exec (this=0xaa598290, flags=...) at kernel/qeventloop.cpp:201
#12 0x00c035a8 in QThread::exec (this=0x89eded8) at thread/qthread.cpp:487
#13 0x00ce6c1b in QInotifyFileSystemWatcherEngine::run (this=0x89eded8) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x00c0632e in QThreadPrivate::start (arg=0x89eded8) at thread/qthread_unix.cpp:248
#15 0x0043196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x06516a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xa9d8bb70 (LWP 1523)):
#0  0x003b7422 in __kernel_vsyscall ()
#1  0x00436015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x06fec9d7 in ?? () from /usr/lib/libQtWebKit.so.4
#3  0x06feca21 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0x0043196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x06516a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xa7b97b70 (LWP 1825)):
#0  0x003b7422 in __kernel_vsyscall ()
#1  0x00436015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00c07287 in QWaitConditionPrivate::wait (this=0x8909d18, mutex=0x89014f8, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x8909d18, mutex=0x89014f8, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x01ba0870 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8909d00, th=0x8ebf5c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x01ba338c in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8932d58, th=0x8ebf5c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x01b9f27b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8909d00, th=0x8ebf5c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x01ba3482 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8932d58, th=0x8ebf5c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x01ba04d3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8909d00, th=0x8ebf5c0, previous=0x8909670) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x01ba151e in ThreadWeaver::ThreadRunHelper::run (this=0xa7b972f4, parent=0x8909d00, th=0x8ebf5c0) at ../../../threadweaver/Weaver/Thread.cpp:87
#10 0x01ba1c3b in ThreadWeaver::Thread::run (this=0x8ebf5c0) at ../../../threadweaver/Weaver/Thread.cpp:142
#11 0x00c0632e in QThreadPrivate::start (arg=0x8ebf5c0) at thread/qthread_unix.cpp:248
#12 0x0043196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x06516a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xa7396b70 (LWP 1826)):
#0  0x003b7422 in __kernel_vsyscall ()
#1  0x00436015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00c07287 in QWaitConditionPrivate::wait (this=0x8909d18, mutex=0x89014f8, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x8909d18, mutex=0x89014f8, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x01ba0870 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8909d00, th=0x8f39a90) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x01ba338c in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8932d58, th=0x8f39a90) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x01b9f27b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8909d00, th=0x8f39a90) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x01ba3482 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8932d58, th=0x8f39a90) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x01ba04d3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8909d00, th=0x8f39a90, previous=0x8f63268) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x01ba151e in ThreadWeaver::ThreadRunHelper::run (this=0xa73962f4, parent=0x8909d00, th=0x8f39a90) at ../../../threadweaver/Weaver/Thread.cpp:87
#10 0x01ba1c3b in ThreadWeaver::Thread::run (this=0x8f39a90) at ../../../threadweaver/Weaver/Thread.cpp:142
#11 0x00c0632e in QThreadPrivate::start (arg=0x8f39a90) at thread/qthread_unix.cpp:248
#12 0x0043196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x06516a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xa6b95b70 (LWP 1827)):
#0  0x003b7422 in __kernel_vsyscall ()
#1  0x00436015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00c07287 in QWaitConditionPrivate::wait (this=0x8909d18, mutex=0x89014f8, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x8909d18, mutex=0x89014f8, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x01ba0870 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8909d00, th=0x8dedc88) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x01ba338c in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8932d58, th=0x8dedc88) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x01b9f27b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8909d00, th=0x8dedc88) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x01ba3482 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8932d58, th=0x8dedc88) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x01ba04d3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8909d00, th=0x8dedc88, previous=0x8622c78) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x01ba151e in ThreadWeaver::ThreadRunHelper::run (this=0xa6b952f4, parent=0x8909d00, th=0x8dedc88) at ../../../threadweaver/Weaver/Thread.cpp:87
#10 0x01ba1c3b in ThreadWeaver::Thread::run (this=0x8dedc88) at ../../../threadweaver/Weaver/Thread.cpp:142
#11 0x00c0632e in QThreadPrivate::start (arg=0x8dedc88) at thread/qthread_unix.cpp:248
#12 0x0043196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x06516a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa61ffb70 (LWP 1828)):
#0  0x003b7422 in __kernel_vsyscall ()
#1  0x00436015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x00c07287 in QWaitConditionPrivate::wait (this=0x8909d18, mutex=0x89014f8, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x8909d18, mutex=0x89014f8, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x01ba0870 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8909d00, th=0x8d18ee8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#5  0x01ba338c in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8932d58, th=0x8d18ee8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#6  0x01b9f27b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8909d00, th=0x8d18ee8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#7  0x01ba3482 in ThreadWeaver::WorkingHardState::applyForWork (this=0x8932d58, th=0x8d18ee8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#8  0x01ba04d3 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8909d00, th=0x8d18ee8, previous=0x8636050) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#9  0x01ba151e in ThreadWeaver::ThreadRunHelper::run (this=0xa61ff2f4, parent=0x8909d00, th=0x8d18ee8) at ../../../threadweaver/Weaver/Thread.cpp:87
#10 0x01ba1c3b in ThreadWeaver::Thread::run (this=0x8d18ee8) at ../../../threadweaver/Weaver/Thread.cpp:142
#11 0x00c0632e in QThreadPrivate::start (arg=0x8d18ee8) at thread/qthread_unix.cpp:248
#12 0x0043196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x06516a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb78a0aa0 (LWP 1518)):
[KCrash Handler]
#6  0x00c00f99 in QBasicAtomicInt::fetchAndAddOrdered (this=0x8dff07a) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:163
#7  QBasicAtomicInt::fetchAndAddAcquire (this=0x8dff07a) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:296
#8  QMutex::lock (this=0x8dff07a) at thread/qmutex.cpp:196
#9  0x00d08634 in QCoreApplication::postEvent (receiver=0x98f33a8, event=0x9a55a20, priority=0) at kernel/qcoreapplication.cpp:1113
#10 0x00d089ac in QCoreApplication::postEvent (receiver=0x98f33a8, event=0x9a55a20) at kernel/qcoreapplication.cpp:1066
#11 0x00d188a4 in QObject::deleteLater (this=0x98f33a8) at kernel/qobject.cpp:2158
#12 0x0116ba25 in QX11Data::xdndHandleFinished (this=0x85ede70, xe=0xbf9a640c, passive=false) at kernel/qdnd_x11.cpp:1239
#13 0x0114beb6 in QApplication::x11ClientMessage (this=0x85e47d8, w=0x9a3d058, event=0xbf9a640c, passive_only=true) at kernel/qapplication_x11.cpp:3090
#14 0x0115b879 in QApplication::x11ProcessEvent (this=0x85e47d8, event=0xbf9a640c) at kernel/qapplication_x11.cpp:3633
#15 0x0118b60a in x11EventSourceDispatch (s=0x85ed5a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#16 0x04b805e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#17 0x04b842d8 in ?? () from /lib/libglib-2.0.so.0
#18 0x04b844b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#19 0x00d345d5 in QEventDispatcherGlib::processEvents (this=0x85ea5c0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#20 0x0118b135 in QGuiEventDispatcherGlib::processEvents (this=0x85ea5c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#21 0x00d07059 in QEventLoop::processEvents (this=0xbf9a6704, flags=) at kernel/qeventloop.cpp:149
#22 0x00d074aa in QEventLoop::exec (this=0xbf9a6704, flags=...) at kernel/qeventloop.cpp:201
#23 0x00d0b69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#24 0x010cb577 in QApplication::exec () at kernel/qapplication.cpp:3579
#25 0x0220205e in kdemain (argc=1, argv=0x85dbad0) at ../../../../plasma/desktop/shell/main.cpp:112
#26 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x85db950 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#27 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#28 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#29 0x0804fe4f in main (argc=4, argv=0xbf9a71b4, envp=0xbf9a71c8) at ../../kinit/kinit.cpp:1845

Reported using DrKonqi
Comment 1 Beat Wolf 2010-08-27 12:30:25 UTC

*** This bug has been marked as a duplicate of bug 192000 ***