Bug 258095 - plasma crashed when i draged an image file to GIMP
Summary: plasma crashed when i draged an image file to GIMP
Status: RESOLVED DUPLICATE of bug 252098
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-27 18:58 UTC by Hari
Modified: 2010-11-29 15:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hari 2010-11-27 18:58:39 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-23-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I was dragging an image file from Dolphin to GIMP and the Plasma desktop crashed

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb786e720 (LWP 1445))]

Thread 2 (Thread 0xae1b9b70 (LWP 1452)):
#0  QThreadData::current () at thread/qthread_unix.cpp:146
#1  0x07c09ab5 in postEventSourcePrepare (s=0xaf100f58, timeout=0xae1b90ac) at kernel/qeventdispatcher_glib.cpp:254
#2  0x0450ce6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#3  0x0450d279 in ?? () from /lib/libglib-2.0.so.0
#4  0x0450d848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x07c0959f in QEventDispatcherGlib::processEvents (this=0xaf100658, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x07bd9609 in QEventLoop::processEvents (this=0xae1b9280, flags=) at kernel/qeventloop.cpp:149
#7  0x07bd9a8a in QEventLoop::exec (this=0xae1b9280, flags=...) at kernel/qeventloop.cpp:201
#8  0x07ad5b7e in QThread::exec (this=0xa356a40) at thread/qthread.cpp:490
#9  0x07bb835b in QInotifyFileSystemWatcherEngine::run (this=0xa356a40) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x07ad8df9 in QThreadPrivate::start (arg=0xa356a40) at thread/qthread_unix.cpp:266
#11 0x00249cc9 in start_thread () from /lib/libpthread.so.0
#12 0x00e9d6be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb786e720 (LWP 1445)):
[KCrash Handler]
#7  0x07ad359b in fetchAndAddOrdered (this=0x250087) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:163
#8  fetchAndAddAcquire (this=0x250087) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:296
#9  QMutex::lock (this=0x250087) at thread/qmutex.cpp:159
#10 0x07bdd724 in QCoreApplication::postEvent (receiver=0xb380778, event=0xa4fefa0, priority=0) at kernel/qcoreapplication.cpp:1141
#11 0x07bddaac in QCoreApplication::postEvent (receiver=0xb380778, event=0xa4fefa0) at kernel/qcoreapplication.cpp:1094
#12 0x07bec2c4 in QObject::deleteLater (this=0xb380778) at kernel/qobject.cpp:2131
#13 0x088f3213 in QDragManager::timerEvent (this=0xb4669b0, e=0xbfae5450) at kernel/qdnd_x11.cpp:1277
#14 0x07bed504 in QObject::event (this=0xb4669b0, e=0x1) at kernel/qobject.cpp:1183
#15 0x0884bfdc in QApplicationPrivate::notify_helper (this=0x99be668, receiver=0xb4669b0, e=0xbfae5450) at kernel/qapplication.cpp:4396
#16 0x0885204e in QApplication::notify (this=0x99b37b0, receiver=0xb4669b0, e=0xbfae5450) at kernel/qapplication.cpp:3798
#17 0x0110368a in KApplication::notify (this=0x99b37b0, receiver=0xb4669b0, event=0xbfae5450) at ../../kdeui/kernel/kapplication.cpp:310
#18 0x07bdab3b in QCoreApplication::notifyInternal (this=0x99b37b0, receiver=0xb4669b0, event=0xbfae5450) at kernel/qcoreapplication.cpp:732
#19 0x07c0cad6 in sendEvent (this=0x99c1834) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#20 QTimerInfoList::activateTimers (this=0x99c1834) at kernel/qeventdispatcher_unix.cpp:602
#21 0x07c098a7 in timerSourceDispatch (source=0x99c1868) at kernel/qeventdispatcher_glib.cpp:184
#22 idleTimerSourceDispatch (source=0x99c1868) at kernel/qeventdispatcher_glib.cpp:231
#23 0x04509855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x0450d668 in ?? () from /lib/libglib-2.0.so.0
#25 0x0450d848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x07c09565 in QEventDispatcherGlib::processEvents (this=0x999cce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#27 0x0890dbe5 in QGuiEventDispatcherGlib::processEvents (this=0x999cce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x07bd9609 in QEventLoop::processEvents (this=0xbfae5714, flags=) at kernel/qeventloop.cpp:149
#29 0x07bd9a8a in QEventLoop::exec (this=0xbfae5714, flags=...) at kernel/qeventloop.cpp:201
#30 0x07bde00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#31 0x0884ae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#32 0x0047b86e in kdemain (argc=1, argv=0xbfae5924) at ../../../../plasma/desktop/shell/main.cpp:118
#33 0x080485bb in main (argc=1, argv=0xbfae5924) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 254699, bug 252098, bug 247792, bug 247467, bug 235790.

Reported using DrKonqi
Comment 1 Beat Wolf 2010-11-29 15:24:52 UTC

*** This bug has been marked as a duplicate of bug 252098 ***