Bug 260434 - picture gray scale mode looks weird
Summary: picture gray scale mode looks weird
Status: VERIFIED FIXED
Alias: None
Product: calligracommon
Classification: Applications
Component: flake-picture (show other bugs)
Version: 2.4.1
Platform: Unlisted Binaries All
: NOR normal (vote)
Target Milestone: ---
Assignee: Calligra Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-10 14:14 UTC by Lassi Nieminen
Modified: 2012-10-23 07:50 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Open Office document to be open in Kword (1.42 MB, application/opendocument)
2009-12-10 14:14 UTC, David Faure
Details
Screenshot of the document in Kword (231.12 KB, image/pjpeg)
2009-12-10 14:16 UTC, David Faure
Details
Screenshot of the document in Open Office (271.49 KB, image/pjpeg)
2009-12-10 14:16 UTC, David Faure
Details
document with embeddded image with grayscale effect. (12.66 KB, application/vnd.oasis.opendocument.text)
2011-04-05 10:57 UTC, Halla Rempt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Faure 2010-12-17 19:41:15 UTC


---- Reported by faure@kde.org 2010-03-22 12:44:13 ----




---- Reported by lassi.ta.nieminen@nokia.com 2009-12-10 15:14:57 +0200 ----

Created an attachment
Open Office document to be open in Kword

SOFTWARE VERSION:
   Kubuntu 9.04
   Koffice (svn version  1056420)-
   Test document (Open Office): oow_pic_gray_scale_mode.odt

 STEPS LEADING TO THE PROBLEM:
   1. Open the attached document Open Office.
   2. Open the same document in KOffice.
   3. Observe the picture in the document.

 EXPECTED OUTCOME:
   Kword should be able to show the picture in gray scale mode
   As seen in the attachment oow_pic_gray_scale_mode-odt.jpeg

 ACTUAL OUTCOME:
   Kword is not showing the picture in gray scale mode
   Picture is shown in actual color.
   As seen in the attachment oow_pic_gray_scale_mode-kword.jpeg

 FREQUENCY:
   Always



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-10 15:16:00 +0200 ----

Created an attachment
Screenshot of the document in Kword



---- Additional Comments From lassi.ta.nieminen@nokia.com 2009-12-10 15:16:55 +0200 ----

Created an attachment
Screenshot of the document in Open Office



--- Bug imported by faure@kde.org 2010-03-22 12:44  ---

This bug was previously known as _bug_ 150263.

Imported an attachment (id=42026)
Imported an attachment (id=42027)
Imported an attachment (id=42028)




---- Additional Comments From boud@valdyas.org 2010-03-23 10:46:14 ----

Not filter but core bugs.



---- Additional Comments From zander@kde.org 2010-03-23 17:42:36 ----

*** http://bugs.kde.org/show_bug.cgi?id=231698 has been marked as a duplicate of this bug. ***



---- Additional Comments From zander@kde.org 2010-03-23 17:43:42 ----

*** http://bugs.kde.org/show_bug.cgi?id=231700 has been marked as a duplicate of this bug. ***



---- Additional Comments From zander@kde.org 2010-09-27 16:31:16 ----

*** http://bugs.kde.org/show_bug.cgi?id=239341 has been marked as a duplicate of this bug. ***



---- Additional Comments From zander@kde.org 2010-09-27 16:32:17 ----

Should work in 2.3



--- Bug imported by faure@kde.org 2010-12-17 19:42  ---

This bug was previously known as bug 231704.

Imported an attachment (id=54902)
Imported an attachment (id=54903)
Imported an attachment (id=54904)

The original submitter of attachment 54902 [details] is unknown.
   Reassigning to the person who moved it here: faure@kde.org.
The original submitter of attachment 54903 [details] is unknown.
   Reassigning to the person who moved it here: faure@kde.org.
The original submitter of attachment 54904 [details] is unknown.
   Reassigning to the person who moved it here: faure@kde.org.

Comment 1 Halla Rempt 2011-04-05 10:56:46 UTC
The attachment is broken. I'll add a new attachment. The filter is applied now, but the result is wrong.
Comment 2 Halla Rempt 2011-04-05 10:57:46 UTC
Created attachment 58590 [details]
document with embeddded image with grayscale effect.
Comment 3 Inge Wallin 2012-05-01 00:57:30 UTC
Git commit 67295f608bef848aeadd6572f12a63edb7f6549e by Inge Wallin.
Committed on 01/05/2012 at 02:56.
Pushed by ingwa into branch 'master'.

Fix image effects 'grayscale' and 'mono'.

The original author had forgotten to take the alpha channel into account.

M  +20   -10   plugins/pictureshape/filters/GreyscaleFilterEffect.cpp
M  +3    -2    plugins/pictureshape/filters/MonoFilterEffect.cpp

http://commits.kde.org/calligra/67295f608bef848aeadd6572f12a63edb7f6549e
Comment 4 Inge Wallin 2012-05-25 00:09:33 UTC
Git commit f74271802d7b365e2b4eb10651eac2a26f9abf8b by Inge Wallin.
Committed on 01/05/2012 at 02:56.
Pushed by ingwa into branch 'calligra/2.4'.

Fix image effects 'grayscale' and 'mono'.

The original author had forgotten to take the alpha channel into account.

M  +20   -10   plugins/pictureshape/GreyscaleFilterEffect.cpp
M  +3    -2    plugins/pictureshape/MonoFilterEffect.cpp

http://commits.kde.org/calligra/f74271802d7b365e2b4eb10651eac2a26f9abf8b
Comment 5 swathi 2012-10-23 07:50:20 UTC
Verified in git commit ad0416095c417a8cfa55306ea8959ac0ef4460bb.